Elite Direto Not Changing Resistance


(Anthony Von Barron) #22

Folks - today I booted up in a different sequence and it all worked. Trainer first, connects to laptop via ant+. Variable resistance works. Then companion app on phone with bluetooth connecting to bluetooth hrm. On settings screen then connect to hrm. All worked for me in this sequence both last night and today for the whole ride.

I had previously been waking up the trainer last as I didn’t want my hrm to connect to it. I think this is not an issue as you have to manually connect the Elite Direto to the hrm via their app.

I’m not saying this is the solution, only that it’s the only thing I have changed and it seems to work.


(Esa Heinonen) #23

I have proplems Direto also. Last night I rode New York route and first doing my own 4x4min test. ERG mode didn’t working and after that rode normal whitout ERG mode, so resistant didn’t work, only speed chance. This have been situasion after last update. I even calibrate Direto and thingten belt at -0. I have ant+ Windows 10. Hope you fix this soon. I bought Direto just one month ago (old was Elite turbo muin) cause I want to ride Zwift resistant/ERG mode. Well It was working twice and then came this update :slight_smile: .


(Luc Heijnen) #24

Have you tried unpairing the Direto? Unpair, new search for power meter and pair again… Works for me after an update!


(Esa Heinonen) #25

Yes I have tried, many times but It not help.I downloud Zwift program again but it not help.


(Peter Castrop) #26

Nothing helps. I have this issue now for two months but Zwift tells me that unfortunately they don’t have a progress update. And they are so sorry. Well, so am I. Instead I do get spooky Halloween stuff. Who cares? I just want Zwift to work as it should and what I pay for.


(Josh Y) #27

I am having the same problem as well. I’ve pretty much tried all of the troubleshooting techniques and no dice.


(John Van Vliet) #28

I am having the same problem. My setup is:

  • Apple TV
  • Elite Direto and Wahoo Tickr connected with Bluetooth
  • Not using Zwift Companion

It seemed to work on my first quick test ride but not on the second ride. I ran the Elite training app between sessions so maybe it is still holding a connection somehow? I haven’t tried rebooting yet.


(Jonathan Francis) #29

Same issue here. The ATV sees the unit fine. The Direto will recover if you unplug / plug back in. Seems like an Elite issue. I think the unit is sensitive to being connected to only one device,so put your phone down.

I’m also having problems with the base/minimum resistance on a flat. Despite the unit being calibrated and tire size set, I’m running out of gear on my 42t 1x setup. It’d be nice to able to add more minimum resistance.


(Vincent W.) #30

@Jonathan_Francis and @JohnV2 We may have made a breakthrough with BLE resistance issues that should affect the Direto as well once a hotfix is implemented:


(Brian Muir (RACC)) #31

I have just taken delivery of a new Elite Direto and trying to interact with Zwift through Ant+ on my laptop but I get no resistance on climbs whatsoever. I have logged on and off, restarted and so and gave up at the 4th attempt. So to test the feature of my trainer I installed the My Etraining app by Elite, created a short point to point course, and yes it works on that. Even the smallest changes in gradient are noticeable and you can actually hear the trainer changing resistance. Unless I can resolve this I may be cancelling my Zwift membership and moving onto another platform. I’d rather not but that is why I paid good money for this trainer!


(Steven Gilbert (PACK)) #32

Check that when you pair the controllable trainer in Zwift that is it pairing as the “FE-C” option, rather than the other option (can’t remember what it’s called right now, but it’s something else). I found that if you start Zwift first and then only wake your trainer up by pedalling once on the pairing screen, by default it pairs as the wrong option. I found that pedalling and waking the trainer up before I start Zwift ensures it pairs as the controllable FE-C option (but still worth checking).


(Brian Muir (RACC)) #33

FEC is selected but my ride isn’t saved on Zwift, just 0.0 metrics, but the ride ons are. If I use it as a non controllable trainer it records my metrics. Everything is showing on screen when I am actually riding however I also have issue with the power meter as it is way under what it should be, I reckon by more than 25% and the slope gradients are just ridiculous. The first climb on Hilly Route on Watopia feels at least 15 percent or more, small chain ring and low gear. But on the flat it’s way too easy, I could comfortably ride round on the 53 x 12. I have these issues no matter if I coonect via Ant+ on my laptop or Bluetooth on my iPhone app. To muddy the waters even farther as far as Zwift is concerned, yesterday, to try and pinpoint the issue I visited friends who are using the same trainer. I did a test ride on their machine loggged into their iPad and yet Zwift still didn’t record the metrics on my ride!


(Yy Wong) #34

Hi ,

I have same issue for this two days event started with no resistance after 1 hours cycling then then the signal dropped and I need to switch to Bluetooth connection in the midst of event. Even with Bluetooth connection I still never get any resistance .

Please fix or share with us any steps to try out.


(Vincent W.) #35

Hey Yy can you send us a support conversation with your log files for your most recent ride?

Support conversation: https://support.zwift.com/hc/en-us/requests/new
How do I find my log files: https://support.zwift.com/en_us/how-do-i-find-my-log-files-(cycling)-SyTW0JZSX

In the meantime we have a troubleshooting article for ANT + and Bluetooth connection drops that could definitely help!