FIXED: Trainer Resistance Issues (Mainly on iOS Devices)

I have the new Kickr core updated to the latest firmware using the latest Zwift and getting no resistance

KICKR CORE Firmware v1.0.6 - 31 October 2018
Devise running Zwift IOS Latest update 12
Connection BLE
Zwift game version 1.0.31304

I made a few post earlier in the thread about the core loosing resistance and dropping connection when using the Giant ridesense speed and candence sensor , I reftified this by changing the sensor to a Wahoo candence sensor and this seamed to rectify the drop outs whilst riding , but I still lost connection if I stopped for longer than 3 minutes.

I bought a Wahoo Ant+ key and tried to use this with my ipad pro ,it wold connect to my heart rate,candence sensor and Kicker core but not smart trainer so I did not use it as no support for smart trainer,
I decided to try it again with the Ant+ key and connected my heart rate ,candence and Kicker core to Ant+ and smart trainer to bluetooth, this has now been running connected blue flashing bluthooth light for an hour with no drops after 3 minutes, will try a ride this afternoon when I have time

1 Like

Update #2
Thanks to everyone’s help here we’re working well on the investigation. Will update everyone with more detail as soon as possible.

I’m new to Zwift but today I’ve been having a nightmare with my power dropping out to nothing. Heart rate monitor and cadence sensor carried on working throughout, but speed and power just fell off the scale to nothing. Why does this happen? I did a spin down and then a factory spin down, I also tried turning erg mode off and on.

I have a 2017 Kickr which seems to have all its updates in place and I am running zwift on a mid 2010 MacBook Pro, with an ant+ dongle, hrm is Garmin as is cadence sensor. Internet is BT but all seemed to be working fine. Until random power die offs.

Am I just being thick? It all worked fine on Sunday night, in fact it was really good (today was only my third time using zwift and it was glitchy and rubbish, nothing like Saturday and Sunday. Does it make a difference which course I am on? Sunday was a race in watopia - today was New York) any help/advice gratefully received!

Zwift membership - cancelled. Happy trails, guys & gals.

Hey Laura, the two times you rode before the glitchy ride did you also have your HRM and cadence sensor paired?
Also did you happen to pair your Kickr to Wahoo app at all? If so can you unpair from the Wahoo app/forget your Kickr then only pair to Zwift to see if that helps?

Hey all, some good news. After identifying what was common across most of the reports of this issue (using this thread!) we finally today got it to reproduce 100% of the time. Once we had that, we tracked the issue down in about 15 minutes.

It appears that if you let a device go out of range (ie, walk away with your heart rate strap), or let your cadence device go to sleep (ie, don’t pedal for a while), our re-scanning code that starts searching for the missing devices can sometimes conflict with sending commands to the trainer from that point onwards. This would be why it was impossible for us to consistently reproduce, and also why 100,000+ other users were Zwifting happily over bluetooth and reporting no issues.

We’re putting together an update now, and will try to get it submitted to apple in the next 48 hours. From there it can take up to a week to get approved by Apple - so in the meantime, the workaround would be to pair up your devices only once you’re ready to ride. Sorry for the inconvenience, but it was really due to the posts here that we were finally able to track such a very specific bug down.

It could be possible the bug could also happen ‘organically’ mid-ride if a device drops out for a long enough time, and that case too is probably handled with this fix although we’ve not fully verified that case yet.

(NOTE, another case that could cause sim/erg not to work is by performing a spindown, but cancelling it without making it through to success. This too will be fixed in the update).


Thank you for directly chiming in w/an update. :+1:

Thanks for the update @Jon I think mine is must be due to it rescanning organically as I only start Zwift on the tv once I’m fully ready and on the bike. Hopefully the fix will cure this too.

Thanks for the update and that makes a bit of sense. I originally thought it was just the Bluetooth combo speed / cadence sensor, however today when I was riding, I got interrupted and left it idle and walked away (wearing my BT HRM) and when I returned the connection dropped out.

Hopefully the fix is approved quickly and we all live happily ever after

Hi Jon
Thanks for the update. Your summary of the root cause is consistent with what I’ve been reporting to Zwift for months, and speculating as a theory. Can you confirm whether this is a regression, as this seems to be something that changed late June, or around the time of Innsbruck?

I am reluctant to criticise - I work in a similar domain - so I understand how the process of triage works, and the necessity of reproducibility of issues, but it is disappointing for it to take this long to get to fix. Despite my repeated offers to help, I was met with silence. Providing a debug build to a tiny set of trusted savvy customers (under NDA) could have solved this months back. I urge you to consider this approach in future.

Looking forward to getting Zwift back working properly again.


Hi Kevin, indeed it was a regression around the time of Innsbruck. The issue at play here is really our companies growth. I can no longer read forums as often as I like (nor can the rest of the developers), so some information doesn’t end up getting to the right people as quickly as it used to. In this case, you tagged me and it was the first time I’d personally seen this treasure trove of info. It is embarrassing (and something we will address), but true. This thread really was the final key we needed to unlock the mystery of this seemingly impossible to reproduce bug.

Now we will spend the next day or two vetting the fix and seeing if it addresses the less clear cut cases that some Zwifters in this thread came across.


@Jon thanks for the heads up on the workaround. We are are however consistently getting no ‘ERG’ when joining a group workout event directly from a freeride (warmup) on TvOS. This can be remedied by a workaround, ‘ensuring you exit zwift and restart zwift and join the workout directly in pen without turning the pedals’. Not sure if this issue is related/same.


Thanks @Jon for the update. Posts like that are sincerely appreciated. Glad to hear it was a regression as that certainly fits the timelines too. In my case, the issues have never been whilst leaving the room, but could potentially be drop-outs. Fingers crossed the fix clears things up. Either way…thanks for the update.

1 Like

Will this update happen automatically or will we have to delete and reload the app from the Apple Store

It’ll be automatic, as usual

it depends on your AppleTV settings. I always find its best to check App store and apply update before launching zwift once its available. I’ve been caught out many times with AppleTV not updating automatically.

Well, I did as suggested …Unpaired devices, log out …blah blah blah…in order …

Logged back in launched reconnected…same thing 0 to + or -1 felt like 0 to + or - 5…

Original post # 55 above…

BTW never left the bike, always within 4’ of my computer…never paused connections.

Would it be possible to let us know when this has gone through QA successfully and been sent to Apple? I assume you send iOS and tvOS versions simultaneously?

Same issue. no resistance changes during a ride, ATV, tried various models of KICKR. No other devices connected except the KICKR

Please fix, it’s killing the Zwift experience!