Direto not providing resistance

I have direto over a year withou trouble. On 16th did Zwift race was fine. Now for last 4 days resistance is off. Up hills has resistance but feels too easy for gear I’m in. In flats very light despite being in 50/11. Downhill basically nonexistent. When I join a race resistance drops drops in starting pen and faster I pedal more it drops so I’ll be spinning 50/11 at 110 rpm for like 60 watts. I use Apple TV

I’ve tried reinstalling Zwift
Two Apple TVs
Unplugging direto.
Turning off all Bluetooth devices in house
Putting Apple TV within 2 feet of direto.
Recalibrating direto
Taking apart direto to examine belt
Adjusting trainer difficulty setting
Adjusting wheel circumference in MyETraining app

MyETraining app can control direto resistance fine over Bluetooth and my wahoo can control over ant+

Anyone have any suggestions or similar problem? I don’t know if it’s trainer or Zwift that’s problem

When you turn on Direto, do you hear the work of the stepper motor bzzzzzz, bzzzz? Complete the MyTraining task. Is there any resistance?

Hi, this is interesting to see as I have a very similar experience since a few days… not with a Direto but also Elite (Real Turbo Muin), admittedly not a new model but worked fine so far…
I did TdZ stage 6 on Sunday and it still fealt ok, then on Tuesday (jan 22j for stage 7 I suddenly had the impression that climbing was too easy for the gear, but on the other hand flats and downhill fealt quite hard, as if the trainer difficulty was down, but I checked and it.s not changed…

Yesterday it was still the same experience, riding up the epic kom fealt like on a basic trainer, i mean resistance hardly changing according to landscape, but about the same throughout…
I did change the zwift bike to a Trek Madone before the Tuesday ride, can it be related to that?
Appreciate any ideas what could be wrong or changed, thanks!

The erg workout mode seems to work in Zwift. Also, step mode from MyETraining via Bluetooth and on my wahoo elemnt via ant+ are working.

I’ve contacted Zwift twice without response thus far. Elite customer service replying with a suggestion I have already stated in ticket didn’t work they seem worthless.

I was able to fix it, it’s the „wrong“ Elite trainer pairing… see this post here:

After selecting the „proper“ trainer, it feels much better again, hope it works for you too!

1 Like

Unfortunately under iOS for Apple TV there is only on pairing option and it’s Bluetooth not ant+ so this solution doesn’t seem to work

Hey Nicholas, I replied to your support conversation :slight_smile:

Hey! Just checking if you got this fixed? Mine is doing something very similar suddenly, sometime in the last week.

I did. I used my wahoo elemnt head unit to control trainer over ant +. I had all other devices off. Then I simply switched out of control mode to read ant + broadcast only mode, then turned off head unit, restarted everything and trainer with Apple TV via Bluetooth worked again. This seems to have reset the trainer to allow it to work with Bluetooth.

1 Like

@Nicholas_Schneider_w I have this issue when sprinting only on the flat. works fine when you go up a hill. Can you give a step by step guide how you reset it? an can you confirm if its something you have had to keep doing or is your direto now working well? I have a wahoo bolt so i should be able to do what your asking?

kind regards
Chris

I found that if my wahoo bolt was set to trainer control mode at any point it kind of switched off zwift’s ability to control the trainer. I think it’s an issue with ant+ overriding Bluetooth control. I would recommend turning everything off that might connect to your direto. No WiFi or ant+ connections. Power on direto. Power on bolt. Change bolt to trainer control mode over ant+. Do some pedaling adjusting the resistance with the bolt. Once it’s clear that is working, turn the trainer control on bolt off and onto output only mode. Power off bolt. Unplug direto. Then power on direto and try to connect to zwift. This worked for me.

Also, I wasn’t getting any trainer control in zwift when I was having problem. I could only get like 150 watts resistance no matter how hard I petalled or what terain was like. You might just need to adjust trainer resistance in zwift if hills seem fine but flats seem too easy.

Hi

I font actually use my bolt while zwifting but will definetly try this. Il let you know how i get on.

Many thanks

Its on 100% and cant sprint

similar issue here: no resistance on flat.
I see there’s plenty of post. Anyone with the final solution?

tried your way, full of hope… nothing changed! :frowning:
but thank for your detailed info. i guess it works for others

Did you try this in free ride mode?

What bike and gearing are you using? (Road or MTB)

what power can you produce on a climb?

the free ride mode is exactly the issue, whereas workout ERG mode is ok.
i use a standard carbonframe road bike, ultegra 11v groupset
climb is very hard and i can push all-out power

I can put out over 1000 watts when i have resistance max 1044 watts on 4% climb all be for short period. However on apple tv over bluetooth if i try and hold 250 watts on 0% whilst in the 52/11 i simply cant. i just spin even worse if i try sprint. really annoying when other have no issues on the kickr etc. my direto works normally on level mote in the app etc and works fine when over 1% on zwift. surely this most be zwift software not communicating correctly at 0% or when the power is applied on the flat. in real life if i tried sprinting in the 52/11 i would not be able to hold 120-150rpm. more like 85-95 going flatout. this is what really annoys me as zwift or elite can help regardless of the countless forums/facebook users reporting issues. Should of bought a kickr :frowning: Also i would have to buy a laptop to confimr if it works okay on ant + FEC but why should it not work across all the platforms and connections they advertise. Aghhhh

flat races are pointless for me. If its yorkshire at least i have a chance it just hurts like ■■■■.