Zwift not controlling resistance of Elite Direto


(David Whelan) #1

I’ve been using Zwift for about a month now, along with a Direto trainer, running Zwift on a Mac, and connecting via Bluetooth through ZCA on an iPhone. 

In order for Zwift to control my trainer resistance (e.g. to simulate slopes), I must always “reset” the Direto by plugging it out, then back in, before starting Zwift/ZCA. If I do not “reset” the trainer in this way, Zwift/ZCA will connect successfully to the trainer, but will not control the resistance of the Direto. 

The most frustrating problem occurs when I’m in the middle of a ride and Zwift loses connection with my Direto (this can happen, for example, if my WiFi connection with my iPhone momentarily drops, or if ZCA loses its BLE connections - which happens sometimes) - when Zwift/ZCA regains the connection to the Direto, it is not able to control resistance of the Direto, and I need to both “reset” the Direto by plugging it out, then back in, and also restart Zwift/ZCA. This is frustrating, as I need to abandon a workout or ride, and then restart.

Note: I’ve confirmed that Zwift/ZCA is connecting to the Direto as a controllable trainer in all instances. 

This does not happen with the Elite My-E-Training App, hence this problem is in the interaction between the Direto trainer, and Zwift/ZCA software. The challenge when it comes to problems like this is the trainer manufacturer says its a problem with the training software, and the training software company says its a problem with the trainer - making it hard to find a resolution.

I’m posting this here to see if anyone can provide recommendations to fix this. Would appreciate any help. Cheers, Dave.


(Paul Graham) #2

Hi David

Going the ANT+ route will lessen your problems. You’ll need an ANT+ dongle for your Mac but definitely wort the investment.

I use ANT+ and while I still get drops they are less than Bluetooth and the re-connection is way more reliable.

As an aside, have you run your Zwift log through Zwiftalizer.com, see if anything can be spotted there?


(David Whelan) #3

Yep - ANT+ is a possible solution - assuming the Direto/Zwift interact better together on ANT+ than they do on BLE.  

My most recent drop was due to my iPhone (running ZCA) losing its wifi connection. When it regained its wifi connection, Zwift indicated it had successfully reconnected to the Direto as a controllable trainer, but the power reading on Zwift was fixed at ~160W (regardless of how hard I was pedaling), and the trainer resistance was not changing. 

When I look at the log file, there is a difference in the reported BLE connections between when the Direto was connected successfully, and when it wasn’t… but I’m still left with the question as to why Zwift cannot successfully reconnect to the Direto after a disconnection…


(Joe Daknis) #4

My setup: I have a Direto, Wahoo Tickr HRM, and a Garmin cadence sensor (the magnet-free type that mounts to a crankarm with rubber bands).  All of it is connected via ANT+ using a Suunto dongle and a 10 ft USB extension.  I run Zwift on a pretty basic Lenovo laptop w/ Windows 8 connected to my home wifi.

No issues with signal drops, and the Direto resistance/control has been *flawless* since I bought the trainer a few months ago - with ONE notable exception:

You cannot launch the Elite ‘myETraining’ app (e.g. on an iPhone) and perform a spindown calibration *while also* connected to Zwift.  If you do this, Zwift will immediately stop controlling the resistance and won’t properly simulate changes in grade, etc. Basically, ANT+ control is disabled when the phone app establishes a Bluetooth connection with the trainer and ANT+ won’t ‘reconnect’ unless you cycle power on the trainer and restart Zwift.

This is the only issue I’ve had w/ the Direto, and it’s a simple one to avoid.  Just have to calibrate BEFORE I launch Zwift on my PC (or… don’t bother, since it’s been rock-solid from day 1 anyway).

 

[edit: Correction! I did another calibration yesterday before running Zwift and still encountered the same problem afterward. So - it seems that *something* happens whenever the Elite trainer app is used that prevents Zwift from controlling resistance on the Direto unless the trainer is rebooted.  After I cycled power on and off on the trainer, everything was back to normal.]

 


(Alberto Funaioli) #5

I have the same issue. IPad 5th generation, iOS 11.4.1, Elite Direto. Everything has been flawless since I bought my Direto last April. Since I updated to the latest version of Zwift (Innsbruck) Zwift started losing control of the resistance in the middle of the ride. No issues with the Elite MyTraining app. Definitely something is wrong with Zwift, please look into this and fix it!