No Resistance with Elite Direto & Zwift


For a number of weeks now, I am not getting any resistance with my Elite Direto / Zwift set-up. I have used both Ant+ and Bluetooth using the FEC setting with no success and its driving me nuts. I am running Zwift on a laptop running Windows 10 and the whole set-up worked successfully up until fairly recently.

Does anyone have any ideas or has seen this issue before?


Hi @Alastair_Knockton:

Did you try the Direto with the Elite software to test if it is not the unit?

Hi Gerrie,

Thank-you for the reply. I tested the software again and the Bluetooth seems to be working the resistance now but not the Ant+. No problem as I am ok using Bluetooth.



If you’d like to switch back to ANT+ at some point down the road, please ensure Bluetooth is disabled from your Windows Control Panel before pairing to Zwift. While the two protocols shouldn’t interfere with each other, I’ve noticed that while communicating over ANT+ FE-C, if there are strong Bluetooth connections in the area or a Bluetooth receiver periodically scanning for new devices, that can cause dropout over ANT+ and generally, when dropout occurs, resistance ends up noticeably affected.

Hi David,

Great and thank you for the reply. It makes sense and I will try this and let you know how I get on.



I had the same thing happen (also with Win 10), but it was because Zwift connected automatically to the non-FEC flavor of ANT+, which doesn’t transmit resistance data. I had connected it with FEC with no problems and it connected automatically for several rides, but at one point it inexplicably defaulted to non-FEC. I reconnected it manually and solved the problem. I double-check every time now. All I can offer is that make sure that you REALLY ARE connected via FEC.

1 Like