Elite Direto X - ANT Controllable



I know a number of variations of a broadly similar issue keep cropping up but I’m really struggling to find the right answer.

I purchased the elite direto X recently, plugged it in and it worked a treat. Until, I joined group rides! During group rides it would either cut out between the lobby and the event, or after 30 minutes. Very frustrating.

In response I got myself an ANT dongle - plugged it in and it seemed fine until I noticed that there was no resistance. All elements are connected to the FE-C option, but I can no longer hear the humming sound that I hear on Bluetooth, assuming this is the controllable feature applying and removing resistance.

I tried to calibrate in the spindown feature on the zwift app 12 times, no luck. I then used the native elite app to do it, it worked. The resistance then worked on zwift briefly (5 mins). I logged off and when I came back to it the next morning - exactly the same problem.

Do I need to calibrate through the elite app every time I want to ride? I’m using Bluetooth for now, but that means no group rides.

I’m really running out of options. I’ve only had it for 2 weeks so hoping for a response so I can get a refund within the 30 days since purchase. I’m really disappointed - I saved up for a long time to buy the kit.

My current setup:

  • Elite Direto X
  • Laptop - Lenovo (2014), running windows 10
  • zwift companion running on iPhone 11
  • Apple Watch connecting to the zwift companion

Thanks in advance!

Did you pair it as power AND Controllable. Also use the ANT+ FE-C option

How to pair your smart trainer



Thanks for your response. Yep, all are connected to the FE-C option.

I have a Direto X and it’s been controllable for me using both Bluetooth and ANT+ (using a 2010 iMac running OSX Sierra). I ride 4-5x a week on Zwift and calibrate the trainer once a month or thereabouts using the Elite App.

How close is the ANT+ dongle to the trainer? Have you tried a different ANT+ stick (as the trainer appears to be OK in BT)? Also have you tried an external BT dongle?