Hard resistance at beginning of activities

Hey all,

I have an issue which began in November 2021 (I don’t know exactly when), which results in the start of any cycling activity I do in Zwift being super difficult to spin the pedals.

I’m using an Eltie Direto XR trainer which has previously worked fine since Sept 2020.

I’ve had a ticket open with Elite, but as the issue is only in Zwift (either through the mobile app or through the app on my Apple TV) and it works fine using the Elite E-Training App, I’m here for help.

So far I have tried the usual re-calibrations, I’ve tried not pedalling when loading Zwift, and also pedalling before Zwift loads, or only start pedalling when I’m at the screen to select my workout/ ride.

Nothing appears to make any difference, and I’m at my wits end (although using a 12-25 on a compact chainset means my legs get a good burn going for the first 2 minutes or so of cycling!).

The resistance is fine when Zwift loads, but as soon as I hit that screen to pair my devices, or select a ride, the resistance ramps up. Within a minute or so ofriding it then backs off to it’s usual levels.

Hi @K_ingOfMoll_BSCC, when you first drop into a route in Zwift what size cassette and chainring are you starting on and are you starting a route from the beginning or are you dropping in on another rider mid route. Most routes have relatively flat starting points to make getting started easier but if you’re in a higher gearing it could still be difficult to turn the pedals and get the flywheel started once the simulated road resistance kicks in. I’m also curious if you’re experiencing this in structured workouts or just in free ride.

Hey Lucas,

I run a compact chainset with a 12-25 at the back.
I always start my rides in the little ring up front, and the largest cog at the back (so my easiest gear), so my legs can warm up.

I don’t use the workouts but on any free ride I start at the beginning of a ride solo (so no dropping in and joining another ride). As you say, most starts are flat or relatively flat, but the resistance tends to increase when I’m at the screen choosing a route and regardless of what route I choose (even if it starts downhill), I may have to get out of the saddle just to put enough power down to turn the pedals.

You can hear it in the trainer too, as the brake is applied to mimic a steep gradient (I’d say 15%).

I also always start pedalling as I’ve fired up the trainer, and before I’ve even fired up Zwift. I’ll keep this up constantly too as I go through the pairing screen and route choice screen.

Interestingly tonight though, I decided to do stage 6 of TDZ. I wanted to warm-up so chose a route in Paris and whilst I was at the route-choice screen the resistance increased.
However; this time it backed off to where it should have been as the route started!
I thought it was pure luck, so ended the ride after a minute and tried again and everything seemed ok.

I’ll keep testing, but this is the first time it has behaved normally in about 3 months!

Sounds like you’re doing everything right. I took a peek at your account and I’m not seeing any unusual SIM or ERG commands that I might expect to cause unusual resistance. It does look like your firmware might be out of date but it’s hard to be certain since Elite doesn’t publish their current firmware numbers so you might want to try the Upgrado app to see if it helps.

One other thing you could test would be to create a custom workout with a short warmup and then a “free ride” block, this free ride block will be neutral resistance which is what you should feel while pedaling before dropping in on a route. That block should feel close to 0% incline so if it doesn’t it gives us a good place to look.

Something is definitely wrong there. I have an XR too (well, XR-T, but they’re identical). In the pairing process my resistance ramps up too, but only for around 2 seconds and then it goes back to normal. I’m using Bluetooth on Apple TV.

So did Elite talk you through riding in myETraining and manually increasing resistance, and that worked ok?

It sounds like there’s something wrong with your trainer to me, because otherwise there would be lots of XR owners reporting the same problem.

Yes as previously mentioned elite talked me thru using their app and it worked fine all through the different levels of resistance.

As the issue is only with zwift and is replicated of both the mobile app and Apple TV app I’d suggest it’s more likely a problem with zwift communicating with the trainer.

This morning I’ve just hopped on for a quick recovery ride and it’s back to its old tricks.
Fan flats on Richmond starting at 4% gradient feels like a much higher resistance.

Of course troubleshooting can be tricky, but just because it’s ok in myETraining doesn’t necessarily mean that the problem is in Zwift. It could be that myETraining doesn’t send the right sequence of commands (or even the timing of the same commands could be different) to reproduce this error as Zwift does.

If it was a general Zwift problem with this model of trainer then loads of people would be reporting it, because that’s a popular trainer.

I’ve got the same trainer as you, and I’m also using Apple TV with Bluetooth, and as I said I get this for literally around 2 seconds in the Pairing screen and then it’s fine.

Sorry, I know it must be frustrating bouncing between Zwift support and Elite support.

I found a topic from August on this very forum, but I can’t add links to my post.
Post 554081

I don’t mind working with Zwift support or Elite, but yes it’s frustrating trying to find the issue whilst in the meantime I can’t warm up properly or enjoy the Zwift experience I used to either because of my trainer, or because of a communication issue.

It’s worked fine for 16 months of ownership (probably only about 9 months of usage in that time) and is now out of warranty.

My 2ct to this would direct to this thread as root cause…

I really doubt it, because as I said no-one else has been reporting this with the Direto.

What is the title of that thread? I am having trouble finding it.

It’s “Resistance Super hard at start of workout”

It was posted Aug 2021

1 Like

Seems that problem went away for them by simply pedalling as the workout is loading? So that doesn’t sound the same as your problem to me, since you said that the problem stays there as you’re pedalling.

So still this sounds like it’s just you right now which, whilst very frustrating for you, would imply it’s not likely to be a general problem with Zwift and this model of trainer.

Sounds like I need to go back to Elite then.

Are you Zwift tech support Steve?

No, not at all. Zwift Support have that fact clearly labelled against their forum names. But the majority of the support given here on the forums is by the Zwift community, i.e. regular Zwifters.

I’m just a Zwifter like you, with the same trainer and also an Apple TV. Though I do follow the forums so I’d like to think that I have a general idea of what sort of issues are getting raised by people here, and being a Direto XR user too I’d also like to think that I’d especially notice issues being raised on that same trainer. There are quite a few very knowledgeable Zwifters here on the forums, so it’s a good place to ask for help.

You can still raise a support ticket with Zwift to get them involved (assuming they don’t join in on this thread in the week).

1 Like

Steve seems to be pretty much on the same track I was looking at. I don’t see anything obviously out of place in the server logs, it doesn’t sound like you’re doing anything incorrect, and systemic issues of this nature tend to generate a lot of chatter. Since you mention that the resistance increases while in the menus but then gradually corrects once you’re on the road it might be worth trying to open your pairing menu when you’re on the road, my best guess at the moment is that in the period of time between pairing and Zwift sending resistance instructions the trainer is doing something unusual. If this is the case then it might be worth opening the paring menu after you’re on the road, unpairing the trainer, and repairing the trainer to see if it helps as a potential workaround to reset the trainer resistance and quickly get you back to the road.

If you want to to open a support request at Contact Us - Official Zwift Support | Zwift we can generally provide more in depth support through emails. I’d just recommend including a link to this thread to reduce how much information needs repeated.

1 Like

Just to update this thread, as it’s been a little while.

I’ve spent the last few weeks going back and forth with both Zwift support and Elite, and it has been incredibly frustrating with neither party able to provide a clear-cut answer as to who or what may be at fault. Elite in fact just kept re-iterating that once there was no issue with using the trainer on their “My E-training” app, that the trainer was not at fault and I had to chase them for help again.

I had to take the initiative this week and decide to do my own testing and actually took my turbo and bike to a friend’s house to try and get to the bottom of it.
I couldn’t take my Apple TV setup of course, but did take my mobile (as I had the same issue using Zwift on my phone as well), so felt confident that was acceptable.

My friend uses a Mac and the plan was to try my bike and turbo, with their Mac using my login.
Then try my login again, but this time with their Elite Direto turbo (the slightly older Direto-X model).

We didn’t infact get that far, as my turbo worked straight away. It actually worked every time on both devices, without any issue.
Ergo, the problem is not the trainer!
I took it all home, and the problem reappeared. So tomorrow I shall be doing more testing as I can only assume either it’s power related (a dodgy socket perhaps), or electronic interference.

Nothing has changed in my garage setup since this time last year, and the problem started in November 2021 so I’m hoping it’s either a Bluetooth device has updated and is causing the interference issue, or my neighbours have purchased something that is causing electronic interference (I sincerely doubt, and hope this is not the case!).

I am using a Saris H3 and I notice something very similar everytime I am loading zwift - not sure why it does it, but after pairing sensor screen, it goes to menu/route-selection screen on my windows app version. usually I am spinning pedals in that screen to warmup me and trainer a bit before starting activity. At some point during the menu the resistance steps instantly to very high. Like spinning at 80-130watts… to instant 220+ not pleasant when you are trying to navigate menus or have an easy warmup. Not sure why it does it or what it is supposed to do in those screens, but my assumption would be that it would pretty much freewheel almost or ERG of a low watt.

Well, I believe I have pinpointed the issue - it’s the Apple TV I have.

The issue I had with it acting up on my phone must’ve been a 1-off, as it worked fine today again at home.
I tried plugging the trainer into a completely different socket, and tested it using my phone, and an iPad and everything worked great!

I then tried the Apple TV again, and had the same issue. So can only assume there is a problem with the Bluetooth on the Apple TV perhaps?
Are there any known issues with the Apply TV 4th Gen?

Edit: Found this thread tonight and Omar’s issue is very similar to mine, albeit using ANT:" [Elite Direto XR: Resistance Issues with Zwift - 552222)"

I did another test tonight and thought I’d cracked it, but it was short lived. I simply didn’t pedal at all until actually in the ride on Zwift (previously I’d be pedalling from before even opening Zwift on the Apple TV).

First route it worked fine, but when I turned everything off and back on again after a few minutes and tried another route it worked for the first 200m or so and then played up for another couple of minutes before catching up with the gradient changes and correct resistance again.

I’ve already told you about my experience with the same trainer. Just to clarify though, your Apple TV has a black Siri remote but isn’t the 4K version?