Current Issues with Elite Direto Trainers

Why would you choose this gear for sprinting (or for anything, really)?

If the interval is too short for the trainer to ramp up enough resistance for you to hit your target wattage, then you probably need to use your big ring.

Direto is rated to deliver a maximum of 1,400W @ 40KPH or 2,200W @ 60KPH.

Looking at your Short Mix data from the 23rd, you hit a max of 888W on the third rep, so… plateauing isn’t really what’s happening.

FWIW, those are only 10 second efforts - and, yeah, it’s well known that Direto (and some others) aren’t great for big jump ERG intervals that short. If you’re working on those regularly, you’re better off using your big ring and switching ERG off.

Not sure how long you have been using zwift? You do need to change gears in zwift as this is how the watts increases. This trainer does take a few seconds to drop wattage so making sure you power over at the end of the section and keep peddling hard into the easy section and let the trainer adjust. If you let off the gas it will be like pedalling in treacle.

Hi all, I’ve currently got an issue with my Elite Direto - everything is connected, bluetooth, Ant etc, all showing as fine on Zwift and then also with the Elite App… however there is absolutely no data transmitting at all between the two. No power, no cadence etc. Very frustrating and can’t work out for the life of me what it is! Obviously tried unplugging etc but just seems very weird after being fine for months on end!

Hi Adam, I suppose the cause is a electronic issue , contact the support Elite.

Hello Friends,
I have a problem with corretly speed measure in my Wahoo Roam. Daily I using Elite Direto. When I using Wahoo to steering Direto, Wahoo shows incorret value of my currently speed.
Example: When I pedaling with speed 30 is okay. But when I increase pedaling Wahoo shows wrongly speed value or nothing shows or shows 2 km/h.

Circumference in My E-Traning I have set 2105 mm
Circumference in Wahoo 0,173 m

I don’t know where is a problem. Guys from Elite and Wahoo don’t know where is a problem.

Do know solution for this issue guys?

Hi @Lukasz_Szymczak.

The Wahoo Roam will not show the same speed as Zwift. The Wahoo Roam only know your wheel speed it does not know if you are going up or down. Zwift use the Power data from your Elite Direto to calculate virtual speed using complex formulas.

Your Wahoo Roam should show the same power values as Zwift. But not speed.

Okay. But I don’t know why when I using Wahoo to steering Direto I have a problem. I understand that it has a different method to calculate speed. But Elite recommendation this formula. Circumference/12,1= Corretly circumference to Wahoo.

Sometimes I want riding without Zwift or Elite App. Only with Wahoo. And I will have a problem with this.

Hi Lukasz,
I’m Gaetano Mercante from Elite R&D. Your assumption is correct. To have the right speed on your device you should set the circumference to 0.173m.
This only in case the computer gets the speed using the Speed&Cadence profile (i.e. it uses the trainer as a Speed&Cadence sensor).
If the Roar connects to the trainer using the ANT+ FE-C or BLE FTMS (as fitness equiment), you should not set the circonference to 0.173m. Just leave your real circumference.

Hi Gaetano,
Thanks for your answer.
Wahoo seems Direto like a sensor FITNESS EQUIPMENT. ANT+ When I changed circumference just like should be -> 2105 mm in Wahoo I had speed above 200 km/h.

Lukasz,
I’d rather suggest to start a training session with my E-training app. That’s because at the beginning of the training, the app sets the correct circumfence into the trainer.
You can also check the speed from the app.
If the my E-training app shows the correct speed, then it’s likely a problem with the Wahoo device, otherwise is something wrong with the trainer. in this case, you’d better contact our support.

Speed in My E-Training is corretly. I wrote do Wahoo support in this issue. If they will not help me I have to exclude speed monitoring on screen of Wahoo and will learn riding with power meter :slightly_smiling_face:

Probably a stupid question, but does this matter even if using a direct drive smart trainer?

Is this problem still happening to those with the first generation Elite Drivo? I’m looking to buy one this week for a great deal of 300$-500$. I’m using an Iphone 8 plus as my source.

I’ve also bought a Direto this week.

Paired the “Controllable trainer: FE-C xxxxxx” with ANT+ dongle to my Windows 10 PC.

First rides I noticed the resistance has not been adjusted. Using the Elite app, you will almost immediately hear the motor adjusting the resistance.

I’ve been fiddling with lots of thing, tried the android app, nothing seems to work.

Searching in the Zwift logs on my windows PC, I noticed lots of these messages:

[8:38:20] FE-C SIM GRADE 0.027

[8:38:20] ANT : AUC message id=64

[8:38:20] ANT : Unknown response

Obvious it’s an ANT+ related problem. But how do I solve it?

I have a Direto X.
If I pair it with Zwift with Controllable “Elite Real Trainer” it doesn’t change restistance.
If I pair it as “Elite FE-C xxxxx” it works fine.

Pair as Powersource als “Elite PWR xxx” oder as “Elite FE-C xxx” don’t matter.

Check the “trianer difficulty” as well.
by default is at 50% but it it’s on off, the trianer won’t change the resistance.

Trainer difficulty is set to max.

Hi,

I have a Direto for a year now. I always used ant+ to communicate with the trainer. I did a training on Thursday (09-01-2020) and everything went great. However, this afternoon (12-01-2020), I am facing an issue similar to Jeroen, the resistance doesn’t change when Zwift increase the power. When I stop pedaling I ear the motor inside the Direto, usually I only ear this sound when I start the trainer. In the log I see a lot of those line:

:23:28] ANT : FET grade set successfully

[16:23:28] ANT : Rx Fail on channel 1

[16:23:29] FE-C SIM GRADE 0.010

[16:23:29] ANT : Rx Fail on channel 1

[16:23:29] NETCLIENT:[INFO] Auxiliary Controller failed to connect to socket: ‘Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.’ (10061)

[16:23:29] ANT : Rx Fail on channel 1

[16:23:29] ANT : Transfer Completed.

I have tried to pair my trainer as suggested by Ben but no luck. I also tried to restart my computer, my Direto no luck either. I also tried to re-calibrate the trainer, but still facing the same issue. I also tried to used Bluetooth communication instead of Ant+, but same issue.

Does any of you have face similar issue recently, and found a solution.

Thanks

Hi,
I have been able to calibrate my trainer through trainer road, pair it with zwift through ant+ and Bluetooth the resistance does not stay consistent, it keep fluctuating with good resistance then poor then it goes really stiff all in a couple of minutes on the same elevation on zwift. what am I doing wrong

Yesterday I was fiddling around a bit and tried several things:
Android phone:

  • myETraining: works, resistance is controlled.
  • Zwift: does not find “controllable device”

Laptop windows 10 with ANT+ dongle:

  • myETraining: does not find trainer
  • zwift: works, but no control of resistance.

Looks like something is “stealing” the ant+ connection. I’ve closed all programs and removed all possible interfering devices. So when testing myETraining windows, I shut my phone down and closed Zwift (also the service) and vice versa. When testing my phone I closed all aps and removed all other devices. But still no controllable device is found within Zwift.