Can't U-Turn [October 2021] [1.18.0]

Just adding my experience in case it helps with a resolution. I was doing hill repeats on the Alpe, so only going part way up, u-turn, down to the bottom, u-turn and head back up again. I was able to U-turn fine, but always only after pressing the button twice. I would press and hold until the progress bar in the button filled, then press again and my avatar would always turn on the second press. I didn’t experience any speed restrictions going down. And using an iPad Pro.

I applaud the Zwift Community working together and sharing information and experiences to deal with unfortunate issues like this one. It certainly sounds like @James_Bridges has a specific workaround above for L’Alpe du Zwift.

At the same time, some in the community are making (perhaps deservedly) cheeky remarks about “U-Turning being disabled as a feature” to fix an exploit, which is not accurate and a misinterpretation of my remarks in the October Update thread.

In an effort to help Zwifters navigate this issue, I would like to share an update of what I know so far.

[Update: My post was intended to provide an update to the issue, information about the issue and a possible workaround. However, it was not coordinated with the internal teams that work together to address and resolve issues. In hindsight, it would have been better for me to leave the communication to those who do this for a living, and to keep my personal theories to myself. Please consider this post as what it really is: the thoughts of a lone developer at Zwift and not an official response or guide from Zwift.]

This issue has been assigned to a team for investigation and resolution. I’m not on that team, so I can’t give more information beyond that, but I’ve passed my findings on to that team, and I’m sharing below what I’ve gleaned from my investigation this past weekend.

Normal U-Turn Behavior:
Whenever a Zwifter performs a U-Turn, the bike must be slowed down to a speed that makes sense. For example, if one were to perform a U-Turn while riding downhill in a tuck at 67 mph, you would not expect to safely complete a U-Turn at that speed. Neither would we, so as part of any U-Turn the bike is slowed down to a more sensible speed of 24 kph (15 mph). Once at a reasonable speed, the U-Turn begins and it completes once the avatar is lined up in the opposite traffic lane with the proper direction/alignment.

Left and Right turns don’t make any sense in the middle of a U-Turn, so intersection decisions are not processed during this action. Likewise, it doesn’t make sense to make a U-Turn in the middle of a U-Turn, so any U-Turn action is ignored until the current U-Turn has completed.

"Stuck" U-Turn Behavior:
The speeds mentioned above may sound familiar to those affected by this issue. This is because after the Zwifter has “actioned” the U-Turn, the bike “max speed limit” has been set to drop to the appropriate speed, but due to new conditions introduced in release 1.18.0, (and in only one verified situation so far – more on that below), the U-Turn does not actually proceed, so we end up stuck in a perpetual condition where the app thinks the Zwifter is in the midst of a U-turn, but other logic does not proceed with the U-Turn. This behavior is completely unintentional, simply a bug, and will be addressed.

Being stuck in a U-Turn also explains all three behaviors (the low max speed, inability to choose routes at intersections, and inability to request a new U-Turn). It’s really just one bug that unfortunately makes a mess of things.

Triggering the Issue:
Now let’s talk about the trigger for this issue. I’ve spent many hours over the weekend trying to reproduce this issue. So far, the only times I have successfully triggered this issue is by attempting a U-turn exactly at the finish line (Arch) when completing a route.

When I time it just right and trigger the issue, I get the exact symptoms and behavior already mentioned. However, if instead, I just wait about 5-10 seconds after completing a route (as I did on other, separate test rides), I find the U-Turn functions normally and there is no issue. This suggests we have a workaround for the issue when completing a route.

Possible Workaround (when completing a route):
When completing a route, I suggest waiting 5-10 seconds after crossing the finish line/arch before attempting a U-Turn.

[Update: It looks like this workaround has, within minutes, been verified as maybe not so helpful. I won’t be able to update this post in the hours ahead (bad planning on my part), so please also look at what others are saying about whether this workaround is helpful or not. On my end, I will try to focus on L’Alpe du Zwift later as I have time.]

Other U-Turn cases:
“But I was just riding around, and only went 1 km before this happened to me.” you may say. I don’t doubt that. But I would ask if this was just after launching the app, or if it was perhaps after performing an earlier activity.

If this issue occurs, it remains active until Zwift is shutdown (desktop) or force-closed (mobile/Apple TV). So if the issue was somehow triggered in a previous activity, the Zwifter may not notice until some point in the next activity.

Cases where U-Turns are intentionally disabled In Zwift
Wait! Are there some cases where Zwift has in fact, intentionally disables U-Turns? Yes. But before you freak out, these cases have been around for more than a year. Let’s look at these cases and Zwift’s reasoning.

During Tutorial – While new Zwifters are in the Riding Basics course, the tutorial calls out landmarks during the ride. This doesn’t work well if a snarky Zwifter immediately performs a U-turn and starts riding in the opposite direction. Also note: new Zwifters can verify for themselves that after completing the Riding Basics course, U-Turn functionality is re-enabled.

During Group Event/Race or Meetup or Mission – I’m not an expert on all of these systems, but from what I’ve gleaned, U-Turning is disabled during some group rides to prevent Zwifters from accidentally performing a U-Turn and breaking from the group. Likewise, I don’t think any racer would appreciate accidentally clicking the U-Turn action on the action bar during a race. After completing said event, U-Turns are once again enabled, which can also be verified by any Zwifter.

I’ve mentioned these just so we don’t waste time/posts dealing with U-Turns that are intentionally disabled/re-enabled by design.

While I have verified the Tutorial behavior working as intended, I have not yet found time to participate in Group Events/Races, Missions or Meetups. It is possible there could be issues with U-Turns remaining disabled after completion, but there is currently no evidence to suggest this.

Even in the cases where U-Turns were mistakenly left disabled after a mission/meetup/group ride/ group race, it would simply mean U-Turns can’t be “actioned” and therefore such a bug still wouldn’t result in getting stuck at the start of a U-Turn like this issue. It would therefore not restrict the ability to turn right or left at intersections or limit the avatar bike speed as described above. This leads me to suggest the main triggering event for this behavior is simply turning around at the arch/finish line when completing a route.

What You Can Do
You can prove me wrong if you like! I simply want to help resolve this issue, and if I’m wrong, I’m happy to hear it. If you can post steps that trigger the issue in other scenarios than I’ve described above, feel free to post them. You can also prove me right, by trying my suggested workaround and see if it helps, and reporting back if it does. You also have my permission to re-post this content in a TL;DR version for those who are not interested in all these cases and details.

More importantly, you hopefully now understand the bizarre behavior (max speed limit, non-working intersections, inability to action a U-Turn) is a bug that causes the avatar to get stuck in a U-Turn, at least one scenario that can cause this issue, what can be done to avoid that scenario, and that Zwift is working on a resolution.

So please digest what I’ve shared, enjoy your activities, and if you encounter the issue, please feel free to continue passing on any helpful information about it for the benefit of Zwift and others in the community.


When I time it just right and trigger the issue, I get the exact symptoms and behavior already mentioned. However, if instead, I just wait about 5-10 seconds after completing a route (as I did on other, separate test rides), I find the U-Turn functions normally and there is no issue. This suggests we have a workaround for the issue when completing a route.

Workaround (when completing a route):
When completing a route, I suggest waiting 5-10 seconds after crossing the finish line/arch before attempting a U-Turn.

Unfortunately the workaround does not appear to be that simple.

I have gone through the finish banner on Road to Sky/Alpe du Zwift twice since the update and hit the issue both times. Neither time did I trigger the U-turn within 5-10 seconds of going through the finish arch at the top.

The last time I reproduced this issue, I hit the flat section after the finish banner at about 1hr 11 mins elapsed time. I did not trigger the U-turn till I was down again around turn 3, at about 1 hr 20 mins elapsed time into the ride.

So I still hit the bug after 9 mins.

Happy to provide logs/screenshots if that helps.

Edit: Screenshot of speed from Strava attached with a silhouette of the Alpe elevation in the background. The finish arch is at the top of the ascent. You can see the point at which the speed starts to flatline at 24kph until the end of the ride - it starts on the downhill segment of the Alpe. So a signifcant time after completing the ascent and going through the finish banner before going round the flat segment at the top and descending again.


Fair points @Marvin_Dorfler, I can readily admit my tests did not involve Alpe du Zwift, and this seems to be a frequently reported case. For the sake of time, I performed my testing on short routes like Watopia’s Volcano Circuit.

Perhaps it would be best to shutdown my suggested workaround until more testing can verify other triggers for the behavior. I have updated my original post.

1 Like

Yeah, it’s not like anybody thinks this is intentional, but with the apparent quality of the Zwift codebase, it is not much of a surprise that doing something about u-turns in one place unexpectedly breaks something else around u-turns in a completely different place and maybe only on some platform and with some specific upgrade path. Good luck debugging this.

1 Like

@Mike.Winfield Thanks for a detailed interim response. This is an sadly somewhat rare example of Zwift engaging in a beneficial way with the community on a bug reported by many.

Too often we feel ignored when there is absolutely zero Zwift response in a lengthy thread with all sorts of details about a bug, and that just increases the frustration felt here by many.

I applaud your engagement here. More of this from Zwift staffers, please! @shooj This is a great example.


Totally agree. Really interesting stuff.

1 Like

Fully agree. More background info also helps us users to reproduce and isolate each bug, especially if it can’t for some reason be reproduced at ZHQ. I guess the number of Zwift users who do or have done this kind of stuff for a living is nontrivial, so engaging the community more in this way as a resource should be helpful for all.

(I somehow feel the need to clarify that my “good luck debugging this” was intended at face value…)


This is a textbook example of productive engagement the community (if I may…) expects from Zwift.

Acknowledge the issue, do not try to sweep it under the carpet, provide detailed cause/effects analysis, keep us in the picture, work (with the community) on workarounds until the issue is fixed.

There will always be bugs (hint: QA…). Interaction and engagement is the sought for ingredient in such cases - something sorely missing.

Good work, @Mike.Winfield, thanks!


Hey @Mike.Winfield
Very nice writeup !
You might pass along to the bug fixers that the routes that end at the top of L’Alpe are unique for the rounda de fortuna at the arch which I suspect complicates the logic enough to require some extra thought and testing effort ( they no doubt know but mentioning this might help )
Thanks again from all of us Zwifters

1 Like

Fully agree !

I don’t think this workaround will work as when I was testing I did a U-turn straight away after starting the Road to the Sky which affectively cancelled the route attempt (route countdown disappeared from the UX). Performed another few U-turns (just to be sure) and headed up the Alpe and back down again. After passing the KOM start point marker I attempted to U-turn several times ( even coming to a full stop and then pedalling again and waiting much several minutes) but wasn’t able to perform a U-turn. :upside_down_face:

nice logic and test - thanks @Duncan_Samwell_Tri-A
I’m thinking that one issue though is that you started a route that ends at the top of the alpe. I’m going to try but I won’t start the road to sky since it ends at the top - I’ll try starting a route that ends someplace else and then break that route and also not include all the elements of any route that ends at the top of the alpe ? what think ?

That will be interesting to see if that works.
After reading @Mike.Winfield’s reply, one thing that might make a difference is that I didn’t completely shut down the application after the first aborted attempt where I completed the Road To The Sky. After riding several kilometers past the KOM Start point and even going past the Mayan bridge junction without trying but failing to U-turn, I ended the ride and started the route again (doing the U-turns to abort the 2nd route attempt). I wonder if I should have completely restarted Zwift instead of just ending the ride and starting a new one.

Michael, Try selecting the Jungle Circuit and manually navigating to the Alpe. You will never complete the route thus nor trigger the bug as long as you are just going up and down the Alpe.

okay - I’m gong to try a variant of @Duncan_Samwell_Tri-A

  1. restart Zwift
  2. choose road to sky
  3. immediately do two U-turns
  4. top off L’Alpe
  5. try a U-turn
  6. reply back to this forum with the results

Thanks @Mike.Winfield for the explanations on probable causes of this new ‘directional’ bug. I have been experiencing issues with the U-turn as well as the Left-Right directions since last week’s update (1.0.85684). I thought I was the only one having those issues but coming here today was reassuring…
Friday, Oct 22, after finishing a group ride in Watopia (because we often want to extend our rides when a group ride finishes…) I just used a Right turn once and it worked, but after this, nothing else worked (no more Left/Right or U-turns) Any attempts were simply ignored (Companion app or keyboard arrows). Sunday, Oct 24, same thing, after finishing a group ride in Makuri Islands, I took a left turn in Village Onsen, and was struck in looping continuously in the village… Could not do Left/Right or U-turns). At least, in the current state of things, If we want to extend our rides after a group ride ends, we are allowed 1 turn, that’s it! Zwifters should choose well where they want to go… :slight_smile:


While I truly applaud @Mike.Winfield providing such a detailed (and completely unexpected) response, I wanted to point out something I found ‘interesting’ in it:

Why is it that Zwift feel it necessary to slow riders down to 24 km/h (15 mph) to make a U-Turn, but find it perfectly acceptable to negotiate the switchbacks coming down the Alpe at 65+ km/h (40+ mph)? :rofl: :rofl: :rofl:



@Nigel_Tufnel, you got me there. I was laughing about this myself today on the way down the Alpe.