Can't U-Turn [October 2021] [1.18.0]

This bug was created by Strava so you can’t pull u-turns after the “local” legend segments and ride them over and over and over and over… :grinning_face_with_smiling_eyes:

Sarcasm doesn’t come across well on the forums…


In the middle of a course. Specifically, ascending the long S curves (Just around the first curve) towards 365 Bridge/Italian Villas junction. After that I was throttled and couldn’t make turns at junctions either.

Honest question, (albeit slightly tangential to the topic in hand, so sorry) does Strava do anything to prevent this sort of thing on real life segments?

I get that Strava probably don’t want to enable a feature and immediately have people posting 4000 reps of feugo sprint within an hour. But this solution seems like it’s being implemented in the wrong place (if Strava don’t want people skewing leaderboards with repeated reps of the same segment, then perhaps they’d be better off sorting out a better method of calculating those leaderboards; one activity will only count once per segment or something) - I don’t see why zwift is putting measures in place to constrain how people wish to spent their time riding on their product, when it’s a third party data (the LL leaderboards) that’s the target for that measure.

No, and why would they. Some Strava segments are lap routes so obviously the idea is that such segments would be done back-to-back. And the maximum number of even the shortest point-to-point segments you can do in an hour is something like 50–70, considering that the segment is at least ~10 seconds at full speed which you can’t achieve because you have to slow down for the turn.

I presume the U-turn bug has something to do with the fix for this one:

  • Fixed an issue which allowed Zwifters to do a quick u-turn on a route and get the achievement for the reverse version of their current route.

The super-tuck up Alpe du Zwift is probably the bug where someone has sprinted flat out then jumped to the pairing screen which allows them to stop turning the pedals while still keeping the previously attained speed. That is cheating! I was surprised by the talk of it and tried that method too on Friday and sure enough, I could go uphill after LAX in Watopia at 43km/h no effort at all. I quickly jumped back out of it because I didn’t want to wreck my ride.

And what of this speed-limit after U-turn bug for people trying to do a vEverest? I’ve heard of heaps of people who abandoned that because of this new “feature”.

It is interesting that Zwift never fails to accurately deduct the monthly charge, despite all these non-stop bugs.


I was riding in Innsbruck. The turnaround button didnt work (not in laptop and on Companion app). After pushing the button I couldn’t ride faster than 23/24 km/hr. Even when I pushed to 350 watt. The speed limits to 24km.

Today, continuing riding after this event (Zwift Power id 2358303), I wanted to do a u-turn mid-climb but it was disabled (no effect at all, either on the App or the game or the keyboard). So I went on up the Ventoux. At the top, on the flat section, my avatar was limited to 24kph max. No way to go above. And, finally, my avatar kept on going into circles at the top of the Ventoux, not taking the route down nor letting me choose at the junction.

Game version: 1.0.85684
Launcher version: 1.0.52

1 Like

Exactly the same experience on completing Ventoux route for me. Just keep circling at the top with no way to get down the mountain. It has been like this for the last three days with no changes.

1 Like

Tested it out this morning before the Dempsey at 7am Pacific. Worked before the event during warm up on the Out&Back course; on the Companion app, the keyboard and the Wahoo Bike right handlebar control. After the event, no worky on anything AND I was limited to 24kph no matter how hard I pedaled. So I ended the ride and restarted the same route, O&B, and everything worked fine. I didn’t have time to ride out to see if it went off later in the ride but apparently it kicks in after some distance.

This bug is probably the most widespread eff-up I’ve seen on Zwift. Can’t imagine how this kind of sh*t gets past QC before dissemination…


Exactly , this is not a bug its actually a feature release that was completely unfit for any purpose wanted or not . (Why are Zwift putting this effect into fixing gamification elements when they entire gamifcation model is completely unfit for anything really ) This calls into question more than just testing being lacking but actually the design and refinement of solutions being implemented .

1 Like

Agreed Mark . Whilst its not as fatal as others the real problem with it is that it was seriously put out as a feature fix. Not only is it arguably tickering with an aspect of Zwift that its broken to the core (gamification) and needs overhauling and not many care if someone gets a route baged or not … its so far from priority . It is a solution that is so unfit for purpose , seriously disabling the ability to U turn is seen as a good approach to this ? then the actual implementation . UX is trash , at the very least you should get some feedback that says " Illegal U turn attempted" or similar .

Give this shocker of an issue , what “plan” are we about to get unleashed to address it … just fixing the speed limit issue but U turning permanently deprecated as a feature … who knows . :man_facepalming: If ever there was a roll back required it is here .


Me too - so much for my Everesting attempt :sob:


I had this issue today. Session was 3 x up the Alpe. Started with Route to the Sky. After descending the Alpe the U-turn function didn’t work.Tried bottom arrow, tried from menu and also tried using the Alpe. All other menu options worked but not u-turn. Ended ride and restarted Route to the Sky. At the beginning of the 2nd ride tested u-turn and was working however, the issue reoccured after the descent. Aborted this ride and atttempted 3rd, tested u-turn at start: working fine. At the bottom of the Alpe, U-turn once again didn’t work. Did a 2 x Alpe last weekend before update and U-turn was working then.
Hope this is fixed before anyone attempts a vEveresting.
Also seperate issue, no interim power-ups given on Alpe ascent (could see power-up countdown on map) but nothing happened when passing the power up points (was on regular road bike not TT).


The power up bug is a joke…are you listening Zwift. It’s been like that FOR YEARS!!!

Hi Shuji. I have experienced this problem today inside the Innsbruck KOM segment, about halfway up the climb. Not sure if that qualifies as close to the banner, but it seemed significant to be inside a segment.

It happened to be right after I passed the volcano circuit banner, so yes. I haven’t made any U-turns since so I have no clue as to how much corelation there is.

You don’t need to be near anything for the u-turns to stop working. Just be some distance into the ride. I’m amazed this hasn’t been rolled back.

I think you CAN vEverest on L’Alpe du Zwift and here is the WORKAROUND I am going to try

Since you can’t do a U-turn after you complete a ROUTE ( the exploit this bug was trying to fix ) then don’t do a route !

Instead start on Serpentine 8 but then manually turn left to the alpe and abandon the Serentine 8 route ( cleverly skipping the segment between the Mayan Bridge road and the alpe road ) and I think you are good to go after that with u-turns-a-plenty ( my new in-game name ! ) even after you pass the arch at the top since you will not have completed a route. Next just roll to the bottom and U-turn back up again 7.54 more times ! You could also do the Jungle Circuit counter clockwise and turn left onto the alpe road.

See the update
Game Update 1.18 - October 20th, 2021

@John_Blumenthal I’m afraid the 1.18.1 patch does not address the “U-Turn” issue. That doesn’t mean there isn’t a plan for resolving this issue …


I think I found a workaround ( see my update below )

Well, I’ve joined the club.

I late joined a timed group ride which ended then joined a 3R race on Sand and Sequoias without restarting Zwift. After the race my speed was limited to 24kmh and u-turns would not work. I continued riding from the race finish line (the sprint line on Fuego Flats) to the old timey train town and continued trying to u-turn with no success (and still speed limited).

Apple iPad, Zwift 1.18.1

1 Like