Can't U-Turn [October 2021] [1.18.0]

Hey @Mike.Winfield - I saw you U-turning atop the alpe earlier today

@Duncan_Samwell_Tri-A - this works >>>

I just tried this vEverest ( 1.5 of 8.54 ascents ) on L’Alpe and it’s a verified U-Turn bug workaround !

  1. start zwift
  2. Choose Watopia
  3. Select Serpentine 8
  4. turn left at first turn ( clockwise jungle circuit )
  5. turn right at second turn ( mayan bridge )
  6. turn left at third turn ( jungle circuit counter-clockwise )
  7. turn right onto L’Alpe
  8. top off the alpe
  9. U-Turn after getting the prize
  10. get to the bottom and U-turn back up

@James_Bridges, when I searched my log for “u-turn”, your nickname showed up! :grinning_face_with_smiling_eyes: (u-turns-a-plenty)

Thanks for the Ride On. Apologies for not responding. My eyes were on the computer more than the world.

@Marvin_Dorfler, I have some questions if you don’t mind.

Was turn 3 the first time you initiated a U-Turn in your session (since launching Zwift)?
Did you ride alone, with a meetup, or a group?
And you chose the Road to Sky route for your ride activity?
What device was Zwift running on? (Windows/Mac/Android/iOS/Apple TV)?

1 Like

Was turn 3 the first time you initiated a U-Turn in your session (since launching Zwift)?
Did you ride alone, with a meetup, or a group?
And you chose the Road to Sky route for your ride activity?
What device was Zwift running on? (Windows/Mac/Android/iOS/Apple TV)?

For both times I encountered this issue the scenario was the same:

The u-turn where I experienced the problem was the first u-turn attempt. This was several minutes after passing through the finish arch for the route (at around turn number 3 for the most recent time it happened).
I was doing an individual workout, riding alone (not a group workout or a meetup)
I had chosen Road to Sky as the route while doing the workout.
Zwift was running on Windows.

If I can help by re-testing a particular scenario I should be able to do that tonight - please feel free to let me know how I can assist.

@Marvin_Dorfler, thanks for the answers. I’d say you’ve given me plenty to work with. When I get time, I’ll try to follow your steps, turning around near turn number 3 (about 9 minutes after the banner).

Please let me know if I’ve got any of this wrong:

  1. Launch Zwift on Windows
  2. Choose Watopia route: “Road to Sky”
  3. Choose to “Free Ride”
  4. Ride the route until reaching the finish arch at the top of the Alpe and note time of crossing
  5. Continue on up and around, circling around the top and then heading back down
  6. About 9 minutes after reaching the arch (and around turn number 3), attempt a U-Turn
  7. Verify if U-Turn succeeds, and if not, if speed is normal or capped at 24 kph while descending

@Mike.Winfield that’s all correct.

Any time after you’ve gone through the arch, circled round the top and are heading back down should be OK to attempt the u-turn.

As you pointed out, a successful repro will be that you see the speed drop to 24kph to initiate the u-turn but it will never complete. Further attempts at u-turns will not be successful.

Great stuff @James_Bridges. Good to know I can do my 4xAdZ session planned for this weekend now :neutral_face:

More fun adventures in u-turns on iPad.

I did a one lap race of the Richmond UCI course today (teleported straight from Watopia to Richmond after logging in, who needs a warm up anyway?). After the race I rode on for maybe another km or two. Certainly past the next turn-off after the finish line. I thought, that’s long enough, and tried a u-turn. No luck. Straight to the 24kmh speed limit.

I quit and saved the ride and Zwift took me back to the login screen so i thought I’d try the Volcano Circuit as Mike from Zwift did. After selecting the route and Watopia loading my avatar did a u-turn immediately. It’s as if my u-turn from the Richmond ride was still valid and straight after starting the Volcano Circuit it completed the u-turn. I did another u-turn to get back on course and rode the Volcano Circuit (there was no progress bar so I assume the u-turn cleared it).

After completing one circuit I continued on past the Italian Village turn-off and tried another u-turn. No luck, straight to 24kmh. Quit and saved the ride and thought I’d try one more ride to make sure that the u-turn being completed after logging in wasn’t just my imagination.

I loaded the Yorkshire UCI course and sure enough, my avatar completed the u-turn I had initiated on Watopia as soon as I started riding, Quit and saved as that was enough silliness for one day.

A couple of interesting points. U-turns being initiated in one ride, failing to complete (speed dropping to 24kmh in preparation for the u-turn but no turn) but being actioned after another ride has been loaded. I was able to complete another u-turn after that initial u-turn after loading. It was only after completing the route that further u-turns were not possible. I didn’t seem to matter how far past the finish banner I was, further u-turns were not possible.

My advice would be, don’t do any u-turns after finishing an event. You will be speed limited to 24kmh. As the bug seems to be persistent if you start another ride I’d also recommend completely shutting down the app and restarting.

I’d also suggest (like James_Bridges has suggested) not completing any sort of route if you are free riding. Start a different route and then get off that course as soon as possible. It seems like completing a route is the cause of the u-turn bug. If you never complete a course you shouldn’t get the bug. This could be tested on the Volcano Circuit by doing the loop counter-clockwise and then trying to u-turn after completing one full counter-clockwise lap, then doing clockwise lap and trying to u-turn again.


I just rode up the alpe du zwift and got to. The top and couldn’t use the button to turn around and on the downhill I couldn’t get past 24kph. Earlier in the ride I did bump into a rider on the climb and my bike almost stopped maybe it started there.

Just after finish banner

1 Like

Well that explains everything - Strava writing Zwift code, that combination will break anything.

Has anyone at Zwift thought about maybe, perhaps just rolling back those changes until they figure out how to make them without turning U-turns into speed limits? It’s not like the entire app was collapsing from some people using U-turns in weird ways.

1 Like

3 more test rides on iPad this morning to follow up from yesterday’s post.

I repeated the Volcano Circuit I did last night, following Mike from Zwift’s instructions. Selected the Volcano Circuit course, finished the route, continued past the Italian Villas turn-off, tried a u-turn and failed with speed limited to 24kmh. Save ride and force quit the app to prevent any carryover of information.

I then did the test I suggested in my previous post. Selected the Volcano Circuit again but turned right off the route at the glass bridge and continued to ride what should be the Volcano Circuit CCW route, once through the start banner and then a full lap after that (even though I rode the route course I doubt Zwift would recognise it as completing a route, it seems Zwift will only recognise that you have completed a route if you have selected to ride that route and not free rode it). I then continued out of the volcano cave and successfully completed a u-turn. I then went back through the banner, did another couple of u-turns and then rode a clockwise lap. Again, a few more successful u-turns. Saved the ride and force quit the app.

The final ride was the Duchy Estate route on Yorkshire. I rode the route and after completing the route I continued all the way around to the 4 way intersection and turned left off the route to head back to the start pens. I tried a u-turn and again, no success and speed limited to 24kmh.

Conclusions: It looks like the only factor is completing the selected route. If you go off route and continue to ride you shouldn’t have any issues with u-turns (my second ride today showed that where I had no issues). As soon as you complete a route (either selected in free ride or after finishing a group ride, workout or race) then you will get the u-turn bug. It doesn’t seem to matter the distance after the end of the route, as soon as you hit u-turn you will be speed limited to 24kmh and unable to finish the u-turn or select any new turns.

This bug seems so easy to reproduce that I am surprised that Mike from Zwift was having problems reproducing the issue. Select a route, ride the route, bug is ready to be triggered any time you do a u-turn after finishing the route. Boosh.

Anyone planning on doing any vEveresting should select the Serpentine or Jungle routes and manually ride the Alpe. This way you will never finish the selected route so you shouldn’t experience the u-turn bug. Selecting the Road to Sky will mean you will complete a route and will get the bug. Of course, you should test this yourself before committing to riding all day.


Please know that this, along with your previous investigations and write-ups are really appreciated. So thorough and crystal clear. Thank you.

1 Like

Same issues for me as well ever since the last update. No u-turn or left-right functionality at any speed.

1 Like

FIX THE U-TURN! Continues to not work. Pressed u-turn. Repeatedly. Nothing. Stopped the program, got out, logged back in and started another ride. What was the first thing it did? U-TURN! Without any input from me!

1 Like

I have experienced the U-turn bug and the No left-right bug yesterday twice.

  1. After finishing a group ride, I continued, No left-right or U-turns possible.
  2. During a solo ride on Innsbruckring route, after completing 1 lap, I continued, got up the Leg Snapper, tried U-turn, did not work, so I continued on the same route at 24 kph and decided to end it there… There was no point in continuing to ride at 24kph without any possibility to go faster…

This did not work

  1. restart Zwift
  2. choose road to sky
  3. immediately do two U-turns
  4. top off L’Alpe
  5. try a U-turn

You can see the descent speed is less than 24kph


Choosing Jungle Circuit or Serpentine 8 and manually navigating to the Alpe will work.
Have seen it work 2x. Taking a group up that way using this method in an hour.

1 Like

Same problem. Is this bug being fixed, Zwift??

I wonder why isn’t an emergency update being pushed?

This is not some obscure bug. This goes to some significant functionality.

1 Like