Can't switch bikes in The Garage [1.25.0] [May 2022] [SOLVED]

Hi everyone,
Impossible to change about bike…a Zwift bike is forced and even after a restart of the game :open_mouth:


I had the same problem. Could only change wheels, but was stuck on the zwift carbon.


I reproducied the bike change problem on Amdroid. Bike appears to change whem I select it in the Garage, but when I exit the Garage my bike goes back to what it was before. The change doesn’t stick.

1 Like

Hi @S_LEGROS @Sigurd_Espeland and @Steve_Hammatt
Thank you for flagging this up. I also was able to reproduce this on Win10.

We’re on it and will update this thread with progress reports.


Same problem for me. Can’t change bike since the update

1 Like

Same here - bike is fixed in the garage to the frame I had before the update. I seem to able able to change wheels, just not the frame.


It seems to get the selected check mark on multiple bikes at the same time. With a bunch of clicking and double clicking I could select only the bike I wanted.


That doesn’t work for me. On my last launch I was stuck on the last frame I selected. After restarting, I’m stuck on Zwift carbon, which I had not selected at any recent time. Clickety click doesn’t seem to help.

It seems to be easier going when going into the garage from the pause menu than from the main menu. You also have to click on the other bike to unselect.


same thing for me. PC on Windows 10. Level 43 and stuck with the Zwift Carbon. At least it isn’t the Buffalo bike.

1 Like

Same for me on Mac, seems to work here and there, but is not working for the most part.

Had this issue on Mac today. Was stuck on the Tron bike so I restarted. It stuck on the Tron bike again, then I restarted and it was stuck on Zwift carbon. Finally on the last restart and a bunch of double clicking, I was able to choose the bike I wanted.

Windows 10 I’m stuck on the aetheos (which is the bike was on prior to the update). I can change wheels but not bikes.

I tried exiting Zwift. Tried from home screen and from in game. Tried to ‘unselect’ bike and re-select.

“My Garage” on the home screen does not work.
“My Garage” on the menu screen works minimally, but it’s not normal.

Maybe the workaround is to use a “drop shop” to change the bike and wheels.

Same for me on iPhone. Stuck on the Tron.

I saw this also on Windows, it works eventually if you click the bike twice before exiting.

In iOS and iPadOS, I can confirm that the change indeed seems to ‘stick’ when clicking twice on the desired bike in the garage.
I notice (in iOS and iPadOS), clicking on a bike in my garage turns the bike background lozenge blue, but clicking a second time makes a green tick appear in the upper left corner of that lozenge. This seems to coincide with the choice sticking (i.e. desirable outcome).
Also noticed that the 3D game audio (e.g. bird calls at the Tempus spawn point) seems to become muted after the first click, and then resumes when the choice is confirmed with the second click. Could be coincidental.

Edit: Also confirmed on Win 10: reliable bike switching with two clicks each time on the desired bike lozenge so that the green tick appears. Changes stick between sessions and changes of platform (i.e. desirable outcome).

Edit #4(!): This two-click workaround consistently works for me in Win 10, iOS and iPadOS if the Garage is accessed via the ‘Paused Menu’ after having already started a ride, i.e. like we always used to. It doesn’t work using the Garage icon in the new UI homescreen.

1 Like

Same issue. Going into the kirchmair races on the stock bike :grimacing:

No joy when you double click on the target bike in your garage?