Can't login to ipad zwift When laptop login is fine. Help?

Hi guys. Whats the fix for this if there is no space in your user or password? Thanks!

1 Like

Hi Victor, I was using the tab button and it wasnt working logging in (didnt think tab would be an issue). Closed the app, used the touch screen features and logged straight in. Hope it worked for you.

1 Like

Vincent - Exact same issue just now on my iPad Pro. Fortunately found this thread and was able to login when not using the TAB key and clicking into the field. Spent over .5 hour troubleshooting. Is this still an open issue from Dec 2018? Did not get a reset password from the iPad, reset password on Win 10 Web Browser while logged in. All super frustrating.

I’m having the same issue. I can login via Macbook Pro just fine but the App on my iPad does not recognize my password. Reinstalling the app doesn’t help.

I have this issue as well. Laptop works, iPad doesn’t. This is since a couple of days and seems to be related to latest software update.

Funny is, that everything works in the morning when there is less load on Zwift. In the afternoon the login doesn’t work anymore. Sometimes I get a message which is: You’re logged in. But there are no roads to ride.

It could also be that Zwift can’t handle the load. Since Corona I saw days with 25.000 people riding and there was traffic like on a high way during rush hour.

My guess it’s an issue with your ISP (German Telekom): Problem with login to Zwift via German Telekom

Thanks Paul. This Telekom Thread is really helpful. It could be very likely that due to Corona internet traffic there are issues in DNS or Routing of involved ISPs like Telekom and AWS or in general between EU and US. I well reply here as soon as there is a solution in place. For now I don’t see that the issue is at Zwift.

Same problem. Can’t log in on iPad. Really poor. Is there a fix for this?

I have the same issue on an 11 inch iPad Pro (2020). Charging my credit card for my Zwift account did work! Very poor.

Who’s going to fix?

I am having the same issue with my Ipad Pro. Login from Malaysia. Anyone can help to advise please.

Make sure there are no extra spaces in the user name or password (don’t use Tab to go from user name to password).

1 Like

Tried that Paul. Still not working. Wonder if it is a network issue?

1 Like

Could be on your end Zwift is reporting no issues: https://status.zwift.com/

Try restarting your modem, router and Zwift device.

2 Likes

I have the same issue. First time user and I can’t login to the app with the password I just created and used flawlessly on the website. I’ve tried everything suggested in this thread, short of restarting my modem and router which, honestly, if that’s the solution, then I’m done with Zwift before I even start. There are other apps out there.

Infuriating!

How do I make the app ask for username/password? I would try the items here, but my app goes straight in, never asking me to input a name or password. Then just say Whoa…

Oops, I’m sorry. You have to do that really intuitive thing called Change User…since, of course, I’m not actually changing user…

Had same issue — FIXED by not using TAB to move between fields on iPad (I was using keyboard to login and hitting TAB to move between email address and password field). Once I used touchscreen to select the password field after typing email, then typing in password it worked just fine. Was driving me crazy for several weeks.

1 Like

I just started having this problem. Using the touchscreen doesn’t help. Also, I can’t see the characters I’m typing until I change fields.

Same problem. Super frustrating and haven’t been able to get it to work on iPad Pro after spending 30 minutes resetting and not tabbing.

Got mine to work by reinstalling app and going through the forgot password routine, then just need to update password on any other devices