Can't log in to iOS App - can anyone help please?

I am having a problem starting my very first Zwift session. I have been a “Zwifter” now for nearly two days but have not been able to use Zwift yet!

The problem I have is that I can’t login to the Zwift app on any of 3 apple devices (iPhone 7plus, iPhone 8, iPad Pro Gen3). All have the latest apple software updates.

I have tried deleting the app and re-installing. I have deleted the cache. I have made sure there is no space at the end of the email address and password. I am not using the TAB key to move between the two.

I have tried on Wi-fi and also over mobile data.

My husband has tried to create himself an account through the app but that does not recognise his email address as being valid (could be the same problem?).

I can log in on the website on my Mac (which is how I created my account).

I can log into the companion app on each of the 3 apple devices listed above.

I have tried through the ambassador chats twice and they have tried to help but have been unsuccessful.

I have made an email request at 10:14 this morning but have still heard nothing back nearly 9.5 hours later (is that normal?).

My free premium account 1 month trial is counting down and I can’t even get into the app!!!

I have the latest version of the app and iOS software.

Any help would be greatly appreciated before I walk away from Zwift forever. This is not the happy, healthy experience that all of the adverts promise!

When you click on the app what specifically happens?

I type in my email address, then my password then get the message “Oops. Wrong email/password. Let’s try this again”.

Have you tried creating an entirely new user with an entirely new email when the app first opens?
Or could it be that your trial has expired?
Make absolute sure that there are no spaces at the beginning or end of your user names or password.
Do not use the tab key to go between user name and password
One more thing to try is “forgot password “ and reset it

Yes, I’ve tried that (through my husband’s email address) but it says at the sign up screen that it is not a real email address.
I have made sure there are no spaces, made sure that I don’t use the TAB and also tried the forgot password all with no success.
I can however login to the companion app and the Zwift website.

Try clearing your cache on the machine where you can’t login.
On your iOS devices under settings> Safari you can clear recent history.

Thanks, but I have done that already as well with no luck.

Only other thing I can offer is to go to the App Store on your iPad/phone and tap on your profile pic in upper right. Click on “purchased” tab and scroll down to Zwift and make sure there is no update pending.
Other than that it may be up to Zwift support to help you or maybe another forum user knows the secret fix.

Thanks Bob, I have just checked that and there is no update pending.

I have had emails into Zwift Support since yesterday with no success. They give similar points to you have but with no success and no way to get back in touch with them to tell them that it hasn’t worked apart from starting the whole “contact us” process again which just doesn’t work.

It seems like something is wrong with the way the login page is seeing what I have typed (all the same details work fine on the companion app, the website, and the app on the Mac).

Thank you for you advice and guidance, but it looks like me and Zwift is just not meant to happen!

One more thing, really reaching here, instead of typing in your email and password what about copy and pasting them from say an email page? Start an email and type in your email and password in the body then copy each one and paste it into your Zwift login.
I know this is a stretch.

Good idea. I have tried it this morning but it also didn’t work. Thanks for everything Bob, you have been far more use than Zwift support!

@Lisa_Davies
I’d suggest you reset your password at my.zwift.com

After you reset it, when you log into the game app - it’s important that you don’t use the Tab key to jump between the username field and the password field. On iOS, tabbing can introduce a blank space that’s not visible, but is counted as a character, and this will mess with your login.

1 Like

Thanks Shuji. I have tried all that but it hasn’t work. It would appear that Tech Support are now looking into it for me. Thanks for your help.