Calibration wrench icon appears then disappears [October 2023]

Hello, When ever I connect my Zwift hub DC6Cthe wrench appears then disappears in less than 2 seconds. I have calibrated in the past without 0 issues but now is not lettting me!! Please help

Hi @Kevin_Lopez, welcome to the forums!

Doesn’t the Hub have autocalibration?

Not sure. I have this a month ago and almost every time I use it I calibrated manually after 10 minutes warm up I make a little sprint and let it spin down

The wrench used to appear. Now appears and seconds afterwards disappear

did you update the firmware recently?

Yes. I have the recent update

I would assume you have the autocalibration then, and maybe that is why the wrench doesn’t appear anymore? I don’t have a Hub, so no idea?

Hope somebody help me then :frowning: I feel that I to put more power now even tho the watts says that I am putting the same effort as usual.

Hi Kevin, I’ve had the same issue! Since I bought the zwift hub over a month ago i used to do a manual calibration every time i launched zwift. Now the wrench disappears after a second or two and calibration isn’t possible. I did contact zwift support but they had no idea what the issue was and asked for a video so they could investigate. Still no closer to sorting the problem. Let me know if you get a fix…

Sorry to hear that from you to Ryan. They contact me and said that the problem is from my Bluetooth. I’ve try change it from a place to another and different devices but nothing fixes it. Let me know is that helped you! I think this problem started since the last update!

HI @Kevin_Lopez @Ryan_Durham welcome to Zwift forums to both of you.

We’re aware of the wrench icon disappearing after a few seconds, and we’re working on fix for that.

In the meantime, your Zwift Hub trainer will autocalibrate as long as the trainer is on firmware version 4.0 or newer, and you’re coasting for at least five seconds from a speed of at least 15 kph / 10 mph. See this Support article for details

Thank you for the info!

My Hub is doing the same thing. I have no spanner icon and the watts are erratic - it doesn’t matter if I use 3s average of instant. The flywheel resistance also feels off

If your Zwift Hub firmware has been updated to version 5.2+, what you’re seeing with the power data flicking quickly is most likely because the Hub trainer is now capable of reporting power data 10x a second (10Hz) instead of the 1Hz it used to. More info about that here

We are aware that the power numbers can flick too quickly for some tastes and are working on that.

1 Like

Thanks, Shuji.

Just ordered the virtual shifting to go along with the 10hz power reporting. :laughing:

Same issue here. I just installed the new Hub today but the wrench icon disappears after 1 second so I have been unable to manually calibrate the new Hub. I’m just hoping it is calibrating automatically, but it is not giving me much confidence when riding.

Same issue, Updated firmware, cannot calibrate. Tried to do a group ride and was in the highest gear and was spinning like I was in small/big. Definitely not calibrated, what is going on?!

Okay, after 2 frustrating hours and no workout I think/hope I figured it out. In settings in the app, scroll all the way to the bottom where it says “Virtual Shifting”, mine was On. Why?! Thanks Zwift, aargh! I switched it to Off and the resistance came back. My time for a workout has evaporated so hopefully tomorrow I can actually ride stage 3 of the Tour of Watopia.

1 Like

I had the same thing last night after updating the firmware! Spinning my highest gear just to keep a steady pace, no way of sprinting as that was useless. Went to calibrate and no icon to do it!

I will try what you have said and hopefully get a more purposeful ride in tonight.

It worked, I just completed stage 3 of the Tour.