Zwift hub calibration freezing mid-process

Hi everyone,

My dad has a zwift hub and is currently having a few calibration issues. The hub is on firmware version 5.2.2 and he’s running the latest zwift game version.

On the pairing screen, he can see the hub is linked-up and the wrench icon is showing. When clicking on the wrench it takes him to the calibration screen, which says ‘waiting for device’, sometimes nothing happens and then some times this stage is quickly skipped taking you to the screen which asks you to pedal at a specific speed. When he’s on this screen the calibration process sometimes freezes at what appears to be a random speed, its different each time. Sometimes this then results in a ‘calibration failed’ message and other times you’re just stuck in the speedo screen and have to back out to the pairing screen. When back on the pairing screen, the wrench icon is gone, but the calibration process hasn’t completed.

Does anyone have any ideas on a remedy for this.


I have the same problem

I have the same problem. But „waiting for device“ is the only screen I can see. I can wait over 1h and there is no new screen.

1 Like

everything is paired, as far as we can tell there is no ‘setup issue’, all devices are paired and selected correctly within the device screen, it seems like it’s something on the software side. I will check to see if pairing via BT or ANT+ makes a difference, but I’m fairly sure we’ve tried these options too and come up with the same outcome

it seems odd that the wrench disappears after the failed calbration attempt, almost as if Zwift/the Hub thinks the calibration completed correctly

I’ve also the same issue with my Zwift Hub. my setup is with an Apple TV. I tried it also with my I pad but still the same issue.

It will auto-calibrate under the right conditions as of firmware 4.x