Calibrating - "Waiting for device"

I can’t get past the screen that says “waiting for device…” I can use Zwift to do a workout butt my computer is stuck indefinitely on a screen that says, waiting for device. I’ve waited as long as 10 minutes without any progress to the next screen.

What’s the make/model of trainer you’re using? If it’s a Zwift Hub then you’ll have to calibrate it in Zwift, but if it’s anything else you should always use the trainer manufacturer’s app to calibrate it.

I have this too. Warmed up Zwift hub with iPad (gen 7 I think)

(Checked: Model: MW6C2B/A (iPad 7th Gen))

I’ve just tried with my iPhone too (iPhone SE). With same result. Both on latest iOS. Game version updated 2 days ago and firmware updated last week too

Same issue here with latest firmware update on zwift hub. Wrench icon appears for a couple of seconds, if I manage to catch it in time I am met with the same screen ‘waiting for device’. If I don’t catch it then the wrench icon disappears altogether!

Tried a ride without calibrating and it was awful. Was in highest gear for most of it, no way of putting more power down as it would just spin out! The only thing I changed from previous ride was updating the firmware.

Is virtual shifting enabled in settings? If so turn it off. If that fixes it then it’s not a calibration problem.

1 Like

i get the same but Zwift has Auto calibration so dont need to do it manually

Thank you. Just tried on my ride this evening and it worked. Not sure why it was set to on but thank you for the advice and saving me hours of frustration!