New guy silly question

I tried using Zwift today for the first time. Unfortunately, I couldn’t figure it out. I got the sensors all hooked up, picked a ride and got to the screen where it said I have 25 km to go. The only problem was, I wasn’t going anywhere. Looked like people were passing me but I was just stuck on the side of the road. I stayed on pedaling for a while in case this was some sort of warm up, but nothing. Would appreciate any help in what I’m doing wrong. Thanks.

I’m sure we can help. Can you give more detail about what trainer you are using and any sensors. Also what device are you running zwift in and how are you connecting the trainer to Zwift. Ie. Bluetooth or Ant+

Thanks, Stuart. I’m using the CycleOps Fluid 2 trainer. My senors are the Wahoo Speed and Cadence sensors (also a MyPulse HR monitor). On the Apple iPad as well as trying the iphone, same thing happened on both. All through Bluetooth. Let me know if anything else needed. Thanks.

When you launch Zwift on the device pairing screen are you searching for the sensors and pairing them?

iPad and iPhone only support 2 Bluetooth connections.

Total guess here, but the Wahoo Speed sensor possibly wasn’t able to connect as the Bluetooth slots were taken up by the Cadence and HR.

Try just connecting Speed and Cadence.

Yes, the sensors are paired up. Both of them.

Thanks, Tim. I’m trying all of the apps and was on the sufferfest the other day and it had all 3 on my iphone. I’ll give your suggestion a try though.

When you are sat by the roadside is your hr being reported.
That’ll help isolate the issue.

Yes, my HR was there.

Then it’s isolated to the Wahoo sensor. I can only think it’s dropping the pairing between the initial pairing screen and when you are placed at the roadside.

Did you press A and check it was still paired?

When pedaling on the pairing screen power source device list, do you get any watts?

Actually the iPad and iPhone can connect to more than 2 Bluetooth devices. I typically have my trainer, TACX Flux, my Wahoo cadence and Wahoo heart rate monitor connected at the same time.

I think you may be thinking of the Apple TV which can only connect to 3 BT devices, one of which has to be the remote.

I’ve been using a few months & same thing happened to me at start of my 1st race … left standing on start line. So switched to doing a London ride … no problems, do don’t think the issue was sensors. Any other thoughts pls?

Here are some of the most common reasons why your bike avatar may not be moving:

Would you run through those and eliminate any that might apply to you?

Thank you all. I went through my connections with sensors and HR monitor with another app. All worked with no issues. Tried again this morning and hit the London course. I was moving although my change in speed / cadence did not look to change much for my avatar. I really didn’t have much time this morning so will try again tomorrow and will advise how things are running. Really appreciate the community responces.

I am having the exact same problem as yours. The wahoo speed sensor doesn’t seem to properly registered with the program. The reading I have on my wahoo Elemnt bolt comparing to the reading from Zwift is probably 2x faster.

I am still not sure what’s causing the discrepancy.