Zwift Hub One Calibration


I just unboxed my new Zwift Hub One and did my first spin. Though I never did my calibration and the watt and speed seemed completely off. A cadence of 90+ and my virtual bike nearly fell over due to slow speed. Something is most definitely off.

A friend addressed the need to calibrate. Though both my Apple iPhone as my MacBook never showed the wrench icon to make calibration possible.

I checked all the video’s, did a one hour spin and went back to the pairing options though no wrench. Switched off the Hub One, switched power back on, tried numerous times. No wrench. I’m lost.

Firmware is up to date. No idea how to calibrate when the option with the wrench isn’t showing. #help

The Hub auto-calibrates under the right conditions. It won’t tell you when that happens but this document explains the requirements for auto-calibration to occur:

What were the power readings while you were moving so slowly? One possibility is that your in-game weight is set incorrectly high, so a high power wasn’t moving you as fast as it should.

How much resistance were you feeling at that 90+ RPM? 90 RPM at a very low resistance–just spinning away? Or 90 RPM when you were hammering and your legs were feeling it?

(Sorry if those are overly basic questions, wasn’t sure from your post how much experience with Zwift you have :slight_smile: )

1 Like

I’m having similar problem with the Hub One. Pedaling feels way too hard compared to wattage shown on the app. It’s been discussed with the Zwift support, but the problem currently remains unsolved.

Firmware and app (Android) are up to date, and weight is set correctly. I also tried changing trainer difficulty various times, toggling virtual shifting on / off etc, but nothing seems to help.

During test ride I noticed some extraordinary power spikes while coasting. They occurs each time when coasting, 5-7 seconds after pedaling stops. App is recording both cadence and watts during spikes. My best guess is that those spikes are messing up (or blocking) the auto calibration, and therefore the wattage shown on the app is wrong.

Thanks for the reply.
I tried to take some ss. Though I am a newbie indeed. Just purchased the Hub One and downloaded Zwift. The parameters went all over the place. Riding outside was a hell lot less difficult for sure.

Level 8-10 is like almost no heavy pedaling. Level 12 and up where much noticeable up unto heavy.

Since my MacBook refused to see my Apple Watch as a heart rate monitor, I had to use the iPhone instead and the screen is so tiny I had difficulties reading all the data. Though my weight was entered correctly, I just never saw that wrench option to calibrate.

It wasn’t clear when I went uphill or downhill as this might cause more heavy pedaling as well. Just couldn’t see that on screen.

In overall there should be an option to calibrate. And it never showed.

Sounds familiar and not being able to solve the issue isn’t particularly comforting. Makes me wonder if I should even hold on to this trainer. It just doesn’t make any sense as this is their own trainer and should be most compatible with their own software.
Already send out an email to Zwift asking the same questions: how can I calibrate?

I did notice something else at some point. Made a ss of it.

Its this greenish icon. Perhaps auto calibration? Not sure.

As far as I know there’s no longer option for manual calibration. The device should calibrate itself while riding.

Does your device measure wattage/cadence when coasting?

This explains how auto calibration is triggered

There could be a calibration issue for sure, I don’t know about that. But I will say that you were on the New York map, and that map is lumpy–a lot of short elevation changes. If you were on a small screen and couldn’t see those happening, that might explain some of what you’re seeing.

Try using your MacBook (forget about HR for the moment) and try to Tempus Fugit course. Very flat, steady elevation, so it’ll give us a better idea if elevation changes are playing a role.

1 Like

If you have a watch or cycling computer also connected to the Hub One (as a sensor connection of either smart trainer or power meter) I believe these can interefere with initial Zwift calibration. I make sure the watch/computer are set to resistance of 0, and after you connect them, then do the auto-calibration in Zwift. I also do the auto-calibration a few times at the start of ever ride for peace of mind


I think so. Tiny screen didn’t help much. Downloading on my Samsung Galaxy Tab as we speak to make more visible.

Good tip. Attempting the Galaxy Tab download first and will search for that location. Thanks.

Saw that previously. Thanks.

This one is interesting. Could try calibration before adding the Apple Watch. That might be it.

Hey Karen
I think I’m having the same issue…
Have you found a solution since ?

I have the same issue. I bought a used “nearly new” Zwift Hub One.

Comming from a Magene T-100 I thought this would be an awesome upgrade, since GPLama noticed in a test, that the Magene T-100 is significantly lower in reading the right watts, especially when pushing higher numbers.

If anyone is interested: on yt: watch?v=P1Ke7imru-c

Anyway. Today is my first day with the Zwift Hub One and I updated the firmware, the game and the companion app. I tried to auto-calibrate the Hub (sadly, there is no user feedback). Then I stepped into a ramp test. And I was shocked, because I was not able to even reach my zwiftpower 20min power… I mean… common. Something is really off here.

When riding it felt super hard and the shown watts where relatively low. Riding felt super hard.

I mean, of course there could be the possibility that my old trainer was super off and was showing me waaaay too high numbers.

Also, I noticed other strange behavior: When using the virual shifting, at first it gets harder to pedal, but then it gets easier again (Not in workout mode).
Also, when riding at a (felt) constant intensity, on the flat, the power numbers jump around quite heavily, like from 120 - 170 watts. I was trying to hold 150.

Ah, and the virtual shifting by the clip does not always work.

Now, I am a bit lost.

There are a few possibilities:

  1. My old trainer was showing waaaay to high wattages and the Hub One is right. This still does not explain sudden changes in intensity on the (near) flat even if trainer difficulty is off
  2. My old trainer was about right, and Hub One is broken
  3. Is there a problem when using used Zwift Hardware from another user?

I’m either doubting my actual fitness, or the faultiness of the hub one or my old trainer.
I mean, it’s bad in any way. Do I really have to buy an actual powermeter applied to my bike to figure out which trainer is broken?

This is all very unpleasant, especially as I bought the device second-hand.


There should not be any issue using a device used by someone else.

It’s hard to guess which trainer is correct without an additional power meter.

Have you tried putting a normal cassette on the trainer and riding it with no virtual shifter paired? I wonder if you would get a different result if there were no virtual shifting going on. You would still need to meet the criteria for auto-calibration:

1 Like

Paul, that is a good suggestion, I’ll try using my cassette and see what it does. But honestly I don’t think it will make any difference. But who knows

Thank you :slight_smile:

Okay. I switched to a normal cassette today. The behavior also feels similar and wrong.

What I noticed today on another test ride is the following:
When I try to keep a constant wattage, at a certain point it feels like the resistance is getting lower, randomly getting harder again. this somehow leads to me developing a higher cadence to reach the power I’m aiming for. the most annoying thing is that I never really get into my sweet spot of power and cadence because things magically change.
This is on a straight stretch, no workout mode, no drafting. Sometimes I had trainer difficulty at 100, sometimes at 0.

Hi everyone,

Just to let you know that, since my message on Feb 29, I reported my issue to Zwift. After a few exchanged emails and a video from me, they decided to send me a new unit.

So it can happen that some units are failing if you were wondering. (My issue was that the power displayed was almost 3 times lower than the actual power, no “power jump”, just a wrong continuous calibration).

Maybe you can explore this avenue if you have a similar problem.

1 Like