Spindown callibration

I’m trying to perform a weekly spin down calibration but everytime I click on the wrench all I get is error message “Waiting for device” anyone know of the fix for this??? Frustrated!

fyi - this happened right after the latest firmware update!

Which trainer? If it’s a Zwift Hub there is a bug but it will auto calibrate under the right conditions.

If it’s not a Zwift Hub, then never calibrate it in Zwift. Use the manufacturer’s app.

Paul - It is a Zwift hub and I’m running firmware version 5.2.2 so I guess it will auto-calibrate. I don’t understand why they tell you to re-calibrate every week then?!?

Hi @T_Blum

The Zwift HUB does auto calibrate so you don’t need to do the weekly calibration. The option to manually calibrate is there for first time setup, and if you were to move the trainer or swap bikes. There are also folks out there, that just like to make sure everything is calibrated.

As for the calibration nor working, if you are using a Mac or PC you could try deleting the Preferences under documents/Zwift. If that doesn’t work I suggest reinstalling Zwift as some of the data may have become corrupt.

If that still isn’t working The next step is to contact Zwift Support to see if they can find an issue.

Hi @Terry.G -

Deleting the Preferences under documents/Zwift worked on the PC, but still can’t get it to work on my phone. I tried deleting the app and re-installing but no success, the only reason I would like to get it working on my phone is that I have some trips coming up and would like to take my zwift hub and would like to re-calibrate it after I move it and get it set back up. Any ideas on the phone app and spindown calibration? Is this a known issue?

Thanks in advance for your help!
T, Blum

Hey @T_Blum
In order to clear the preferences file on your phone, you will need to reinstall Zwift completely on your phone. There isn’t a way to access the file structure to delete just that file, so the whole game needs to be deleted.

I’ve had this problem for weeks now. I contacted the support and they said that it’s a known problem and that they are working on a software fix.

I tried deleting the preference file on windows but it doesn’t work for me. Before I deleted the preference file I noticed that it had field “LASTCALIBRATION” or something similar. It had date of third of this month as last calibration so I’m not even sure if autocalibration is working.