Cadence and power got stuck during ride

I’m a newbie. Fourth ride tonight. I have a cyclops H2 smart trainer. As you can see from the screen shot attached; my cadence and Watts / KG froze during my ride tonight. I am new enough that I didn’t really figure out that something was wrong til Incame over the top of the climb and started to descend and my cadence didn’t change (neither did the resistance I don’t think.)
As a matter of fact, when I stopped riding my avatar just kept going to I ended the ride.

Any advice ? Thanks!

I would like to know as well, i had the exact same problem today. And a friend of mine as well. Both on an Cycleops H2 trainer. Mine was stuck at 149Watt and 85 cadence. I stopped my ride, saved it and logged in to my zwift account again, and when I entered Watopia again it was still stuck at the same power and cadence. The only thing that helped was resetting the power on the trainer.

March 8th,
It just happened to me again. This time my H2/Zwift hang up had my cadence set at 70. I tried jumping off and unplugging the trainer and re-plugging it in but then Zwift said it couldn’t get a signal from the trainer.
Any fixes out there?
Thanks

I too had this happen - H2, stuck at 300 Watts, cadence at 93 rpm. Very clumsy fix suggested by Zwift that forces me off the bike (no Zwift Companion fix). I should note this has never happened on TrainerRoad (5 to 1 usage over Zwift) so my suspicions are that this is a Zwift issue.

Sounds like I’m not the only one, but no Zwift help or solutions offered yet.

Same here on a Hammer. Cycling power on the Hammer fixed it. There is a known issue thread on this and I posted there as well. It’s here:

Thanks!

Can you elaborate on what you mean by Cycling power on the Hammer fixed it? In lost on what you mean.

Thanks!

Remove electrical power (unplug) and plug back in. I did this while continuing a Zwift workout. For the time the Hammer’s power was off, there was no data, but the workout continued and everything returned to normal after the Hammer powered up again and I finished the workout…

Thanks, will try it next time I have the problem

This also happens with my H2 connected via a Garmin ANT+ stick but it’s quite random. Oddly it’s most likely to happen when I’m traversing the middle of the main Watopia island. The Figure 8 route is the most likely to trigger this. I’m not using ERG mode… this is normal riding.

What I did note in zwiftalyser is that Zwift is reporting BTLE connection attempts during the problem period yet no ANT+ drops. Additionally strange, is that I don’t have BT on that PC and Zwift on my phone has BTLE disabled.

As mentioned above, power cycling the trainer resolves the issue. It would be nice if that wasn’t necesary.

I’m getting this right now with a Wahoo Kickr, PC and companion app. I tried repairing the trainer but it didn’t work.

Edit: unplugged the power for 30 secs then turned it on again seems ok now.

For H2 users try using a garmin cadence/speed sensor versus the virtual cadence on the H2.
I just got a H2 and had issues with inconsistent cadence and delays in power. Installed a Garmin sensor and paired it up today. Problem solved.

I had a new h2 delivered on the weekend.and in 4 rides it’s happened to me twice.once on a free ride around london.and again doing the absa cape epic workout in erg mode.the erg mode was terrible and my power was all over the place and during the cool down at the end it stuck at 166 watts.i have arranged to send the trainer back and get a replacement.i hope it’s not a zwift issue as I only use my trainer for zwift

Trainer: Tacx
Device with Zwift App: iPhone
ANT + or BLE: BLE
ERG mode or SIM: ERG is not working and in a free ride the watts are wrong

Wattage stuck at 150. In companion app can select and deselect ERG mode and/or increase incline, but does nothing. Unplugged and replugged, still stuck at 150. Tacx Neo with ANT stick. Was 75 minutes into the ride. Used for several years and never had a previous issue.

I had the same problem today on my Wahoo Kicker. Watts and cadence stuck. Always during a group event.

This happened to me yesterday right at the end of 2nd lap on the “7 days of tarmac sl7” stage 2. Stuck me at 397W and 101rpm just as I was cresting Libby Hill and letting off my pedaling effort. I want to be clear: It is only the onscreen values that are being stuck - The trainer is not stuck in some kind of erg mode forcing me to apply the same wattage. I was able to sprint, coast, spin easy, etc with no change to onscreen numbers.

The stuck power began at 41min into the EVENT (which began at 0430 EDT), so roughly 5:11am is ‘when’ the thing happened. More on this below.

It has happened to me in the past at other wattages/rpm as well.

Using:
Game Version 1.0.54377
CycleOps H2 (firmware v. 31.043)
PC (Intel i7 w/ GTX 970 graphics)
Ant+ dongle shows in Device Manager as “Dynastream Innovations Inc” but it says Garmin on it.

I have the Ant+ dongle on a USB extension cable to be within ~3ft of the H2.

The PC is connected via cable ethernet and my home wifi is on Channel 1 to minimize interference on the Ant+ band (which would overlap heavily on wifi channel 11).

I opened yesterday’s Zwift log file on Zwiftalizer and it shows a framerate drop to a minimum of 35 right at the start when there were still hundreds of other avatars on screen for the event start.

The Ant+ signal quality looks strong, with only 1 “search” right at the beginning of the log and this remark below: " Perfect! Your ANT+ devices were paired just once which means there were no dropouts after you started riding. Congratulations!"

On the Network Performance part of zwiftalizer it does show a few reconnects early in the log and one more reconnect at the 5:16 timestamp but that was 5 minutes after the stuck power/rpm began so not sure if related. Likewise, no “Network errors” after the beginning of the log file.

I went and opened the device on the Saris android app and it showed a new firmware update available (31.062) so I updated.