Latest update seemed to break zwift for me

Yesterday and today it seems my smart trainer no longer keeps being smart and feels like it goes into erg mode and doesn’t change resistance.

It said i hit 1200 watts today… This is really frustrating I can’t get a work out in this way.

Had exactly the same issue yesterday. Went to do a workout on Zwift connected to Wahoo Kickr Snap, but had to update Zwift first. Once that was done, went into one of my scheduled Zwift workouts using ERG, and the trainer was not responding to changes in cadence, or gradient when i went into a free ride.

Have restarted PC and trainer, no change, still not working…


Similar issue for me. yesterday all fine, this morning the update installed itself and now the power is off. the other things it’s doing is the cadence of the tacx genius increases. if you stop pedaling it slows down again but then when back up to cadence it races away again. tried different routes / workouts, Bluetooth Vs companion and re-calibrated the trainer, still the same. the only thing i haven’t done is re-install zwift.


Glad to see its not just me and that others have the same issue after the update. I emailed Zwift all my logs and everything yesterday hopefully we can troubleshoot this all together and get a quick fix!

I’m having same issue with Saris H3. Riding along on flat and suddenly resistance increases 50% or more…I register the watts but then when I downshift, suddenly the resistence goes away and I’m dropped…it was quite a rubber band ride this AM…but not like a workout ride…I had to do all the work…

1 Like

3 posts were merged into an existing topic: Not able to log into account

I think the log in issues are a different issue than I am describing, maybe spin those replies into a different post.

So today went better, I finally had a successful ride longer than 20 minutes with no issues. I hope Zwift gets back to me about my logs and lets me know what was up.