Unexpected Resistance Issues with Trainer [January 2024]

After update I have bug that cause that zwift for me is now unusable.
I am using windows version with tacx flux s connected by Bluetooth. After a while in ride my resistance ramps up even if I am going downhill and wattage and cadence meter freeze. I have to stop spinning and after that it get to the zero. After a while I start spinning it freeze again. :exploding_head:


that kind of sounds like the trainer is failing, can you try with a different program or the Tacx app and see if the same thing happens, or is it really just with Zwift?

1 Like

I have the same issue after today’s update. My trainer is a Tacx flux S, too, and I’m running Zwift on an Apple TV. At least I’m glad to see that my trainer is not broken.

1 Like

After the update today the ERG mode isn’t working on the Windows PC app, although the trainer (elite direto) is connected as always. Trainer and ERG mode is working on the android app

1 Like

@Peter_Michalco and @Robert_Doerner

Thanks for the report on Tacx connectiity issues. Would both of you use the Tacx mobile app and verify you’re on the latest Tacx firmware? Here’s instructions on Garmin’s support site.

For Apple TV specifically - if it’s been a while since you last rebooted , it can help sometimes to power off your Apple TV and power it back on. Would you try this, then restart Zwift?


Reboot didn’t help, I already tried that. I’ll check the trainer firmware tomorrow and will give an update.

1 Like

I quickly checked the firmware - it’s up to date (3.3.40, 1.1.6)

@Peter_Michalco @Robert_Doerner
Followup question: you didn’t mention if you were in an ERG mode structured workout, or a free ride in SIM mode. Would you verify which of those you were using?

Thank you for your report. We’re investigating resistance-related issues reported by Tacx trainer users. Will you also use the Elite Upgrado app and confirm that your Direto is using the latest Elite firmware?

Today’s update seems to have caused my Tacx Flux S trainer not to work in ERG mode. I do a workout and at higher wattage, the trainer is basically free riding. Zwift eventually disables ERG mode because it thinks I’m not able to do the effort.

I’ve tried recalibrating in Zwift and the Tacx app. I’ve disconnected and reconnected the trainer. I’ve tried using the Companion app instead of BLE. Nothing works.

Any help is much appreciated.

Greetings! This morning’s Zwift workout didn’t go well. I updated the application on my Mac and ERG mode stopped working.
No need to update!
Smart trainer Magene T200, in other applications everything works, the force is adjusted.

1 Like

Checked the firmware version in the app and there is no newer version available.

I faced the issue in both modes. In a workout in ERG mode right from the start the wattage didn’t match as exactly as usual and reacted only with some delay. Then, at higher power, say above 200W, the display got kind of frozen - displayed wattage and cadence didn’t change until I stopped pedaling for some seconds. Then everything went well for the remainder of the workout.
Afterwards I restarted both, apple TV and trainer, and tried the SIM mode. Again the system got stuck as soon as I increased the power.

After the update on Apple TV, I have an issue with increased Watts freezing on very high level.

For example after accelerating to 208W, the Zwift froze on that level, irrespective what I was doing.

1 Like


1 Like

Does anyone know if it is possible to install a previous version of zwift?

Not possible

On Windows you can use this script (maybe Mac but not tested) Update Zwift · GitHub


pip install urllib3
python update_zwift.py 124332

ERG not working here either. Calibrated, restarted everything.
Tacx Flux S, Windows, Bluetooth


Today I checked fw on my Tacx Flux S and it is up to date (3.3.44 1.1.6).
I had that problem at sim mode on actual Tour de Zwift Innsbruck longest (A) route. I noticed it after only few kilometers.
After that problem I wrote post here on forum and I restarted my PC and tacx, waited few minutes and after that I tried robopacer 10 kilometers ride at 1,8kg (avg 150w) and it works fine without problems. After that I tried actual Tour de Zwift Innsbruck shortest (C) route and it also worked fine for 30 kilometers ride without problem. So I started to think it was occasional problem, but now I see it is problem for more of us.
I hope for quick fix because for now I have a little aversion to try it again only to find it will not work.

1 Like