Problem with resistance since last Zwift Update


(Gary Zimberg) #1

I have a Tacx Flux.  Since the last Zwift update there is a problem where the perceived resistance always stays the same.  There is some consistant resistance like riding on flats… but my wattage and cadence stay the same, only my speed varies as I go uphill or downhill, but you cannot feel anything different.  Its crazy that I can keep my cadence at 85 going up a 15% hill but it shows I slowed down from 21 to 4 mph.

Its very boring riding this way, as you can never feel any difference, and there is never enough resistance to stand to hill climb.

Before this Zwift update, I would really feel when I was on a hill…

what to do? 

 


(Chris Gulden ODZ (C)) #2

I have the same exact issue. After this last update my Wahoo Kickr no longer changes resistance in the game. I tested my trainer in the Wahoo software and it works fine. I even uninstalled the Zwift software and reinstalled it but that made no difference. No matter what change I tried I still get no resistance in the game. I have been using it for over a year without an issue and now I have to wait for a patch or find another service that works.


(Gary Zimberg) #3

I sent in an email ticket.  got a quick response, they asked me to send my logs.  I got this response… seems that somehow during the last update, but trainer was incorrectly selected.  See their response below…

Thanks for checking in with me, and thanks for sending the info I had requested!

The reason why you’re not seeing the Trainer Difficulty setting in the game is because your smart trainer is not paired as Controllable at the Paired Devices screen.

  • After you launch the game, you will be directed initially to the Paired Devices screen.
  • Where you see ‘Controllable’, click on ‘Search.’
  • Smart trainers like your Tacx Flux T2900 continually broadcast over ANT+. As long as you crank the pedal on your bike to wake up the trainer, they should always show up unless another program is hijacking it (such as TrainerRoad or the Tacx Utility App), in which case you’ll need to first close those other apps/programs.
  • There may be a second option for the exact same trainer, which includes the letters “FE-C.” FE-C, or Fitness Equipment - Control, is the recommended option. Always choose FE-C if it’s available.
  • Once you select the Tacx Flux, it will highlight as blue, and I can click ‘OK.’
  • The Paired Devices screen will show your devices under Power Source, Cadence, and Controllable, so make sure all three of those are paired up to the game.
  • Click ‘OK’.

(Chris Gulden ODZ (C)) #4

Looks like that was my issue as well. Kind of frustrating that the menu changed and my settings were not retained but at least it works.