Bug: Workout portals incorrect colour

Another day, another bug…

Today the workout “portals” for each intervalwere the wrong colour, e.g. portals marking the start of a recovery zone1 effort are usually green, but today they were blue (which is zone2). likewise the zone5 portals are normally red but today were yellow…

Is this a known bug or a new report?

6 months on and this is still occurring, has this been logged as a bug?

Here’s some photos from a ride this week showing the same issue still present.

First photo, showing me in zone 3 (tempo) with a zone 1 (recovery) block coming up. The portal is (erroneously) shown in blue (zone2) rather than grey (zone1):

Then when I pass through the portal you can see that the workout colour at the top of the screen is in grey, confirming that I’ve just transitioned into zone1 (grey) segment, despite the erroneously-coloured portal:

Any chance of getting this logged and fixed please? Seems like such a simple fix…

Agreed, the arc colors are not always correct when in . In addition,
the chime ceases in a second workout within one Zwift session when changing worlds (Windows machine).Well, the mostly annoying bug is the 5W power rounding…

Maybe the Zwift programming guys don’t do any workouts or they even don’t use their product - otherwise those bugs should have been identified and solved within their quality control… :wink:

@anon99260137 question: on what device are you running Zwift? I am on Apple TV and have been doing a lot of workouts lately. One of the things I have noticed is that the arch/portal is actually displayed slightly before the actual end of the interval (as noted by the resistance actually changing). This is especially evident when the interval ends on a curve and the arch/portal is at a different angle than ‘across the road’, but would be at the correct angle if it were just a bit farther down the road.

While I haven’t paid attention to the color of the arch/portal (though I will now), I am wondering if (a) the same ‘location’ bug might be happening to you (I think you’re on iOS, if I remember your other post) and (b) the arch (which actually looks green to me) might be the color of the area it’s actually in. That is, in your example above, you are in a green interval and if the portal is just a bit ‘earlier’ than where it should be it would still be in a green zone.

Any idea if the next portal you encountered was grey, but the zone you were going into was a different color?

Hi Nigel, thanks for your help here and in all other threads. You seem very active here and extremely helpful so just so say its appreciated. Zwift really need to hire you :wink:

@Dreg_Nettirb5190 yes the workouts have multiple issues but I’m trying to keep this thread just “clean” on a single issue. I’ve posted about rounding and other issues elsewhere :slight_smile:

I’m running an Apple iPad Pro, so iPadOS technically (iOS).

I have various bugs with the portal (sometimes they are hidden or half visible, sometimes they flicker in and out of existence, sometimes they show (when path splits) on the “wrong” route (the section of road that the route I’m following is not going to take at the junction), etc etc. But as per comment to Dreg above I’m trying to keep this a clean, simple thread on this one issue so that hopefully this one thing at least can get fixed.

In reply to yuor question, no the entire workout was alternating between Z1/Z3, there were no Z2 sections coming up at any point later in the workout, so its not a location bug. The arch remained in place, but was simply the wrong colour for the workout intensity for that section. Its also consistently wrong, not intermittent - i.e. the portal was blue at the start of every Z1 segment, when it should have been grey each time. Its very reproducible, it happens every time.

An unrelated second bug is that the 100w segments are also highlighted as green in the workout chart (top left of screen) even though they are Z1 and should be grey. It seems as though in intervals both the “off” and “on” are coloured the colour of the higher intensity (Z3 in this case) rather than being the “Correct” colour. You can see this in the screenshot above. But as I say I’m trying to not mention “oh and this is broken, oh and this too, oh and this too”. I would love to see all these things fixed, but when I made a post preiovusly with about 17 bugs in one post… none of them got fixed. Support “noted” them, and too no action that I can tell at all. That was about 9 months ago IIRC. So this time round I’m making one post, one bug. And hoping keeping it focused will at least get one bug fixed!

This only seems to happen inside or around the volcano for me. Have been meaning to mention it for a while now

This only seems to happen inside or around the volcano for me. Have been meaning to mention it for a while now

Good point, yes I think it might be related to the “heat distortion” effect from the lava perhaps? I thought that I’d seen this happen in makuri and the jungle too, perhaps because of similar interference with the “water spray” effect from waterfalls etc.

Do you have any screenshots of this one / want to raise it as a separate bug? Its pretty minor/trivial bug that one in the big scheme of things, but probably one they should fix eventually (you’d hope)

I don’t have any screenshots, this might be hard to explain but i’ll have a go!

It is hidden around corners in the road, so as you come round the corner and your avatar could see it it comes in to view - does that make sense? It is like there are walls on the side of the road that hide it from view.

edit - to point out this happens even if nothing in game is blocking the view - it is “as if” there are walls but there aren’t visually

happens every time and has for a long time - it isn’t a new bug or probably very high priority (but should still be fixed)

1 Like

I lied, i did have a screen shot

as I was trying to explain - the hidden bit is around the corner

edit - i really did lie!

as you can see as you go around the corner more of it comes in to view

1 Like

Great stuff, yes its good to get independent verification and screenshots, I get the exact same thing. I’m guessing perhaps the way the world’s are “built” there really is some wall/element there for some map-building purposes and its just transparent for normal purposes but the logic for the portals doesn’t treat it as such?

I think this error is with the way the roads around the volcano are created, the portals work fine in other places around Watopia but are always part blocked/missing as above in and around the volcano

Are you able to get the original report (workout portals wrong colour) logged as a bug please @shooj since you have multiple reports, with screenshots, of the bug? I’m not a developer but it seems like this should be a really really simple fix :slight_smile:

Just FYI @Chris_Holton I’ve logged the “cropped portals” as a separate bug to this one now - Bug: Workout portals "cropped"/partly hidden on certain routes - since it really is a different issue entirely. If you’re able to delete the posts from above we can keep this thread (here) focused on the portal colour issue :slight_smile:

1 Like

Thanks - you saved me a job, i was going to do that but had completely forgotten.

1 Like

Hehe no worries :smiley: :+1:

I’ve still not seen any response of acknowledgement from Zwift support on this yet as far as I can tell, 6 months after logging it.

@shooj (or anyonne else from Zwift support) can you log this please and provide ticket reference?

Thanks :slight_smile:

Bug still present in latest build - think number is1.32.0 (106182)

Can I get some feedback on whether you plan to fix this one please @James_Zwift @DavidP ?