Booted from a group ride when I was well behind the fence

Hi Jenr, Welcome to the Zwift Forum.

Can you give us a bit more information, like what device do you use for zwift, how did you enroll in the event, how log were you in the pen before it started, anything that can shed more light on the subject.

Thanks for reporting.

I’m using Apple TV. Yesterday’s ride was a late start. 2 mins after ride started. Other rides that I was booted from, I’m usually in the pen 5 mins before start time. I enroll either through Companion or when I log on in Apple TV. Yesterday I enrolled through Apple TV.

The other rides where you were booted did you also late join on those. It seem to happen often to riders that late join.

No. I joined before commencement

Three more observations, again from a large SAS ( C ) ride yesterday on the Sand and Sequoias route…

  1. Distance in right panel crept up pretty quickly where it was 0.3 miles greater than most riders around me and then stayed constant over the rest of the ride
    2)The distance in the right panel was much greater than that show in the top bar (like in the earlier image) (Click on the image to see the whole thing… seems to get cut off in preview)

    As soon as I ended the event (I actually rode through the fence and stayed in front until the “Return to Group” timer ran out) the distance in the right panel and top bar showed the same distance.

I was starting to think that the distance error was the result of my trainer (which is an old Computrainer and which has some lag issues on Zwift) but the distance returning to normal after leaving the fenced event shows that this is likely the result of the fence. I have not had this issue on non-fenced group rides or in races. - J

I started reporting this issue to support last October, So I know they are aware of the problem. There seems to be a lot of folks trying to help troubleshoot this one which is great to see. I consistently have this problem on every group ride I join that uses the fence. Eventually I find the only way to stay on the ride is to fall well behind the leader and ride alone - which totally defeats being on a group ride. My observations:

  1. I have most current software updates
  2. I never actually pass through the fence - warnings start before I get there
  3. My mileage is always several tenths higher than the leader and the longer the ride the higher this number gets.
  4. The longer the ride the the further back from the ride leader I have to be in order to avoid the fence warning

I have lots of pics for when this happens - included the one from today for a reference.

What can I/we do to get this issue resolved once and for all? Willing to help any way I can as I do enjoy participating group rides!

ZWIFT Fence Bug Jan 19 2020|690x416

This is happened to me on Friday and yesterday. Incredibly frustrating. Please fix it.

Just did a fenced ride on London - Flat with NO problems! No Zwift update on the Laptop level, so not sure if it was a server side fix OR the route!?

Miles on left panel tracked miles on top bar and I was actually a bit behind the top riders in total mileage… but got the ‘Return to Group’ warning as soon as I got up to the fence… so all seemed to work well on this ride.

Your experience closely mimics mine. I have been booted by the fence multiple times., including a ride today. I have tried late starting (so that the mileage in the leaderboard stays below the total miles of the ride) and that makes no difference. I agree this is very frustrating!

I’ve noticed that the distance bug has returned during the tour de Zwift rides and races too. The distance in the Group Riders Nearby list is greater than the distance on the top of the screen. XP points are being awarded based on the Group Riders Nearby list every mile/km as well. I suspect this has something to do with the fence booting riders that are behind it.

So, I switched computers and this problem went away. Two long rides with the fence on this weekend and my “leaderboard” miles tracked those of the rider leader almost exactly.
Somewhere in the Zwift forums I read the bug may be related to the frame rates on the device your are running Zwift on. On my old pc I was getting well under 10 frames per second frame rates (bad!) at 1080p, and on the new pc (Microsoft Surface 3) I am getting over 25fps at 720p resolution (better, not great).
Tomorrow I will try a large group fence ride with the old pc and lower resolution (720p) to see if I can get it to run above 10fps, and also to see if that fixes the bug

1 Like

I agree that the bug is incredibly frustrating and it really detracts from the joy of the ride when you constantly are jockeying to avoid getting booted.

Thanks . _Ride_Nowhere for the hint!! I checked my graphics frames per second on the rides I had problems with the fence and it was around the 10 fps range at 1080p resolution. So I swapped out my PC with one that had a newer graphics card and now its showing 30+ fps on Zwift rides. I have been on 10 group rides since then, Not Once did I have an issue with the fence. This seems to have solved my problem. Hope it helps other riders as well. For those folks less technical, I used the Zwiftalizer log analyzer to see the fps for my rides ( Simply upload your ride log and it will spit out all kinds of detail about your ride.

So glad to hear it! I just upgraded to an entry level gaming pc yesterday and am running at 50 fps now at 1080p so I too hope the days of booting are behind me.

For folks that don’t want to upgrade, try dropping the resolution to 720. That also helped on my older setup.

Thrown out by fence when still in the group behind fence.

1 Like