Avatar not moving today

My bike avatar is fine but today when I tried to run on treadmill, it wasn’t moving… everything is paired but it quit on me.

Any advise

Can you post a rundown of your setup for running on Zwift.

Have had the same problem. Everything looks paired but zwift does not recognize the treadmill speed. So avatar is taking a break. This on a Windows pc. Never had this problem on my iPad Pro.

Solution is to unpair. Then pair again. I now always put the treadmill at walking speed during pairing to see if zwift recognizes the speed, or not.

ditto, i have the same problem: footpod paired just as quick as always, but avatar slacker never started, had to treadmill 12 miles without zwift recording!

1 Like

I’ve had the same problem off and on for a year. Try unplugging the sensors on the bike. Also, If you’re wearing an apple watch and not using it as a sensor turn it off. I’m using the apple TV version of Zwift and find these cause problems.

I will just get on to the treadmill and open up the zwift and pair them while I started walking. Normally, all done in a jiffy. Once I see my avatar start moving, I start running.

I never had any problem in biking. I choose the route after I got onto my bike. As soon as I start pedalling, my avatar starts going.

I think this is due to the running pods/treadmill sensors going to sleep so quickly.

I do the same I start walking slowly while pairing and never stop until im walking in game.

I use an apple tv and its limited to 3 bluetooth connections and the remote is one. So today my heart rate monitor was the other and my milestone only connected once, briefly, and never showed any steps or speed. I don’t know what else might have been connected. When the milestone did connect it was when I turned off a fan thinking that might be interfering, but like I said it never showed any speed and was gone in a minute.

Here’s a link to a thread I started last time I was having problems: Milestone runpod and AppleTV connection problems

This is so frustrating. When it works its great but I spend more time troubleshooting then running.

I’ve had similar problems in the past which was very frustrating and was never quite sure how I fixed it. I had the same problem two days ago and tried everything that I normally do to fix it but nothing worked. I decided to try again today and had the same problem.

I decided to see if my Milestone pod would hook up to the Milestone app on my iPad which it did. It said that my pod needed a software update which I applied. I went back on to Zwift and, viola, it worked fine. Logged on and off a few times and it worked every time.

Not sure if this solution was specific to my situation but, given the frustration this causes, it might be worth a try.

1 Like

Thanks for sharing @Colin_McKay, this could be useful to other users.

I think I did this update a month or so ago when I was last having this problem. I logged into the milestone app yesterday and it didn’t notify me that I needed an update and there won’t be anymore now that Zwift no longer supports the milestone app. I did notice that the app showed I ran for 7 minutes, although I was really running for over 30. I guess that narrows it down to the pod.
Yesterday the Milestone pod connected to Zwift on apple tV right away and showed all bars for bluetooth strength, but once again it didn’t seem to be sending any data. I ran for over a half hour while the avatar stood and stretched.
I finally gave up and ordered a stryd. I’ve been hesitant to spend so much on a pod without knowing if it would work consistently but the reviews here seem pretty good. I’ll never use all its features, I’m not that serious of a runner. I’ll post here how it works.
I’ve been having these problems since Zwift running came out and somehow have managed to get to level 10 despite it not working for months at a time. I’ve tried both apple watch and the milestone pod. The watch works better, but drops out too and it is confusing for the blue tooth connection when I want to use a chest strap instead of the watch for heart rate. I’ll post here how the stryd works for me.

I have been using the Stryd run pod for about 2 years now without any issues.

This could have also been a good option for you (it was just announced): https://store.npe-inc.com/runn-smart-treadmill-sensor/

I saw a DC Rainmaker review for what I think was an earlier version of the Runn Smart but it had a different name and I had trouble finding other info on it. I seriously considered it but I decided on the Stryd because it looked like there was more support available and I could use it outside or when traveling, although that wasn’t a huge factor.

I believe the name of the other device was TreadTracker.

Stryd would be my recommendation.

Coincidentally I received an email from Zwift last evening saying that my RunPod battery is “on its last legs” and telling me to replace it and get my RunPod firmware up to date.

Not sure why I am getting this as I have a Milestone Pod (I’m aware that Zwift purchased Milestone). I wasn’t aware that they are treating Milestone and RubPod as the same devices. In my previous post I mentioned that I linked up to the Milestone app yesterday on my iPad and it did a firmware update but also told me that my battery was at about 40%.

Couple of questions: 1. Is the Milestone Pod and the RunPod treated as being the same device by Zwift? If so, will the Zwift app notify me that I need a firmware update when I pair the Milestone Pod as it says it does for the RunPod? 2. Can the Zwift app see if your Milestone Pod or RunPod battery needs replacing?

Here is the link they sent me to update the RunPod firmware.

https://support.zwift.com/en_us/updating-your-zwift-runpod-s-firmware-ByCPjqfwr?utm_source=email&utm_medium=txt-updateyourrunpodsfirmware&utm_campaign=Zwift_ALL_runpodbatterylow_replacebattery

That’s it. When I googled I got mostly info on a device for the OTR trucking industry to track their tire tread.

Somebody needs to invent something like an optical mouse-- but for Treadmills. This future billionaire could also add-in an inclinometer. This magic device would communicate using BLE to Zwift and Garmin watches…

I think the Runn has got that covered.

The Runn essentially connects any treadmill in tracking speed, cadence and incline to your fitness app like Zwift through BLE/ANT+.

This is what I sent to Zwift Support:

My Zwift Runpod stopped transmitting data. The green light turns on, and the pod connects to Zwift through Bluetooth. This is on my Windows 10 PC and my Android (Pixel 3XL, Android 10). Worked perfectly until the last week. My son’s identical runpod works fine. I replaced the battery with a new one, no improvement. What do you recommend? I purchased it through Amazon.com. Thanks!

Also, after connecting on the “Paired Devices” screen, the speed and cadence will show “0” for several seconds then disappear. No movement is ever registered. Tried resetting with leaving the battery out for several minutes, restarted phone/PC, cleared Bluetooth data, etc.

Very frustrating! Any thoughts.

1 Like