Running avatar will not move

I bought a runpod over a month ago and have been trying to get it to work at my gym every week since. It pairs easily with my iPhone but my avatar will not move. I’ve taken the battery out, logged out on my laptop, deleted the companion and zwift apps, and nothing. I even tried using my Apple Watch as the speed sensor and it still didn’t work! I’ve contacted support 3 times but they suggest the same thing and then stop replying. Super disappointing as I was really excited about the tri academy team. Any help is appreciated! Thanks!

Hi @Sam_Teller welcome to Zwift forums

The runpod’s Bluetooth signal can only pair to one thing at a time. When you say “it pairs easily with my iPhone” - are you saying it’s paired directly to the phone OS in the way you’d pair a pair of Bluetooth earbuds?

If that’s the case - that’s the problem. Please got into the phone’s settings > Bluetooth. Then “forget” the runpod.

If this isn’t the problem - please make sure that some other app or device (like your Apple Watch) isn’t stealing the Bluetooth signal before you have a chance to fire up the Zwift game app.

Some other basics covered here. If you’ve been in touch with my colleagues, I’m guessing you’ve already done all the steps there?

Hi Shuji, thanks for the reply. The pod is connected only within the zwift app. I don’t believe the watch is getting in the way, it was giving me trouble before I had ever connected the watch too. And they have directed me that section before. In one discussion with one of your colleagues they mentioned that someone might be able to look at some sort of data log? I’m not sure what that would mean but could it help? Thanks.

I have the same issue with my run pod. Avatar will not move since November. Have tried everything:

  • reinstall Zwift
  • remove battery for 2 minutes
  • multiple new batteries
  • moved other bluetooth devices away
  • logged out everywhere

The logs don’t seem to show much other than sometimes I see this:

[17:27:20] NETWORK:error (6) sending player state

Have you tried updating the firmware of the pod?

I did all you did too and unfortunately my solution was to purchase a new run pod. Fortunately, Zwift customer service refunded me the cost of the new pod. I wish I had better advice to give :frowning: good luck!

I have this issue time to time but realized it only happened when or indoor bike trainer’s bluetooth was on, competing bluetooth signals with my Runn sensor.

I’ve had everything off, tried multiple devices. My food pod is just a battery tester now. I have the Runn but I liked it as a backup.