Apple TV 13 only using lower left corner of screen

I’m running Zwift 1.0.39805 on an Apple TV HD (Gen 4, I think) with tvOS 13 GM and the app is only using the lower left hand corner of the screen (again).

During startup, the app shows a white screen instead of the normal Zwift logo.

When it was running tvOS 12 it worked fine with Zwift taking up the full screen.

I saw this behavior a few tvOS releases ago … but it’s been working fine since.

Check the display settings of the Apple TV. That is most likely where you will find the source of your problem.

I’ve gone through all the useable display resolutions and none of the work properly.

Some quirk with this TV + Apple TV makes it so standard 720p doesn’t work correctly (overscan, and the TV doesn’t have any adjustment capability), so I have to use 1280x768. This worked fine with tvOS 12, but it doesn’t work with tvOS 13.

Same issue here on multiple TV sets after the TVOS update today image image

1 Like

I’ve opened a ticket with Zwift support.

1 Like

I have the same issue with OS 13 and my 720p set. I mentioned this MONTHS ago in the Zwift Facebook group and everyone just made fun of me for complaining about a beta bug. I waited patiently for the full release and still have the problem.

Did you open a support ticket “months ago”? Contrary to the few voices here or on FB (relative to total userbase) Zwift support is both responsive and good.

Is Zwift fully updated? Have you force quit the app and restarted it? Have you checked the display settings of the Apple TV itself? Have you tried changing the said display settings?

I opened one a few weeks ago when tvOS 13 was released. I followed up just today and they are aware of the issue.

And yes, I have a background in IT and have troubleshooted this problem to death in the meantime. This is a bug in Zwift that specifically affects 720p displays and tvOS 13. It worked just fine on tvOS 12 and was immediately broken with the first public beta. No other display settings work. Restarting the app doesn’t work. Deleting the app and reinstalling doesn’t work. Different HDMI cables don’t work. Nothing.

1 Like

Strange bug indeed if limited to only 720p displays and tvOS 13. I wonder if it’s perhaps a tvOS 13 bug? Granted tvOS is separate from iOS 13, but iOS 13 has already been patched three times now in a week… 13 -> 13.1 -> 13.1.1 --> 13.1.2 which is nice and all but kinda ridiculous.

I’m in the same boat … plus, I’ve seen this problem before with a previous new tvOS release.

tvOS 13 works fine with my ATV 4K on a 4k display. I don’t think it’s a tvOS problem.

As I’ve mentioned before, a similar problem happened before and was resolved by a Zwift update.

Same thing here: tvOS 13 and Zwift update caused 1/4 screen on all selectable screen resolutions…

Easy fix to this if you have the option to change your screen resolution to 1080p. restart zwift and boom!

Tried numerous variations on that approach with no luck. :frowning:

Same here, not one setting works after updates install…

I got this reply from Zwift support …

it was discovered that the newest tvOS introduced a new resolution that Zwift doesn’t currently support, and that’s what’s causing this old bug to pop up

They are working on a fix and hope to have it available soon.

david

3 Likes

I have the same problem as David, Zwift would only display correctly on 1360x768 resolution on AppleTV. Unfortunatly my old tv can’t handle setting the resolution to 1080.
Hope Zwift can update this.

1 Like

Latest from Zwift …

I finally received some more concrete updates from our Head Dev regarding this issue. So it turns out that Apple had originally introduced this issue around this time last year in a tvOS update. Our Devs then put a fix in for the issue, only for Apple to follow up eventually with their “fix”, which once again introduced the same issue. This latest update looks to have broken something with Zwift again, and now our Devs are suspecting we may have to correct this at least a couple of times if Apple decides to release a patch that once again breaks it. It looks like the introduction of the new resolution isn’t necessarily causing the issue, but it did reintroduce the original bug. We’re keeping an eye out for any patches coming from Apple, but our Devs are going to try to get a fix for this out in the next release. Again, part of this is dependent on what Apple might have in mind, and anything released on their end will play a role in when we’re able to release a fix.

We do have a small patch scheduled in the next few days or so, and I don’t think it will make it in that update. However, our Devs are planning for the one following that, which will likely be towards the end of the month.

I apologize for not having a more definitive timeline, and I hope we’re able to get this sorted with Apple sooner than later. Please let me know if you have any follow up questions, and keep an eye out for the next larger update for the fix.

2 Likes

Having the same issue. Thanks David for posting this info. I guess the options are to either wait and see what Zwift or Apple does to patch or fix the bug, or perhaps to change to a TV that supports a higher resolution?

Same issue here. Good to see there is a fix on work.

Also gave a reason to try Rouvy and Fulgaz which both seem to work of with AppleTV 13 and 720p resolution…