Zwift only showing 1/4 screen on Apple TV


(Ant Adams) #1

Recently bought an Apple TV 4K to connect to my Dell U2715Hc monitor to run Zwift instead of running it on my Surface laptop.

Initially it worked absolutely fine (couple of tests) but every time I launch Zwift now it only displays in 1/4 of the screen. Anybody come across this before and know of a fix?


(Vincent W.) #2

That’s a little too small, isn’t it? :wink: Can you try these steps and report back if they help at all?

  1. Go to your Program Files/Zwift folder (may be Program Files (x86))
  2. Right click on “ZwiftApp”, click “Properties”.
  3. Click on Compatibility
  4. Click on "Change High DPI Settings
  5. Check the box, “Override high DPI scaling behavior. Scaling performed by:”
  6. In the dropdown box, select “Application”. (Selecting “System” or “System (Enhanced)” will not solve anything)

(Ant Adams) #3

Hi Vincent,

Thanks for coming back to me. Given that I’m using an Apple TV there is no Program Files/Zwift folder. Do you have another solution?

Thanks,
Anthony


(Jesper Rosenlund Nielsen [ZwiftHacks]) #4

My guess would be that this problem occurs after tvOS (the operating system of your Apple TV) was updated to version 12. Maybe you can tweak the Apple TV picture settings somehow, alternatively it is something which must be handled by Zwift in the game.


(Jesper Rosenlund Nielsen [ZwiftHacks]) #5

There is a similar report at https://zwiftinsider.com/tips-and-tricks-for-zwift-on-apple-tv/comment-page-1/#comment-15695 which suggests that there could be a problem with handling QHD monitors under tvOS 12.


(Johan Haels) #6

I have an Apple TV 4K with iOS 12 and a computer screen from Dell 25 inch with 2560 x 1440 resolution. The welcome splash screen fills the whole Screen but the game only fills a quarter of the bottom left hand side. The zwift app is the latest version (1.0.29.385). But when I connect the Apple tv 4K with my LG 4K tv, eveything works fine (app in fulltime screen). Is there a fix?

But today I changed the resolution of my Dell screen from 2560 x 1440 to 1080p and this works, but only when I force the Zwift app to quit and restart (iOS 12).
I didnt use zwift in the summer, i didnt have this problem in april, when i last used zwift.
So I can go on now, but i hope the bug will be fixed.


(Vincent W.) #7

@Ant_Adams Ah sorry about that! Can you reply here when you get a chance to try out the tips @Jesper_Rosenlund and @Johan_Haels suggested?

Also have you tried adjusting the resolution of your Apple TV? https://www.iphonefaq.org/archives/974310


(Jostein Erlandsen) #8

Same problem here; Kickr’17, AppleTV 4K connected to 2560x1440 screen via HDMI.

All worked prima Sept.20th. Full screen. No problem. Then whilst setting up for a ride Sept.22nd, after having logged on, the picture swapped from full screen to 1/4 as shown in Ant Adams post.
The fix / work-around described by Johan Haels worked for me: Closed the app, set the ATV to 1080SDR and re-opened the Zwift app. Picture back in full-screen.

@Johan Haels - many many thanks!