Apple TV 4K - no fullscreen

Hey Zwifters,

I have a problem with the screen resolution of zwift. There are parts of the TV screen which are black - I have already checked over and underscan of my apple TV 4k as well as the different settings of my TV. The highest setting of my TV is 720p. (TV is already a few years old…)

Thanks in advance and RIDE ON!

Hi Marcel, sorry for the trouble. This will be fixed in our next update, sometime next week.

Great news!


I’m experiencing the same thing.  

Any work around until the update is released?

Need a tester for the update?

Was excited to get my Apple TV 4K only to find out my screen is only 1/2 filled running Zwift on my 720p screen.  Bummer.  Happy there will be an update.

Does it make a difference if you change the video resolution in the Apple TV settings to 720p ?

720p is what is set in Apple TV, looks like the first picture in the discussion.  All other apps on Apple TV are working great.  Its a Zwift problem as they seem to be aware.

After fiddling around with it, I found that if I force quit the Zwift app and restarted it, it would sometimes run full screen.


It is only full screen on the Zwift intro then shrinks on the select user screen.

Any update on this issue? Same for me on 720p Samsung

Zwift app updated yesterday and fixed issue, but now it’s too big as some of the text is cutoff on the sides.  I created a ticket for this issue.

I have that problem on my Sony tv. Try setting the screen resolution to something other than 720p or 1080p. I went with something that is 768 wide and it works fine.

Use the Apple TV video calibrate option to verify it’s correct.

Thanks Dean, the update this week worked for us on 720p Samsung. Picture was close to good on re-opening the ATV Zwift app. Like David said, at first it was just slightly larger than our screen now, some text was getting cropped off. On our Samsung TV remote, we just had to cycle through the “P. Size” options from 16:9, 4:3, to the next option, which totally fixed it for us. 

I am having the same problem with my 720p tv, the image is larger than the screen cutting off data like the incline.  I cannot change the settings on my Vizio to make it fit.  Is there a fix coming for this?  Thanks.

Use the video calibrate function to see if it’s the ATV or Zwift.

If the image displayed by the calibrate function goes off the edges, it’s not a Zwift issue and you’ll have to talk to Apple.

At this point if the image is slightly too big for the screen, it’s the TV trying to overscan the image.   The majority of TVs made in the last 10 years don’t use this legacy behavior, which dates back to CRT tv tech from the 1930s.   I’ve personally never seen an HDMI supported flat panel TV that didn’t have an option to not overscan (usually in picture size settings), but I’m sure some do exist out there, especially if it is 10+ years old.  

Ralph Humphries, according to the link below you need to set your picture mode to “NORMAL” on your vizio.

Thanks Jon.  I have one of those 10+ year old TVs I set up for Zwifting.  The remote does not work and the side buttons don’t change it to “normal”.  I have talked to Vizio and no joy.  I guess I will need to get another TV.  I appreciate the prompt response!


Just to make sure, I should be ok if I get an inexpensive 720p as long as its new enough to allow me to adjust the overscan.  Or I can just get a 1080 and not worry about it?

I have just bought a 4K Apple TV and the flat screen JVC is less than a year old. The right hand colum of riders names is cut off through the flags. How do I fix this ?

I just bought the 4K Apple TV 2 weeks ago, and the issues provided on all of these threads do not work. I have changed the settings, restarted, checked the over/under scan and the screen remains zoomed in. All 4 sides are cut off. 

Please advise how this can be fixed, if that is even possible. 


1 Like