Android Companion v3.20.0 crashing [SOLVED]

Not sure if anyone else is having issue with the recent Companion app on Android crashing? I thought maybe it was just the overloaded Focus events this past weekend, but shortly after entering the pens or starting a ride, the Companion app crashes on my phone, and disconnects the BTLE from Apple TV.

There were no stability issues in the previous Android Companion version, and v3.20.0 is supposed to have some BTLE updates. I’m wondering if that is broken, or is broken on my setup.

Further, the v3.20.0 Android Companion also has erroneous unread messages notificatuon bubble in the chat tab. I’m thinking this update is FUBAR. Any other parallel experiences?

1 Like


Our telemetry data is showing it’s not just you. A 3.20.1 patch for Android is being worked on as we speak to address this.


Thank-you for confirming I’m not crazy (about this), and that the issue is being worked on. Much appreciated for the quick reply and update! Ride On!

All on this thread: Companion for Android v.3.20.1 is released. It may take a bit for it to propagate to the Google Play store worldwide.

Please update Companion before your next Zwift session.


Greetings I am running this version of the companion for android v3.20.1 (1101) and yet continue to find this problem I can zwift alone forever… but try to start with an event and my companion drops the signal just like @R_osco_P_Coltrane as soon as the event starts… very frustrating… it just happened to me at today’s WBR charity event. but happens in races, and group rides… this is new as was not an issue 4 weeks ago… but now consistently a problem… running the H3 Saris trainer, a samsung S20 galaxy and PC windows 10).

Sorry to hear @Bryan_MacLeod. The update fixed my issue, and I haven’t had the same behaviour. There are often connection and server issues with big rides > 3000 participants, but shouldn’t be a regular occurrence.

Try and click-hold the Companion icon, and choose the info icon. Then click “force stop”, and then go and clear the cache. Not sure if that will help, but might. If not, do the same again AND clear data, then uninstall the app - then reinstall it. Just a thought.