Companion App always crashing on android


(Nigel Ayers FCC) #1

Okay I will try to give a little back story. First, I use a dumb-trainer with bluetooth speed/cadence sensor on the bike and heartrate monitor. I started using zwift on my PC with the app used to bridge with my sensors and during the free 7 day period in early December everything worked seamlessly. I was hooked!

Fast forward to signing up and initial again everything was good. Then the app would crash for no apparent reason leaving me sat there not going anywhere. So I contacted support and they suggested using zwift Beta without the app, which after borrowing a laptop again gave me a few session of trouble free Zwifting.

So I made a decision tp purchase a brand new laptop (this is getting expensive) let my son have his back. New laptop arrives and I am all excited again! Fired everything up for my zwift session using the Beta and…

Your Bluetooth is not switched on! Yes it is!! A little yellow caution sign just under the bluetooth icon and Zwift says my bluetooth is not switched on. I have been through everything it is switched on and to prove everything is fine with the laptop I downloaded intalled Rouvy and was riding with all sensors connected within a matter of minutes!

So I decided to try Zwift with the companion app and within a short distance the app again crashed!!

I want to use Zwift! I do not understand why for a time things worked so well. Please can someone offer up a solution? I am a paid up user having already forked out for I think 3 payments, I have shelled out £200 on a laptop! I just want to ride!

Oh btw all required specs are met!

Need help!


(Paul Allen (Watopia Wayfinder)) #2

What is the make/model of the sensors and HRM that you are using?
Is the Bluetooth on the laptop 4.0 or above?
Are you using Windows 10?
If so what is the version that you are running?
Is the Android OS fully updated?
Is the ZCA up-to-date?
What are the specs of the laptop, including video card?


(Nigel Ayers FCC) #3

Sensors HR monitor are Lezyne
Bluetooth 4.2
Yes Windows 10 Pro
Android version up to date.
ZCA VERSION 3.1.2
Laptop:
Lenovo 120s ideapad
Processor:Intel® Celeron® CPU N3350 @ 1.10GHz 1.10GHz
Installed Ram: 4.00 /gb (3.83 GB usable)
System type 64-bit, x64-based processor
Graphics: Intel® HD Graphics

:slight_smile:


(Paul Allen (Watopia Wayfinder)) #4

That just barely makes the the minimum specs (might not make it on processor and could use more memory). What Intel HD Graphics is installed on it, you can use this program to find out: https://www.cpuid.com/softwares/cpu-z.html

I would check to see if there are any driver updates available for the laptop especially the Bluetooth, I have seen issues in the past with not having it fully updated.

I am guessing that when you say “the app crashed” you are referring to the Zwift Companion App. Have you tried uninstalling it, restarting the phone and reinstalling it. I would also try uninstalling the Zwift app from it since you are trying to use the laptop to run that.