Also Problems with recent update on Mac Book Pro

Nobody should be telling you that you are out of luck, however the Intel 3000 graphics chip used in 6-7 year old non-gaming laptops is below our minimum supported requirements.  Keep in mind that in the past 7 years graphics capabilities have increased by about 30x, and more and more we will start to use some of those capabilities over the coming years.

We may remove support for Intel 3000 some day in the distant future, however this week we’ll see if we can dial things back again for the machines below minimum spec to get them running closer to where they were before.

I sure hope that is not the case… but we shall see. I guess my 299.00 toshiba satellite that will run it perfect has a heck of video card.

Jon thanks for the reply i’m keeping my fingers cross you all will come thru and help a lot us that dont’ have another computer get back online…

Thanks for the update @Jon Mayfield. Appreciate Zwift’s support on this issue.

same issue here

We rode today on other devices. I used a brand new PC (think pad) and my SO used a brand new iPad. There were issues with both. They worked (and were stable) from a graphics perspective but there were TONS of other problems. Couldn’t get out of erg mode, no tracking of segments, and poor stability of power and cadence. If things were bad before the update, I’d be more willing to understand their explanation that system capacity issues are the problem. But we used two new systems and they weren’t without issues.

:frowning:

Same problems here, before the update everything was working fine, after the update zwifting is impossible. 

This is the response I got from customer support.  Not very supportive since everything was working well before the update.  Would have been nice to have been given warning.  Not sure what to do from here.  My MacBook actually kicks butt for a machine that has been killing it since 2011 with NO issues.  Thinking about looking at other riding platforms.

|

| Brady C |

Brady C  (Zwift)

Feb 4, 16:07 PST

Hey Lorne,

Thanks for reaching out.

Sorry to hear about the trouble there. With our latest update some graphical changes have been made that may be altering your performance if your graphics card doesn’t meet our minimum requirements.

Please check out our minimum requirements page and make sure your device meets Zwift’s requirements.

If you’re device is not supported, we will not be able to further help with this situation.

Additionally, you may try updating your graphics drivers and see if that helps performance.

Sorry for the inconvenience. Let us know if you have any questions before we close this ticket

Brady C 
Member experience agent

|

|

Same problem for me : macbook pro 2011 ! Everything was working fine before last update :confused:

Macbook Air 2011.  Exact same experience as described.  Worked with no issues pre update, now non-functional.  

Same issue for me since the update. Zwift not usable with constant shutter.

Mid 2011 MBA with Intel HD Graphics 3000.

Sad, I’ve been user since beta phase back in Feb. 2015.

1 Like

Same issue I wonder if they will fix this because a lot of the “OG Zwifters” started in 2015 and at that time our 2011 MacBook wasn’t considered out dated. If they don’t fix this they’re going to lose a lot of us OG folks.

Got a response just now to ticket submitted on Saturday.  Slightly better than one copied previously in this chain, but no indication towards timing of fix (or if one will be possible):


| Brady C |

Brady C  (Zwift)

Feb 5, 11:56 PST

Hey James,

Thanks for reaching out.

We’re truly sorry for the trouble that you’re experiencing.

We are currently aware of the graphical issues and are looking into a potential fix. I will put your ticket on hold and get back to you as soon as we receive more information from our developers. You can respond to this ticket if you have any questions.

Thank you for your patience while we work on getting this resolved.

Brady C 
Member experience agent

|

Here is the response I received today from Zwift. Unfortunately it doesn’t help me because I can’t get into the game to change the resolution…

Hi there,

Thank you for reaching out and sorry for the trouble there!

Please try to change your game resolution to 576p via the settings menu in-game.

Let me know how it goes. Thank you!

Same machine as many of you. 2011 MBP that was working fine with Zwift until the update. Now it’s not usable. I opened a ticket…no response in 3 days.

Realize we’re all thinking this is graphics card related…but just in case you were wondering if more RAM would help…it won’t. I upgraded from 4GB of RAM to 10GB today…and this made no difference. 

But the machine is a LOT zippier with everything else.

Time to get an old PC laptop out of mothballs.

Erik

Same MacBook Pro 2011 13 inches  i7 16gb ram. We want to cycle… not spend more buck on big graphics. Please fix or I will unsubscribe. At least create an option for users on older computers.

Same problem here using Zwift has become unrealistic since the update.

I have the same problem with a 2011 Mac Mini.  It was fantastic prior to the recent update.  I got the same “check your specs” reply to my ticket.  I tried it out on an old 2008 MacBook Pro and it ran better, which is strange.

Same as above - MacBook Air with Intel 3000 graphic card - Work great before updates, now it’s unusable. Hoping for a fix soon or moving to TrainerRoad full time. It a shame, really loved riding Zwift.