Also Problems with recent update on Mac Book Pro

1 update and suddenly computer is totally outdated? I’m thinkinig canceling my subscription…unbelievable


I wouldn’t say 1 update, the Intel HD 3000 has been below minimum specs for Zwift for a very long time.

Yes, but Zwift was running just fine before last update…

I think that’s why a lot of people are frustrated. Had there be slow performance deterioration, over time, it would have been a warning that we needed to make a change. But to go from a seemless experience one day to not working at all the next was a big “what?!” If nothing else, they have a PR problem on their hands.


Same issues, same Macbook for me. Horrific if you ask me. Did a Workout of 45min and because of all the lag according to Zwift I registered just 13 minutes.


Have to run Zwift now from my iPhone, which is only 20% of the normal experience I get from a Zwift session.


Wish there was a way to run with low graphic options on my Macbook.

Same issue here. Have been with zwift since beta version and haven t encountered to many frustrating issues along the way. I do agree they should have phased this in. Hopefully they fix soon or allow us to roll back the update and let us operate on the older update until we are ready to purchase a new er machine.

I’ll rather spend money for upgrading my bike than for new computer…

I am having the same issues with a mid 2014 MacBook Pro, worked great last indoor season, nothing but freezing up this year. I am now using ROUVY, really enjoying it.

Logged in at 5:30 EST USA and there was an update.

Post update the app is usable again…and less buggy than before the update that we’re all posting about.

Thanks to Zwift for getting this done.

Many thanks for the update Zwift, my 2011 MacBook Pro is usable again. 

Update: I spoke too soon, although a bit better, the game is still stuttering and unusable. Guess I’ll have to go back to using my iPhone. :frowning:

Thanks Zwift my 2011 MacBook Pro is also usable again…

Uninstalled then reinstalled the app twice. Still has bugs and is unusable. To bad, really thought Zwift was great. Maybe I’ll try it again in a year or so when I get a new laptop. Time to ride outside anyway. 

I did a ride after applying the latest patch and things looked good at first, but ended up still being problematic.  The login was faster than it had been and the menus were now usable.  For the first 5 minutes of the ride, things were looking pretty good, but then it became glitchy again where it would freeze and slowly load for a few minutes, then run fine for a few minutes.  I’m glad Zwift has worked on a fix for us, but it’s still not fully usable.  

Exactly the same experience I’m having. Hope Zwift will keep working towards a fix.

With the latest update I could login pretty fast, select a workout, route and was on my way. Thinking off how my positive reply would look like I found out that after exactly 50 seconds into the workout the stutter was there again and the workout completely unusable. Closed all applications on my Macbook, ran it again, and again it failed in 50 seconds. For me that was about the time I tend to be near the Start/Finish Arch on Watopia.

Btw. I am connecting all my gear using ANT+.


Anyway, went about doing a workout on my iPhone which crashed aswell (twice). That was the moment I really became irritated, my phone went flying through the room and I left my bike frustrated and called it a night.

Similar to recent experiences of others above.  Thought issue was resolved when login and first 10-15 seconds went well.  Then things bogged down again as I approached the arch and I knew the problem was too much to keep attempting on machine.  Had already planned on riding the Garneau Sportive, so closed everything down and started back up on my tiny iphone screen.  Experience was not the same, but performance was fine.  Looks like the graphics are just being pushed a bit too much for that graphics chip now.  Too bad - unsure what changes they made that made such a drastic difference between the patches, but my guess is that there’s no going back :frowning:

What blows my mind though is that it works fine on my phone. I find it very hard to believe that my phone is more powerful that my laptop.


It’s 2 different versions of the same program, the one for iPhone’s is optimized to run on that hardware.