Zwifting now when I'm not! [SOLVED]

Last night I had the following issue when Zwifting. After completing a ride, I stopped, saved, and exited as normal. A few minutes later, I noticed that the activity had not synched to Strava so I started to investigate. I opened the companion app, and by my name and activity it said ‘Zwifting Now’ and it stated in the fit file that the activity was still in progross The elapsed time even continued to increment. I tried each of the following to rectify the situation.

Re-opened Zwift and started a new activity, then saved and exited as normal. This did not work.
Force quit the companion app and re-opened it. This did not work.
Opened Zwift on another machine, started a new activity, saved, and exited. This did not work.
Deleted the in progress .fit file. Restarted the machine. No luck.
Renamed the activity on the companion app, but it want let me click on it, it just says activity in progress.
I have emailed Zwift, but not heard anything.

We use the iPad for my training and rides, so does my husband and son, and they don’t have any problems with it.

I use my galaxy tablet not for the activity on Zwift, but for checking my data etc.

Any other suggestions?

Hi @Nicola_Fisher welcome to Zwift forums.

Shuji at Zwift HQ here. Let’s unpack your question an issue at a time.

  1. If there are any WiFI hiccups at your home (or ISP issues upstream) at the time you’re saving and exiting a session - then your session may not upload to Zwift’s servers completely. If it doesn’t upload to Zwift correctly, then it will not pass to Strava either.

  2. Cycling sessions of less than 2 km will not save in your Activity History. Why is that? Because people will log in solely to change a setting in their profile, or swap bikes in the garage, or other reasons where they don’t actually ride or run. If those zero-activity sessions cluttered up your Activity History, it’d get distracting. For that reason, < 2km sessions don’t sync to Strava’s server either.

  3. Having two different computers logged in to same Zwift account concurrently confuses the server, and can lead to random-seeming weirdness that isn’t random.

In your case, I’m seeing a log in from an iPad followed a few minutes later by a log in from a Windows computer. There’s also a Huawei device getting in on the action yesterday.

This is likely why Zwift thinks you’re Zwifting when you’re not. The solution to this is to make sure you’ve logged out completely on one device (or force-close it) before logging in on a second.

The other reason not to have multiple computers logged in? The Bluetooth signal from your bike / trainer can only pair to one thing at a time. If the speed sensor is already paired to the Zwift app on your iPad, it’ll be unavailable to the Zwift app on your Windows machine, and vice versa.

Hope this clears up the mystery!

1 Like

Dear team

Thank you so much, your advice worked.

Regards
Nicci

1 Like

@Nicola_Fisher

Thank you for coming back to close the loop! We appreciate knowing this solved your problem.