ZwiftApp crashes on my MacBook Pro a few seconds after starting - can't use Swift!


(Thomas Poulter) #1

I have checked that i have a 64 bit Mac which I do (i7 processor) and i have downloaded and installed zwift.  When i open it, it starts playing music and loading up and then just crashes and i get an error message.  I’ve deleted the app and tried installing it again with a fresh download, but the same thing happens.  I was just about to order an ANT+ sensor so i can get up and running but it seems i can’t even get Zwift to work.   I’ve raised a support ticket but the auto response says the tech guys at Zwift are very busy and i don’t know how long i’ll have to wait for a response - any ideas??

 

thanks


(Lindsay Ruppert) #2

Hey Thomas.

I’m very sorry to hear about the issues you’re having. Our customer support team is working very hard to address the tickets we are receiving, and I am sure you will get a response from them soon.

In the meantime, I just wanted to confirm the information you provided in the ticket you submitted. The most useful thing you can give us is the Apple Crash Report that appears after the program closes. If you haven’t included it, please copy/paste the contents and add that to your ticket.

We will work on getting you up and running on Zwift as quickly as possible, and don’t worry! Your free trial won’t start until you’re in and riding.

 


(Dave Musselwhite (M70/ZBR/TeamZF/PACK/RO) #3

Hi Thomas,

I’ve had this problem with my Macbook Pro ( El Capitan ) since day one.  Some days it works fine on other days it takes 3 - 5 minute to log on and once on it will lock up completely within 2kms.

I have two trouble tickets open on this and other problems but I have not had any suggestions as to what may be causing it.  I have sent a dozen log files to the support group.

I have 25 days left on my free Strava package and I really want to continue using Zwift after it runs out. But as of now …

 

Dave

 

 


(Thomas Poulter) #4

Hi Lindsay and Dave, 

thanks for your replies.

Lindsay - the full error log has been included in the ticket i raised for this issue.  I thought i’d raise it on the forum too in the hope that someone might be able to point me to a resolution more quickly.

from Dave’s response it doesn’t look too promising.  i’m using El Capitan 10.11.2, its fully patched up to date with no outstanding graphics driver updates or anything. i haven’t been able to get beyond the first 10 second of the Zwift app starting up before it crashes.

I work in IT and can’t think of anything else to try and I am thinking that there must be a bug in the Zwift app for Mac.

I really wanted to try using Zwift but i don’t want to have to dig out an old windows laptop to use it in my mini-gym (i.e. shed!).

anyone else being affected by it crashing on Mac?

thanks

Tom

 

 

 


(Thomas Poulter) #5

(Dave Musselwhite (M70/ZBR/TeamZF/PACK/RO) #6

Hi Thomas,

One observation I’ve made is that if I select “Just Watch” the programme will run for hours without any problems.  I can access all menu items, set ups, profile etc with any lockups.

It definitely doesn’t look like a graphics problem to me. 

Regards,

Dave


(Stevie Doyle.scot) #7

Well I was working fine for over 50 days until today,  the zwift app updated itself for the new routes and the app now locks up at times varying from 10 mins, 3 mins and 1 min into a ride.   So I went from having zero issues on My Macbook Pro with zwift to having a totally unreliable app.  I gave up today and jumped over to Bkool just to check the hardware, ant+, internet etc was not the issue. 55 mins on bkool with zero issues so I am left in no doubt the latest update has caused the problem.  

I love zwift and will try again, but not if I only have a short training window. Next time I hope to have several hours so that I have to troubleshoot issues I still have time left to ride at the end.


(S Paciorek *USMES*) #8

Have you attempted to repair disk permissions or first aid if you have el captain.


(... david (aka "setuid")) #9

I can confirm that Zwift fails to run on a brand-new, clean install of El Capitan, but runs flawlessly on Yosemite on the same hardware. 

I took a TimeMachine backup of my Yosemite install “Just In Case™”, then downloaded a fresh DMG of El Capitan, installed that, booted up, then removed EVERY reference to Zwift on the system (~/Library/Application Support/Zwift, ~/Downloads/Zwift, ~/Documents/Zwift) and securely emptied the trash, then re-downloaded a fresh, clean installer from http://www.zwift.com/download/mac and installed it clean. Seconds after the app is installed when I get the dialog that pops up saying “Downloading…” it crashes. Immediately. 

Here’s the relevant excerpt from the crash: 

Process: ZwiftLauncher-OSX [5945]
Path: /Applications/Zwift.app/Contents/MacOS/ZwiftLauncher-OSX
Identifier: com.zwift.ZwiftLauncher
Version: 1.0 (11)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: ZwiftLauncher-OSX [5945]
User ID: 501

Date/Time: 2016-03-17 00:13:53.507 -0400
OS Version: Mac OS X 10.11.3 (15D21)
Report Version: 11
Anonymous UUID: 1664758D-5567-2D23-F5E8-08A74D069D49

Time Awake Since Boot: 1800 seconds

System Integrity Protection: disabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
*** __CFTypeCollectionRetain() called with NULL; likely a collection has been corrupted ***


(Baroukh Big-Chief SCC) #10

its shit


(Dave Musselwhite (M70/ZBR/TeamZF/PACK/RO) #11

Not a very constructive statement!

I now have Zwift working well on my Macbook Pro with El Capitan.  It seems my initial problems were due to internet problems with my provider. This has now been fixed and I no longer have any problems.

regards,

 

Dave

 


(Chad Dyer) #12

Just downloaded it and bam as soon as I saw on it crashes.
All I can say is glad I haven’t paid yet. Would love any feedback or help. MacBook Pro Yosemite 10.10.4