Zwift Won't Run on MacOS High Sierrra

Dear all.
I just got an IMac for the first time (always used windows until now)
I have installed Zwift. The problem is when I start the soft. It starts, ask me to log in and then the windows disappears but the music is still here. From that moment the computer doesn’t reply to any command …
If anyone could help me I would be really grateful…

Hi @Adrien_Colson welcome to the Zwift forums.

I’m looking at your session logs on our server, and see the last successful session on January 21 (Windows10).

By any chance, is your iMac running the OSX v10.15 Catalina? Starting with this version of OSX, Apple changed the way permissions work for security reasons. If so, please see this previous thread for the likely solution.

If you’re running an older version of OSX, we can troubleshoot further.


First of all thank you for replying so fast to my request.

Actually I have an older version of Mac OS.

I have MacOS High Sierra and I am not able to upgrade cause the computer is too old (2009)

Other info about my iMac :

2.66ghz Intel core i5

Memory 12Gb

Graphics ATI Radeon HD 4850 512 MB

Waiting for your feedback.


Adrien Colson

In theory, those specs should suffice to run the game (albeit at a lower performance level) despite the computer’s age.

How much free space do you have on your hard drive, as in what percentage of total space? Inadequate hard drive space also has an effect on game performance.


The hard drive in empty, I mean there is more than 500gb free …

Thanks for confirming that hard drive space is not an issue.

I looked through the server logs for your sesssions all the way back to December 1 last year. I’m seeing game sessions mostly on a Windows computer and some on an iPhone.

I see no instances of a MacOS computer logging in, so we’d like to have you send in the log files from that Mac to us so we can see what’s happening on your end.


That’s the problem. I can’t launch the soft on my IMac. The soft start but it stays like in back ground and I can’t access anywhere after that. Like if the soft was working but no visible.

You will not need to have the Zwift game running to send us logs. You’ll locate them using Finder on the instructions I linked.

Whether the applications run correctly or not, they leave behind a history of what happened in those three types of log files. These are stored locally on your computer, and we can use those logs to help us figure out what’s happening.

Would you follow the steps I outlined above and email all of the log files to us?

Ok. Let me check that on the computer.
I will let you know ASAP.

Thank you for your support.


Please find all the file I found in the folder “Logs”

(Attachment Curl_Log.txt is missing)

(Attachment Launcher_log (old 1).txt is missing)

(Attachment Launcher_log (old 2).txt is missing)

(Attachment Launcher_log.txt is missing)

(Attachment Log (old 1).txt is missing)

(Attachment Log (old 2).txt is missing)

(Attachment Log.txt is missing)

Hi I received your email with the log files! I’ll have a look at them now.

Je vois aussi que vous avez une adresse courriel qui termine avec .fr. Dans le cas qu’il sera plus utile ou même pratique pour vous, je vous invite à nous écrire en français à la même adresse ( si vous voudriez. Notre équipe française est toujours prête de vous aider.

Ride On!

Was this resolved? I have the same problems and tried all the steps outlined. Zwift will not launch on Imac (late 2009 mod, 2,66 Ghz, Intel Core i5, 4 GB,
1067 MHz DDDR3, 900gb hd).

Zwift has not been installed on the Mac before (only used on Ipad).

Look forward hearing from you!


I have a similar issue: using a late 2009 iMac: 2.8ghz intel core i7, 16 gb memory, ati Radeon hd 512mb, 1.96tb available on hd.

When I launch zwift, I am able to choose a rider. However once the blue screen opens while the zwift app is launching the system freezes although the music keeps playing. At this point force quit no longer works and I have to manually restart the cpu.

The log files shows that zwift cannot find vertex shader attributes

It’s 2021.


Same issue here! Anyone have any luck getting it to work on their late 2009 iMac with High Sierra?

1 Like

Same issue here.

I’m having the same issue too, has anyone managed to get this to work?

Hi I have same problem! My iMac freezes on the blue screen with swift logo. I’ve tried uninstall and reload but nothing helps.

If you’re running High Sierra, I recommend updating to a newer version of macOS. If your mac is too old for Apple to offer you an update, consider using OpenCore Legacy Patcher to install the latest release. You can find YouTube videos that explain how to do it (Mr Macintosh has some good ones). I’m happy to advise you on how to do it if you need help. I’d be interested to hear if this helps with running Zwift on older macs. Definitely run a backup before attempting.