App launcher crashing with MacOS


Downloaded Zwift onto my iMac and I’ve not been able to launch it. Starts loading from the launcher then quits the app and the launcher goes to ‘not responding’.
Tried removing and re-downloading, allowed access to documents as suggested. Any other ideas??

Hi @Ed_Saunders_3848 welcome to Zwift forums.

MacOS requires that you give apps permissions to access the Documents folder. If you don’t, the app can’t write files to that folder, and this causes it to crash.

See this thread for how to resolve it.

Thanks for getting back to me so quickly

Ive tried that and restarted the computer but its still crashing from launch


Can you provide more information on this iMac? What OS version? Is it a really old 32 bit model? Zwift will not run on 32 bit devices.

Are you seeing any error messages, such as Installer 112 error? If so, see this:

It’s a 2017 4K iMac with a 3GHz i5, 8gb DDR4, and a Radeon Pro 555 2GB

No error messages are coming up at all, it’s just shutting the app and the launcher is not responding.

You didn’t say OS version you’re running, but for a while there, MacOS had some wonky graphics drivers that didn’t play nice, and installing an updated driver resolved them. Would you see if your OS version is one of these?

Sorry it’s OSX Catalina 10.15.4

With Catalina OSX 10.15, you can disregard the graphics driver bit.

If the launcher won’t launch, there are some things known to interfere. Would you have a look if any of those apply in your situation?

And I know this sounds dumb, but have you powered off your computer and rebooted recently? I had this issue happen to me this afternoon on my Windows machine when launcher hung up, and a reboot cleared it right up.

Just tried rebooting it a few times, still having the same issue. Also checked the other known issues and none of them apply…

Just tried it again after a few hours. Still the same result but I actually get a notification telling me its unable to launch the Zwift app, and gives me the option to go to Zwift support


At this point, we’ll need to see the three types of log files that will give us a better idea of when during the launch process this is crashing.

Please see this article to locate your log files. Once you’ve located them, there are three types of logs we want:
LauncherLog.txt (and the ones with numbers in them)
Log.txt (and the ones with numbers in them)

Please attach all of them and email to Please also include the URL of this forum discussion so you don’t have to repeat the same conversation. Thanks

I’ve found the logs but can’t find the ComputerSpecs.txt, its only showing Curl_Log.txt. Do you want this as well?
I’ve also searched my Mac and there aren’t any files under the name of ComputerSpecs.txt

Thanks for all the help by the way, I really appreciate it

My bad - I’m on a Windows PC, curl_log.txt for MacOS!

No worries, I’ll send them over now. Thanks again