Win10 on iMac: Could not find required data files

Hi,

Zwift just won’t start on my iMac running Windows 10. I’ve already tried updating the graphics card driver (directly from AMD and from BootCampDrivers.com) - without succes. Any suggestions? Thanks in advance.

Kind regards,
Kay

ComputerSpecs.pdf (159.4 KB) Launcher_log(old 1).pdf (60.6 KB) Log.pdf (79.7 KB)

Have you installed .Net 3.5?

Is it Windows 10 x64?

Why would you install Windows on a Mac?

I am not going to download and open unknown files.

The log says, Zwift can’t load his files.
I would start there.

Did sth go wrong with installation?
Did you choose a different install path or is it by default different on Win10 as VM on a Mac?

Just run it in MacOS instead of trying to run it in Windows and save yourself a bunch of headaches!

1 Like

I made a clean reinstall now.

I created a new partition for Windows. Downloaded a fresh copy of version 10. Installed it (Bootcamp). Ran a whole bunch of updates. Installed the .net framework. Found new updates an installed them. Finally I downloaded Zwift and made a default installation. Same result: Zwift can’t open its own files. What the heck!

I already tried to run Zwift as an admin and changed the rights of the assets. Zwift still doesn’t start.

One thing I forgot to mention: The copy of Windows is a 64 bit version. On a website I read, Zwift stopped the support of its 32 bit version. However the program is installed in the x86 program files folder.

Try updating to the current released version of Windows 10, or better yet, run Zwift in macOS.

This is actually something we hear about once in a while. Running Zwift on a Mac through a Bootcamped Windows OS isn’t a supported set up. Your best options are to run it as the MacOS version of Zwift, or acquire an actual Windows machine to run it on if you need to run the Windows version for whatever reason.

2 Likes

Bootcamped Windows OS isn’t a supported set up.

Please tell me that’s a joke. Bootcamp isn’t some special OS, hacked setup or virtual/emulation set-up, it’s just a computer running Windows 10 64-bit with drivers for the Mac hardware and is compatible with pretty much everything. I used this for software development so I should know. The log files indicate that it cannot find the appropriate wad files etc when they are clearly there. Zwift goes through the Windows API so it should be completely transparent.

So I’ve come back to Zwift, started my monthly payments and on a 2019 MBP with Bootcamp I get the same message. All graphics drivers are up-to-date (etc) however the logs indicate it simply cannot find the files. This seems to me like either the logs are not indicating the correct problem or there’s some bizarre bug somewhere. I assume this is a 32-bit app because it installs in the x86 folder on 64-bit Windows 10.

Seems you have a bug in your wad file loader. The logs spew out stuff like:

[14:56:31] Log Time: 14:56:31 2020-01-04
[14:56:31] Game Version: 1.0.44368
[14:56:31] Config: Shipping
[14:56:31] Launcher Version : 1.0.50
[14:56:31] Loading WAD file ‘assets/global.wad’ with file.
[14:56:31] ERROR: Could not load wad file: assets/global.wad
[14:56:31] Loading WAD file ‘assets/environment/ground/textures.wad’ with file.
[14:56:31] ERROR: Could not load wad file: assets/environment/ground/textures.wad
[14:56:31] Loading WAD file ‘assets/UI/WhiteOrangeTheme/WhiteOrangeTheme.wad’ with file.
[14:56:31] ERROR: Could not load wad file: assets/UI/WhiteOrangeTheme/WhiteOrangeTheme.wad
[14:56:31] Loading WAD file ‘assets/UI/minimap/minimap.wad’ with file.
[14:56:31] ERROR: Could not load wad file: assets/UI/minimap/minimap.wad
[14:56:31] Loading WAD file ‘assets/UI/WhiteOrangeTheme/Scotty/Scotty.wad’ with file.
[14:56:31] ERROR: Could not load wad file: assets/UI/WhiteOrangeTheme/Scotty/Scotty.wad
[14:56:31] Successful audio init!
[14:56:31] Loaded audio banks
[14:56:31] Initializing graphics window of size 0 x 0
[14:56:31] Attached Monitors:

I couldn’t laugh at all.

To be clear, I was responding to the “support” post above. There’s simply no good reason why it shouldn’t work on “bootcamp” as it’s not any kind of emulation or virtual OS set-up just another PC with the appropriate mac drivers. :frowning:

Hi all,

did you already find a solution to this problem? I’m also having this error on my bootcamped MBP '17. Keeps on saying can’t find the WAD files. Is there any script that makes Zwift look in a different folder, since the files are actually on my computer.

I have this exact same problem on a 2017 retina macbook pro. I’ve attached a debugger to the ZwiftApp.exe and the messagebox is coming from a call to AK::StreamMgr::SetFileLocationResolver, specifically its being raised by the AK::WriteBytesMem::SetCount (+ 0x1ce850).

So it looks like the problem is coming from AudioKinetic …

Any fixes would be massively appreciated as I hate OS X :rofl: