Zwift won't run on Windows 10 after update


(Eric Welch) #1

I’ve previously run Zwift on this machine, but now can’t get past the login and banners. I’ve uninstalled the app, then re-installed (and successfully gotten the update I believe), but still no luck.

Again, I am asked to log in, then the banners show for just a bit, then disappear. No Zwift running after that - although the smart icon is still in the lower right of the screen.

Please let me know if I can provide any files, etc. Thank you,

Eric Welch

 


(Eric C. (Zwift HQ)) #2

Is your computer on the edge of the minimum requirements for Zwift or a bit on the older end of the spectrum (4+ years)?


(Eric Welch) #3

I don’t believe so. It’s been running just fine for the past 6 months. It’s a MacBook Pro i7 with 8 GB of RAM.

I believe it could be related to video drivers perhaps? Any ideas there? 

Thanks.


(Yvan Poulin) #4

Why running it in Windows vs natively in OS X?


(Eric C. (Zwift HQ)) #5

At this point, since it’s running Bootcamp(?), I am going to assume video drivers. Can you install Windows-based video drivers now that the hardware is, pretty much, the same? Or does Bootcamp still make you use Apple-specific ones?


(Eric Welch) #6

I think a Windows Update re-installed drivers or something. After some searching on the apple support sites, I was able to find Bootcamp drivers and re-install. Seems to be working fine now, but that was a pain (on the Windows/Mac side, not the Zwift side). 

 

Thanks for your help Eric C.


(Michael Collins Bicycleattorney.com) #7

I see this issue just about every time the game updates. Reinstalling usually fixes it. Running Win 10 on a Surface Pro 3. All drivers are up to date.


(Michael Collins Bicycleattorney.com) #8

What solved it today was a restart of the machine followed by another small update of Zwift (20 secs). Maybe something with there being multiple updates queued?