Zwift won't install on macOS Monterey BETA v12.3 [February 2022] [SOLVED]

Mac update doesn’t want to work. Have attempted several times now.
iPadOS update fine.
1Gb fibre to the home.

2 Likes

@KevinL
Are you using a beta build of macOS Monterey by any chance?

2 Likes

12.3 Developer Beta 2, yes
I have updated another Mac on 12.2.1 and that looks all good

1 Like

@KevinL
I’ve spit this conversation off to its own thread and pinned it so other macOS beta testers can find it more easily.

This bug appears to be specific to Monterey beta 12.3 users. We’re working on a fix and hope to have this patched as soon as possible.

2 Likes

Same here. ■■■ dangit

what’s the timeline on bringing this product back to life

having this same problem, I hope there is a solution soon! using my iPad for now instead

Having the same issues here.

Same issue here. Currently downloading app on to my wife’s work iPad without her knowledge so i get my ride in before she returns. zwift stealth

Same problem here but on Big Sur

Same problem. MacOS Monterey 12.2.1. Can’t pass through the loading screen. It just won’t start and keep loading.
Contacted the help centre and they told that “Monterey is not yet supported now”. Wow
And what a pain it is to use an iphone app for Zwift should I say. Hope they fix it soon.

Yep, hit with this bug as well today. Let’s hope it’s an easy fix.

It has been working fine on Monterey until this latest zwift update.

Same error for me. All was fine until the latest macOS Monterey beta and Zwift update.

same error here. I re-downloaded a few times before giving up.

I had the same problem running Monterey 12.2.1.
I turned off my VPN and it was able to complete the update. Hope that helps someone.

Same problem :frowning:

Hopefully this gets resolved soon with a ZRL race later today.

Is there a way to launch Zwift and bypass the update?

Same here