Zwift won't adjust power and terrain after latest Wahoo KICKR firmware v4.21

Hello! Can you help me downgrade my software? The app won’t let me do it. I clicked on the icon 10x and no screen popped up to switch updates. Any help would mean the world.

Hi, you have to tap very fast on the icon. Give that a shot and let me know if that works.

Hi, experienced this same issue after recently updating to 4.2.3. Could not work out what was wrong until I read this forum. Have now rolled back to 4.1.2 and all seems ok. Thanks for posting rollback steps.

No problem. I am happy that it is helping others who are experiencing the same problem. I hope that Zwift and Wahoo get together to resolve this asap.

GP Lama recently posted a video about Zwift and Bluetooth problems. He did a total uninstallation of all C++ Redistributables as well as Zwift, rebooted and only installed the latest C++ redistributables (2015-2019) and fresh install of Zwift. Obviously this only works in Windows but might be worth a try. I prefer cycling outdoors at the moments so tests have to wait for colder weather…

So this is still broken 6 months later?

1 Like

It is for me.

I’m on the latest firmware using ATV 4K on the latest iOS for the both the platform & OS and I’m seeing this issue intermittently. Only way of rectifying is to restart everything which is really frustrating.

Rolled back the firmware on Kickr to see how that goes.

Yes it is for me……. They seem to be ignoring this issue, which seems a really big one compared to issues that they are fixing.

Is this a ZWIFT or Wahoo issue. My Kickr worked fine until I uploaded the new Wahoo firmware. In the past when my Kickr always worked well, the blue LED always flickered. Now, the blue LED is always solid. Whenever it was solid in the past, it meant trouble. Has anyone else noticed this?

Blue LED:

  • Blinks once per second when disconnected and advertising Bluetooth
  • Solid when connected via Bluetooth, blinks quickly during information transfers
  • Flashes quickly when connecting to a device via Bluetooth

So, if blue LED is solid, and it’s not Zwift that holds that connection, it will mean problems. So either power-cycle the trainer (it will drop all current connections) OR shortly disable Bluetooth from the phone (or other device) that may be holding the connection. I noticed that only closing the Wahoo App on Android still left the Bluetooth connection going and the blue LED solid.

I have now completed two Custom Workouts without ANY problems. Setup:

  • Kickr v5 firmware 4.2.3
  • Windows 10 with updated Zwift (updated itself so not a new installation)
  • Only the latest C++ redistributables (as described above)
  • All connections via Bluetooth (no ANT+ dongle plugged in)

I have yet to try a free ride but looks good so far…

I’ve had my Kickr not sure what model but new Jan 2020 never done any firmware updates until this Wednesday 25th August 2021 and I’ve spent the last 3 days no training Kickr and Apple TV not connected and as people have mentioned Erg mode randomly coming on and off and KICKR getting so hard couldn’t even turn the pedals out of the saddle. After speaking to Wahoo abs doing all there tests it didn’t get resolved. Thanks so much for all the comments and advice on down grading the firmware … that 10 tap thing actually worked well I might have tapped 20times or more. But at least it worked. Down graded the firmware and I’m. Back in the room. Will never do that again caused so much stress. Why could Wahoo just advise this instead of all the calls emails and me waiting around for hours in my cycling gear ready to try something new. I’m clam here but I can tell you been as bad as moving house stress wise the last 3 days no training and a lot of anger even resulted to a few G&Ts last night … I wonder if they will ever fix whatever they have done that’s messed up the link . Thanks everyone for all the advice :+1:

I’m also having the gradient issues running Kickr Core with Apple TV via Bluetooth. The problem seems to be getting worse and some routes are not rideable. I have tried power on/offs, app closes, spin downs and every other conceivable fix.

After trying the firmware revert on the Kicker Core the versions are different to those listed above for the Kicker. I reverted to the only available option and found that cadence no longer displayed in Zwift so I had to go back to the latest version. If anyone has found a solution for the Core I would love to hear it. Otherwise I will look at trying an ANT dongle with a PC. Incredibly frustrating given neither the core nor the Zwift subscription are exactly cheap and the lag completely ruins the experience.

1 Like

I have switched to Rouvy as well. My KickrV responds exactly as it should in Rouvy. I switched to do a workout in Zwift and resistance changes about 30 to 40 seconds later than expected.

Hi All.

I am having the same issue with my Kickr, however, it’s the 2018 model so firmware versions are different to the V5 model.

Any ideas which firmware I should roll back to and if this would even work on the 2018 model?

Thanks :pray:

Hi Graeme,

Just out of curiosity, what device (Mac, Windows…) and wireless technology (ANT or Bluetooth) are you using?

Bluetooth and via an iPhone and windows laptop, same issue on both. I’ve read on the forums that a recent firmware update to the Kickrs to include Bluetooth FTMS may be the issue so will try and revert the firmware to an earlier version.

Ok, reason I’m asking is because I was able (thus far at least) to get my Kickr v5 to work with the newest firmware following Shane Miller / GPLama’s youtube video (Lama LIVE: Lama Lab Testing // Zwift BLE Sensor Pairing Issue Resolved…?) about removing all C++ redistributables and reinstalling only the newest one…

Might be worth a try - it’s not the first time one thing fixes another as well.

Hey all, is this still a problem for others…or just me?? I got my Kickr 5 about 4 weeks ago and connected to Zwift via BLE to iPAD. I upgraded all firmware as you’re meant to do when taking things out of the box so am running v4.2.3 on the Kickr. For the first 2-3 weeks i was running on iPAD and had no issues. Decided to upgrade to ATV and dedicated TV for Zwifting and first 6 or so rides were awesome, then BAM…the resistance is all over the place. can’t turn the pedals on -8% gradient and able to freely pedal on +10% gradient…seems to be about a 90sec lag and seems to get worse. I’ve power cycled etc etc, had 1 good ride and got excited but its back again. I’ve turned off BLE on the iPAD i was using so its not that stl connected.

When i open Zwift all the devices connect ok with the green tick via BLE direct to the ATC. Then If i try to do a spin down calibration in Zwift, via the spanner icon, it fails as the connection times out.

The first time this issue occurred, I also noticed that i had no sound or music coming from the Zwift session…i thought it might be a TV issue. Since then i have had sound/music all good but still the resistance issue.

I’m happy to look at rolling back the version on the Wahoo, but this seems to have been going on for ages! So interested if others are still having the issue on Wahoo v4.2.3??

Would be good to get a fix for this if its still widespread.
Thanks!

for me: kickr v5, windows 10, BLE connection

i rolled back the firmware about a year ago and am still rolled back. there was no question that a change to the kickr firmware conflicted with zwift, and rolling it back fixed it. as far as i can tell, nothing has changed on that front from either zwift or wahoo. it seems like this is a breaking change that wahoo made that zwift hasn’t prioritized adopting. it’s definitely strange – not clear which company is the one dropping the ball.

for spindown – kickr v5 doesn’t need to spin down – it is the first kickr to auto calibrate, and my experience is that the zwift spindown function doesn’t work for it anyway (same behavior, it just sort of times out)

you can (and should if needed) use the wahoo app to do a spindown, but the auto calibrate behavior will throw away any changes the spindown makes anyway.