Zwift (Windows 11) minimizing during ride [1.40]

Since the newest app update I have been experiencing random exits from the app to the windows desktop.

The app is still running in the background and getting the mouse and clicking on the zwift icon in the taskbar restores the app. Timing seems random but in todays ride two of the events happened while finishing a segment and seeing the confetti on screen

I have tried leaving the cursor mid screen to make sure it wasn’t an issue with the mouse triggering a click.

Acer Swift Laptop with
Windows 11 Pro 10.0.22621
Intel Core i7-1065G7
16GB Ram
Running a Nvidia RTX 2060 Super with 8GB VRam (external desktop GPU in thunderbolt dock)
App at 1440p Ultra on a 1080p TV.

Please let me know if I can provide additional info.

Some additional info that might help.

  • Are you running in a window or full screen
  • Was there another process running in Windows (perhaps a Windows update, or a notification)?

I always run Zwift full screen and ensure Windows updates are completed before I load Zwift.

Full Screen and no significant tasks in the background. I couldn’t see any other app that was obviously stealing focus.

I have seen that if I do something on the laptops monitor zwift minimizes on the tv (as second monitor by hdmi direct to the egpu). So having another app take focus does trigger a similar behaviour I just don’t think that is happening here… I’m not sure if there is a way to track focus stealing?

Unfortunately this has been happening every ride since the last update.

This is usually related to something else on the PC grabbing focus. The solution is usually to either figure out what that thing is, or use Borderless Gaming to run in windowed mode with a full screen view.

1 Like

Hi @Brad_Coe

Shuji at Zwift HQ here. I peeked at your server logs and confirmed that your last ride on Muckle Yin was done on game version 1.40, and not 1.41 which went live earlier in the day during our phased rollout.

This is the first report of this behavior that I’ve seen on 1.40 (or any PC version more broadly). This sounds like it might be specific to your machine and as others have suggested - perhaps some other app is stealing focus. This isn’t a common symptom with known root causes within the Zwift app.

If you try some of the other suggestions and it’s not evident what might be competing with Zwift for system attention - please contact my Support colleagues so we can help you one-on-one and see if anything within Zwift might be captured in your game logs.

1 Like


I found a few tools that track Windows focus and I’ll give those a test (and the bordeless suggestion above) to see if they point at an offending applicaiton. I’ll update here if I identify a non-zwift offender. (My zwift suspicions were raised by the seeming, and admittedly maybe random correlation with in game events)


1 Like

This has been happening to me too. I’m running Windows 10. Everything else closed in the background. Has happened twice in the past week, tends to be earlier in the session. It’s not too disruptive but since I saw this posted may as well share my recent experience

I have experienced this too, with previous versions and still with 1.41. The game switches from full screen to minimized, both Windows 10 and 11, using single or multiple screens. If the game is full screen on the secondary (extended) screen and I click anything on the primary screen, the game minimizes on the secondary screen.

This is normal behaviour for most games. That is why streamers/gamers use windowed mode and borderless gaming app.

Totally normal behaviour that.

It’s possible to log processes that grab focus. It doesn’t have to be an application that you launched - it could be some random background process which you are not aware is running.

Thank you, I will run this for my next ride

Right, the other game I use in full screen (GTA 5) has the borderless window mode built in, that’s why I never needed the third party app.

1 Like

Thanks, I tried the focus app but instead of showing the app grabbing focus it seems to avoid it, Zwift didn’t minimize this time (usually happens once). Will keep using it in my next rides, not that it bothers me too much, because after I return to Zwift it stays stable, but just to find the app grabbing focus.

Today Zwift minimized while running full screen on primary screen (no secondary screen attached) and the focus app didn’t show anything, the next app to have focus after ZwiftApp.exe was focus.exe itself.

1 Like

It’s starting to smell like a bug

One thing I noticed in the log when the app minimizes:

[9:30:51] FB resize: 0 x 0
[9:30:51] resize: 1 x 1

Sorry I forgot to reply here. My issue was indeed another app stealing focus. It just happened to update to a buggy foxus stealing version on the same day as a zwift update to keep things interesting…