Zwift sometimes minimizes after a few minutes

There have been a few threads in the archives regarding this, but they where years old. I experienced it lately on my freshly installed laptop and on the system of my wife as well.

Doesn’t happen all the time, but Zwift minimizes to the taskbar all of a sudden and has to be reopened. It seems to happen randomly, since there is no specific behavior behind which might trigger this problem. Definitely don’t pushing any buttons on the keyboard or mouse.

Running zwift in full screen mode with the latest Win10 21H2. Zwift with latest launcher and game app.

the same problem

To clarify on what you’re describing here; is it simply minimizing so you’re able to expand it back to full screen without losing any ride progress? Or do you have to open Zwift up again? Also, have you noticed any trends for when it happens more often such as specific worlds or in large groups?

Hi Lucas,

Zwift just minimizes to the taskbar. It’s still running and I can expand it back to full screen, continue my ride and save without any other interference. It just happens once during a session.

One thing that might be a trend is that it usually happens in the first ~0-15 minutes of the session. My wife had it in Watopia (while running) and I experienced it in London (cycling). Group size didn’t matter.

This is ‘normal’ behaviour when using multiple displays (and Zwift in full screen mode on one of them) for some reason, but if you’re only using one then it shouldn’t be the case. Something on your system is momentarily taking focus off Zwift which makes it minimise to the system tray. The same thing happens if you hit the Start key, for example. If it’s not user input then it must be software. Antivirus perhaps? Anyway on clean builds of Windows 10 this doesn’t occur, so have a look at what you have installed.

The alternative solution is to use Zwift in windowed mode. If you don’t like how that looks, then a free app called Borderless Gaming can make it look full screen whilst remaining windowed. Personally I find the performance significantly less smooth in windowed mode, but YMMV.

I forgot to mention that I use Zwift on a laptop with a TV connected via HDMI to it. Lid of the Laptop is closed so it’s basically the main window. My wife uses the same laptop model, mine was freshly set up, hers is a few months older.

I did disable the Windows XBOX Game Console App which wanted to record the Session, maybe this App interfered with Zwift. ZwiftApp and Launcher are excluded from AntiVirus Detection Engine.

Anyway, I’ll keep an eye to that and see if I can find a process which triggers this. Personally, I like how it looks in Full Screen mode, it’s more immersive. I have a strong suspicion towards the Logitech Software which enables a lot of addon-Features for the mouse like gestures etc.

Yeah that sounds like a possibility. Might be worth messing about with the Focus Assist settings, just in case it’s something that Windows can suppress for you. I’ve never needed to do this myself, but I run as little installed on my Zwift PC as possible. Also make sure the laptop lid being closed is actually disabling the screen (making the TV the only display) rather than the backlight just going off.

This has also happened to me before when running in Zwift using my laptop. But, it happens rarely, and always seemed to occur in Full Screen mode.

I found it somewhat annoying, so I switched to using Windowed mode instead, and that seems to work better – no more unexpected minimizing.

Also, this issue doesn’t happen on my newer laptop, but did occur on my older laptop, so it was probably some other app or service running the background that was causing Zwift to minimize, but I’ve never figured out what.

+1, for me roughly 30/40mins in it minimizes to the taskbar. I believe it started around mid Jan 2022 :frowning: sounds like I will give windows mode a go. I am glad I am not alone.

nvidia GTX 1080, Windows 10 Version 21H2

1 Like

Sounds like a plan, @Michael_Cives

This is one of those issues that’s been around for a long while, and it’s very hard to pinpoint the cause. As mentioned, the most likely culprit would seem to be some app or service running in the background that’s causing Zwift to minimize when in full screen mode. While I’m unable to figure out what’s causing the issue, using Windowed mode is the suggested workaround.

If you’re not familiar with where to locate the Screen Mode settings in Zwift, see this related article for more info. Thanks!

What happens is some other program in the background take focus and minimize what ever is on the screen.

You can use a program called borderlessgaming to make windowed mode look like full screen, it is very helpful especially if you have multiple monitors.