Zwift minimizes to taskbar after 15 minutes

I am running Zwift on an Alienware Alpha, upgraded to Windows10, and full screen mode.  Religiously, after 15 minutes Zwift is minimize to the taskbar.  The program keeps running, but I have to reselect Zwift to get back to the full screen mode.  I have changed all the sleep settings without resolve.  After a lot of troubleshooting, I now see that some Windows program takes control for a couple of seconds.  I have conducted a complete virus and spyware scan of the machine and it is clean.   I figure that there is some windows app that is set to 15 minute periodicity, but I can not find the culprit to correct - help!!!

I have the exact same problem and have had it since I started using Zwift in October. It always happens at least once per ride, it’s not always 15 minutes for me, it can be 2 minutes after I start or 30 minutes, but you can guarantee it’ll happen once.

Just as you describe it’s just like someone pushing the minimise button and Zwift goes down into the taskbar, so I have to go and click on the icon and everything comes back.

Similar setup to you, ordinary PC with Windows 10 running in full screen.

I had this happen during a ride, and the next day I helpfully uninstalled AlienRespawn as I think this may be the culprit, as that unfortunate software’s reminder messages appear to reduce Zwift to application-in-background status.

Thanks Matt.  I know that AlienRespawn is running, so I will try and shutdown and post the results.

Unistalled Alienware Respawn and Zwift no longer minimizes.  I still need to put some more miles/time on Zwift to confirm it was the problem.

I’m not running Alienware, so it’s not that.

Having said that giving a lie to what I said above, I did an hour in Richmond this morning without issue.

I have the same issue.  I’ve done quite a bit of research on this and it’s a generic Windows 10 problem.  There appears to be no quick solution to it.  I get the problem with any full screen application (not just Zwift) and this effects gamers especially.  For me it’s after a random time, sometimes 15 minutes, but other times I can ride for over an hour with no issue.

For me the issue is very bad because I have my PC in the office up some stairs.  so when it happens I have to stop the ride, get off the bike, walk upstairs, reset, back down, start up.

As a result of this I now run Zwift in a window.  It’s not ideal and detracts from the experience, but it’s the best solution I have.

PS.  I run a custom 3XS PC and have reinstalled Windows 10 as a fresh install to check that the previous upgrade from 8.1 wasn’t causing the issue.

It would be interesting to see what Graphics cards and drivers people with this issue have.  I’m using an Nvidia GTX 680 with the latest drivers.

This could potentially be linked to Nvidia drivers for example.

Have you tried to chance the priority of the program? (Rightclick the icon, and mess with the options).

I’m happy and sad to see others are having the same issue. I’ve had this happen as quickly as two minutes, but it always happens by 15 minutes. I’m running windows 10, I’ve checked all my settings and don’t see anything wrong. I have been able to watch movies, sports, and Hulu without any issues.

What’s next…

This happened to me 1 year ago, run you pc in the toolbar mode ( that’s where you would see the icons on the strip at the bottom) , now I have no issues.

Don’t run in full screen mode !


I’ve been running it from the tool bar. Not sure how to turn off full screen mode. I’ve been thinking of running in Administrator mode.

It’s not tool bar mode but Windowed Mode. You select that from the Settings menu in Zwift itself.

If you want you can download an app called Borderless Gling which makes Windowed Mode full screen

Thank you, I’ll give it a try.

OK.  I feel rather stupid. Same problem. 

But I don’t see where you find “settings in Zwift itself.”  When I click on the zwift on the toolbar I go straight into the full screen mode.  Do you find this settings menu from going to



I am re-entering this thread as the originator.  I corrected the problem by an uninstall and reinstall of Zwift and have had no issues for quite awhile,  until recently, when it started happening again - randomly.  Fortunately, it usually happens when I first start riding and it only occurs once.  When this happens, I am running Zwift from a dedicated Alienware Alpha running Windows 10 (big mistake).  Over the holidays, I used my laptop with Windows 8 (company says do not upgrade to 10) and didn’t have a single occurrence.  I believe that this issue is a Windows 10 issue where it is running diagnostics in the background and sending it to MS, which takes priority over Zwift and can no longer be disabled in W10.  So, I feel this is a Windows issue and not Zwift.

FYI, to exit full screen mode, sign in and then go to menu and settings, from there you will see the screen mode, either Full or Windowed.

From in the game while you’re riding stop riding and click the orange MENU button at the bottom left. Then click settings. Then click Windowed Mode. Then exit and restart.

Thank you all for the help.
I’ve opened Zwift, then hit the menu while in a ride. Then open settings, that’s where I found full screen mode. Turned it off and I’ve been running in Administrative mode. No more problems!
Thanks again for all the help.