Zwift update --> straight into 'No signal'

I incurred a Zwift update this morning and as a result, I can no longer get any read outs from the companion app.

If you can’t be bothered to read the whole post, then just try repairing your trainer.

It starts as it used to, everything seems nominal. I selected a Tri academy 2020 workout (VO2 max short intervals) and I started pedaling. Everything seems fine for 2-3 seconds and then the companion app just stops reading the power output from the my Elite Tuo trainer. This results in Zwift reporting that it sees devices as ‘Connected’ but there is apparently ‘No signal’. Which matches what the companion app also shows.

I am running this on a Windows 7 computer with a wired connection to my home network. Until a few days ago, I was able to use Zwift by pairing with the companion app.

My Zwift version is 1.0.60640 and my companion app is 3.21.0 (1110) running on a Samsung S8 with Android 9. My phone connects over wifi to the same network, i.e. the win 7 computer and the phone are on the same network, Not really sure this is relevant at all since, like I said, this exact same setup worked a few days ago. The only thing that really changed was that Zwift pushed an update.

I also just paid my subscription and find this rather frustrating. I keep fighting off the notion of thinking – wait, I didn’t pay for this sh*t.

I have tried all of the following:

  1. restarted the windows 7 computer
  2. restarted my S8
  3. restarted Zwift a few times
  4. restarted the companion app a few times
  5. started the ride on zwift, killed the companion app during the ride, started it again
  6. unplugged the Elite Tuo during the ride to force the companion app to find it during the ride

None of the above did anything. this point, I am going like… WTF???

Then, I finally tried unpairing my Tuo from zwift and I let the companion app find it again. AND THAT FINALLY WORKED.

I am seriously underwhelmed that Zwift didn’t put up any notification on their app that simply says: If you experience a No Signal you may want to try repairing you devices. It’s really not rocket science. Do they even have product managers that look at their user experiences?

I also realize that this may be a noob problem and part of learning to ‘love’ Zwift, but it was frustrating AF and took all of my morning.

Finally, if you stuck to here, thanks for reading and sorry I vented a bit.


Are you using bluetooth or ANT+ to connect to your sensors?

I am using neither. Bluetooth doesn’t work well on Windows 7. I tried reinstalling a slew of microsoft distributable C++ runtime libraries, but that didn’t really change anything. It seems bluetooth support on Windows 7 is just broken without any signs whatsoever of addressing this problem.
I do have an ANT+ dongle plugged into one the USB ports on the Windows 7 computer. The dongle ends up being about 5 meters (15 feet give or take) from the Tuo smart trainer and cannot even pick it up. I read about people using a USB extension cord to bring the dongle closer to the sensors, but I find this defeats the purpose. We might as well go back to being completely wired at that point.

To answer your question, I have the Tuo and bike sensors paired through the Zwift companion app.

I’m glad I’m not the only one having a similar issue today. I use ATV, when I started Zwift up today it was acting up. Saw there was an update so did that. Continued to act funny after opening with the update. Ended up having to re-pair my Kickr a few times, unplug it, kick it around, throw holy water onto it. It mysteriously started working fine after that.

I thought a couple of things were going on. 1. My idiot neighbor was hooking up to my Kickr via BT to listen to their crap music. A few months ago they kept hooking up to my entertainment room’s speaker via BT, so in the middle of the night we’d hear music, and since they couldn’t hear it, they would blast the volume. Couldn’t figure this out since their house is 50 feet from our house, so I’d assume some other BT speaker would be in range. 2. Then I thought my wife broke my Kickr. She’s one of those damn Cross Fitters, and since she’s been working out in our home gym during the pandemic, I thought she dropped a dumbbell on my Kickr. I cursed her out under my breath, can’t have her hear me since my spindly biker arms are not match for her power lifter arms, she can honestly beat me up.

Still, you have to pair your devices by 1 of the 2 protocols - Bluetooth or Ant +.
Most phones have bluetooth and many will have Ant+.
If your not sure of how you are connecting, then this might be a source of your problem.
Blue tooth can only connect to 1 device and can be prone to interference.
It would be good for you to know your system very well in order to eliminate possible issues.
I don’t know if Windows 7 is a problem or not.
I think it’s pretty old and no longer supported but I may be wrong.

I know it is very frustrating but try to remember, everyday tens of thousands of people Zwift everyday.
When I was Zwifting, there were almost 9,000 at the same time.

Most problems are related to a local issue.
Older software may not work with new updates.
Firmware may need up dated.

Hahaha… thanks for sharing. I had a chuckle reading about your neighbor and you cross fit better half.
Re: actual zwift issue, yeah it’s kinda trying somedays to just be able to get on for a session. Glad you finally got it to work. Must have been the holy water :wink:


My connections are (were) not the issue. The zwift companion connects the sensors and smart trainer over BLE. I thought that was a given – didn’t even know some phones supported Ant+. And the phone was literally 2 feet above both sensors and my Tuo. So I’d be hard pressed to imagine interference there.

My setup was A-OK, before today’s update that is. It worked before and it didn’t anymore after the update. Until, like I explained, I unpaired and pair again my devices.

So far as 10000 riders being on zwift at the same time… good for zwift. But it changes the user experience and frustration very little, if that.

Had the same issue here. The companion app failed to connect to my HRM. Connected but no signal.

Previously all setup is working well. I’m using Apple TV and since Apple TV has a limitation to connect more than 2 BLE, I used the companion app to connect to my HRM, Trainer, and Cadence sensor.

Does anyone experience the same issues after the new update? Please share, thanks.

At the risk of stating the obvious… have tried unpairing your HRM in zwift and the letting your companion app find it again to repair?

Nenad, I’m sorry. Let me start over.
I don’t want to be antagonistic.
Perhaps you can download Zwift, the game, to your phone and see if that will allow you to get on.
I’m not sure you will be able to use the Companion app at the same time.
Zwift on a phone is a battery drain.
The screen is small but it might help you isolate your new issue.
Others may be able to answer if you need to reinstall the game on your computer.
Good luck.

Hi @RA_26,

Yep. Same problem. My Garmin Dual HRM stopped working after the update at the end of October. It pairs and then shows “no signal” when I use the companion app. If I don’t use the companion app then it pairs and the signal is received just fine. This means that I can have my Kickr Snap with either cadence or HRM. As a workaround I have been monitoring my HR on my Garmin Edge.

Just over the weekend I ordered a 4iiii Viiiiva HRM in the hope that it will combine HR and cadence on one of the two BT signals and then I have the trainer on the other. It just now dawns on me to wonder whether that means that I won’t be able to use the companion app anymore for ride ons and photos and stuff. Sigh. I guess I’ll see.

And here’s a link to a long thread about the “no signal” issue if you are interested:

Good luck!

1 Like

Tim … mate, don’t be sorry. You were also not being antagonistic. To be antagonistic, you’d first have to offer some valuable, but opposing perhaps, point of view.

Maybe you missed the part from the original post where I stated in all caps and in bold that I figured what finally worked? Or maybe you missed the part of the post where it’s obvious that the latest zwift update caused problems to keep using already paired devices? Or maybe you don’t really understand that the app on a windows computer may work with the companion app but that the phone app doesn’t really need the companion app as the zwift phone app already uses the phone’s BLE connection and hence doesn’t need the companion?

Finally, and I find this quite intriguing – if you think others may have an answer that you don’t, then what’s the point of replying in the first place mate?

All of that said, I recognize your good intention and thank you for wishing me good luck. Not sure I’ll need it (hint: once again, I already figured the problem).