Zwift Update Causing Calibration Problems - Jan 25, 2023

To tee up the frequency with which I use Zwift and/or a smart trainer, the wife and I are usually on 4-5 days a week for about half of the year during the off-season, or during inclement weather from Spring-Fall. We’ve been using Zwift (and at times Trainer Road) with a Wahoo Kickr Snap for 3 years now. We always do a calibration right away (because we don’t always have 10 minutes to warm up the trainer before the calibration like most people I’m sure), and occasionally experience issues with the trainer not calibrating correctly, which is usually quickly solvable by rebooting Zwift and power-cycling the trainer a couple-few times collectively.

Last night we went to do a workout, and Zwift forced an update for us both. For reference on which update it may have been, I had ridden two days ago, she had ridden two weeks ago…so must be a brand new update. (Also FWIW I use a Mac and she uses a PC.) We tried the usual power-cycling and rebooting of Zwift a solid 20 times on each of our computers and neither of us could perform a successful calibration. Getting the calibration to hit 23mph required me to get on and eventually push 600w+ for 8-10 second, otherwise it wouldn’t get above 19mph, but then would still fail. However, when I calibrated the trainer with the Wahoo app, it worked perfectly every time with no resistance issues.

I also tried unplugging the trainer (Wahoo Kickr Snap, 2020 model) from the wall, from the power box, and from the trainer, for around a minute to try to give any power supply time to reset, but that didn’t help either. Any amount of disfunction is annoying when considering the investment to use these training tools, but this new update seems to have broken everything and I can’t find any related articles online. Anyone have any ideas or similar troubles after the most recent update?

FWIW (avoiding any other issues presently going on with Zwift), you should ALWAYS use the trainer app to calibrate your trainer, NOT the Zwift app.

1 Like

Zwift won’t calibrate my trainer and I’m unable to ride in-game due to my power values being way off. I attempted calibrating in wahoo and was successful and am seeing correct values in wahoo app for my kickr AND correct values on my quarq power meter.

Zwift insider lists details on this bug as does another form thread

Same problem here. I just did Stage 6 C ride. Its like my bike is in some other mode – it got easier to pedal on the uphill, harder to pedal on the downhill. Afterwards I tried to calibrate and am not strong enough to get it up to speed. But, I don’t think it is a calibration issue. Something is broken

This is happening to me after the 33 update also; Kick does not respond to in-game gradient and my Kickr climb is no longer working.

Probably this problem - Trainer Resistance | Trainer Difficulty too low, Simulation and ERG mode do not adjust resistance [January 2023] - #206

Same here with Cycleops/Saris Hammer H1 / Win10 / ANT+

Yesterday’s ride felt somehow strange, too easy, low resistance.
Hammer’s Control LED normally becomes white when starting a ride, yesterday it was green and blinking all the time, though every sensors where connected.

Tried to callibrate the H1 but callibration failed due to “Timeout!”. A timeout has never happend the last five years.

Did a short test ride on Rouvy and everything was fine there (white LED, resistance, …)

Zwift has a problem, the last update for Win10 is crap. :frowning:


Hi folks,

This calibration issue appears to be a side effect of a known issue around Controllable pairing over ANT+. (thank you @Steve_Hammatt for posting the link). We will be releasing an update to fix the resistance issue later today. Please let us know if you are still having issues after updating.


I am totally blue tooth and my trainer spins down to zero but the Zwift calib screen says 3 MPH. Plus I am accelerating to speed on a bit of an incline. When is the fix coming out?

The Update fixed it for me, H1 working normally again.