Kickr Core issue in Zwift (speed/cadence/power)

Since yesterday the trainer was working perfectly fine, but yesterday I was unable to use it.

I tried zwifting but the trainer would not adjust to the correct resistance. I tried running the calibration in zwift but I couldn’t go above 32kph and would get erratic speed readings. I tired doing the spin down in the wahoo app and it would reach the required 34kph. It would jump in speeds even if I was not pedaling.

I tried on 2 iPhones, 1 iPad, 1 laptop. I uninstalled everything, turned off every single BT device in the house. It does the same wonky thing on all devices. Reaches 32kph, then randomly drops to about 14kph then goes back up to 28-29 and slows down from there (all that after I stopped pedaling).

Any idea?

Cant be empty

Not on the kickr core though, just the brand new V5.

I have a core, and have had no issues with connecting or spindowns. Sounds like your core might have failed, best to open a support ticket with Wahoo. They will likely replace it for you.

1 Like

Oh good call out Mike. I’ll amend my post.

I have an open ticket with them, but they are very slow to answer. It kind of sucks on a 5 months old kickr… not very impressed

Hi, did you get a fix for this? I’ve just experienced the same. KICKR won’t go faster than 32kph (so won’t allow recalibration/spindown) and the power/cadence is way off. Essentially unusable. Any advice would be great, cheers

Hi @Careless_Vespa_DPCC

Welcome to the forum.

Try calibrating using the trainer software. That will be the most accurate way to do it.

Hey sorry, turns out there was no fix. The Kickr died and I had to get a new one under warranty which took about 2 months.

I have now switched over to Saris