Wahoo Kickr Snap


(Kurt Angus RCC) #1

Ok, so there are a lot of people having problems so sorry to add another issue.

I got the Snap about a week ago.

Day 1, I did the spind down as reccommended, and another 10 mins in. Then connected to zwift. At first the resistance seemed too high and I was putting in a lot of effort and going a fair bit slower than on my old Kurt Kinetic Road Machine. Im aware this is a dumb trainer but I ride a lot and I know what feels right for a corresponding speed/effort and it was just wrong.

Day 2, restart. Did an advance spindown, laptop off so no zwift or bluetooth connection. Seemed to be much more accurate, I felt like I was going faster than I should have been, but the power seemed much better. So I did a KISS race and was quite happy that the data was ok over a 30+k race.

Day 3, Did the same thing as day 2 and the calibration is completely wrong. Power and speed are not too bad but now i run out of gears. Its like the readings im getting from the snap dont match the difficulty of the gear im in.

Its driving me insane!!!

So here is what im doing. …

I plug in the Snap, and do an advance spindown calibration through the wahoo fitness app using Bluetooth over iphone6. I keep riding for 10 mins and do another advance calibration.

Then I close the wahoo fitness app, turn off bluetooth. Turn bluetooth back on. Open the laptop, turn on bluetooth so my zwift app can connect to zwift from my iphone 6. Plug in my ant+ for Kickr Snap HR, Speed and Cadence.

Then Ride.

I dont get dropout so thats a positive.

I believe i have the latest firware, this updated when I first turned it on a week ago, however there isnt anywhere I can find online to check this, it just tells you it needs to update.

Is it possible that bluetooth and Ant+ are conflicting because I have laptop Bluetooth on for zwift app?

Can the app work without bluetooth?

The Wahoo utility app and fitness app seemed to give different calibration results… which should I use?

What is the correct procedure for calibration and use with Zwift?

Any help would be much appreciated.

I have asked the guys at Zwift to do everyone a favour and post a comprehensive trouble shooting guide for this but no reply.

Oh also, how often are you supposed to calibrate? This seems to vary with everyone.

My setup: Indoor bike always connected to Snap, i check the tyre pressure every use and then do two full rotations once the snap touches the tyre as in the instructions. After use I release the kickrflywheel from the tyre until the next use.

 

 

 

 

 

 


(Kurt Angus RCC) #2

(Bret Giuliani - RtR) #3

Hi Kurt,

Welcome to the Snap-party.  Reading what you have done so far…it sounds like you had things in pretty good shape on Day 2.

The additional Advanced spin-down is where it looks like things got out of sorts.  Do the Advanced once, then leave it alone.  Have the Snap good and warm first.  Make sure your ambient room temperature is not abnormally high or low.  Make a note of your tire pressure, and check that before every ride.  2 turns past contact on the roller is the spec we’ve all been given.

What is your brake factor result?  That will give some clues.  Something in the 1.5 - 1.8 range is what a lot of people have hit, from my research.  The Advanced spindown is Wahoo’s answer to calibration issues, but there are a lot of physics involved.

Once you have an “acceptable” Advanced spindown, turn off everything but the Wahoo fitness app, and see if your power readings correspond to what your legs tell you (use their ERG mode too).  Then shutdown the Wahoo app.  Reboot your mobile device if necessary.

Make sure your Ant + dongle is right next to the Snap radio.  I have mine within an inch or so.  No issues with dropouts this way, at least for me.

Fire up Zwift, and go for a regular ride in SIM mode.  See how the gradients feel.  Start with the resistance slider in the middle, then move it down incrementally if it fees too hard.

Then test a Zwift ERG mode workout.  This is where I am stuck, and seriously frustrated.  Once resistance picks up to around 200 watts, my brake progressively clamps down, reaching the point that I can’t maintain cadence, then quickly reaching the point that I can’t even turn the pedals.  The only way I can get workouts to function is by disabling ERG mode, and using gears/cadence to maintain power levels.

Ultimately, my power output is still too low in the game, but at least it’s consistent.  I’d get my arse handed to me in a race, though…

I applaud you for asking Zwift for a comprehensive setup/troubleshooting guide for the Snap.  It’s sorely needed.  However, I also believe that there are issues with the Snap that Wahoo just won’t admit publicly…


(Cleve Waterman 69y/o) #4

I have had good luck with erg mode during workouts with my Snap. my FTP is only 215, so i do not go above 200 during a workout very often, but nothing like you describe.

Are you keeping your cadence in the 92 to 94 range.  very important, i think,


(Allan Scott) #5

I have a Kick’r Snap and use it for workouts in ERG mode. I have no issues at all with the trainer matching the target wattage on screen and interval resistance happens within 2-3 seconds after starting a new interval.

The only issue I have is the consistency of watts the kick’r thinks it’s producing. I do a spindown before every ride (after a 10min trainer warmup) and I get readings that match my Stages PM to within 1-2 watts to as much as 15 watts over. So my solution is to watch how closely the Kick’r and stages are matching during the 10 minute warmup, so a spindown, and then adjust my FTP on Zwift accordingly before I start the workout. I know that at least my Kick’r is producing watts that are a true value for the workout.


(Bret Giuliani - RtR) #6

Cleve and Allan,

I’m glad to hear ERG mode works for you.  It certainly doesn’t for me, and I know there are others who have the same issue I do.

Basically, once the wattage reaches a certain threshold (somewhere around 175 watts in my case), the braking pressure continues to increase in a linear fashion, beyond the stated setting.  I know you’re required to keep cadence over 90; I can do that no problem for the workouts when ERG mode is off.

I’ve been talking to Wahoo, and tried everything on their troubleshooting list.  The only thing I haven’t tried is doing the spindowns with Apple devices (none in my household, so would need to borrow one).

 


(. TomH..) #7

Hi all, 

There is an android utility app for those who don’t own an iOS device. 

SNAP ERG mode problem - I’ve just tested it in our Zwift lab and it works fine in here (latest trainer firmware 2.0.28.)  latest Zwift version (1.0.10147) Windows 10. 

Before submitting a ticket with us please try following.

  1. Reinstall Zwift in your PC (hard wired if possible) 
  2. Make sure your SNAP is up to date using Wahoo Utility app
  3. Make sure Zwift is no running on your PC
  4. Restart the SNAP - disconnect - wait 15 seconds - connect
  5. Perform Advanced Spindown using Wahoo Fitness App (Turn off the app completely when done) 
  6. Perform Standard Spindown using  Wahoo Fitness App or Wahoo Utility App (Turn off the the app completely when done)
  7. Launch Zwift go to settings - power display - and set “instant” (It will make it easier for you to tell how much power you’re producing at given moment
  8. Start your workout with ERG mode on. 

ERG mode will be ON as you start the workout, however if you will straggle (very low cadence) or stop pedalling the ERG mode will be disabled (you will get a message on the screen). In order to get ERG mode working again you will need to reach your target power and sustain there for few second. (again - you will get a message on the screen saying it’s back ON)

Wahoo is recommending to do the standard spindown every time you use it for accurate readings. The advanced spindown only needs to be done once when purchased or every there is an error during the regular spindown. 

I hope it all make sense and it will work out for you, feel free to ask for assistance and let us know how it went. 

Ride On!

 

 

 


(Chris Adolf (Fell Swoop)) #8

A little late on this discussion. My ERG mode had similar problems descibed above. Advanced or Standard calibration did not help. I was using the Android App. Finally got my son’s Iphone and performed the Advanced calibration. Amazing it worked.